You are not logged in.

#26 2013-12-06 11:49:52

Sanne
Member
Registered: 2012-03-13
Posts: 86

Re: SWF file weirdness

I just solved this problem in SeaMonkey, should work also in Firefox. I followed these instructions from the MozillaZine Knowledge Base. I don't have the entry from point 2, but found 3. Resetting that enabled drag-drop playing of swf files again.

I quote the essentials here for future reference:

  1. Type about:config into the address bar.

  2. Find the preference browser.download.pluginOverrideTypes and, if it is present, right-click on it and select reset.

  3. Find the preference plugin.disable_full_page_plugin_for_types and, if it is present, right-click on it and select reset.


If our currency were not money but appreciation and acknowledgement for what we do for others, for the community, for the benefit of all, we would have paradise on earth.

Offline

#27 2013-12-06 18:53:32

sqlpython
Member
Registered: 2012-08-20
Posts: 9

Re: SWF file weirdness

Thanks for that one @Sanne.

I had found that in a Google some time ago for my own Situation.
Unfortunately, did not do the trick in my Firefox v. 25 ..
Should work for some depending on the age of the Browser.

As I am from the great unwashed hoards, I lowered my head and did not gaze directly upon the Arch as I posted

Offline

#28 2013-12-06 18:53:47

stewie
Member
Registered: 2009-05-16
Posts: 20

Re: SWF file weirdness

Sanne wrote:

I just solved this problem in SeaMonkey, should work also in Firefox. I followed these instructions from the MozillaZine Knowledge Base. I don't have the entry from point 2, but found 3. Resetting that enabled drag-drop playing of swf files again.

I quote the essentials here for future reference:

  1. Type about:config into the address bar.

  2. Find the preference browser.download.pluginOverrideTypes and, if it is present, right-click on it and select reset.

  3. Find the preference plugin.disable_full_page_plugin_for_types and, if it is present, right-click on it and select reset.

I have tried what you suggested here and also deleted mimeTypes.rdf, but the result is the same. I was
also missing browser.download.pluginOverrideTypes, I'm not sure if that is what is causing the problem though.

I have also restarted firefox and the result is the same, it still wants to download and not run.


We wants it, we needs it. Must have the precious. Arch Linux.

Offline

#29 2013-12-06 22:41:52

Sanne
Member
Registered: 2012-03-13
Posts: 86

Re: SWF file weirdness

sqlpython and stewie, sorry it didn't work for you. I was so glad I could fix it for my case so I thought I'd share it. stewie, I also dont't have browser.download.pluginOverrideTypes, wasn't a problem. Resetting no 3 was enough.

If I were you (both), I probably would read the whole MozillaZine page if you haven't already and hopefully find a solution there, and if not, I'd install SeaMonkey temporarily to see if I could get a positive result. You could also try to rename the Firefox settings directory temporarily and mimick the situation of a fresh install. For SeaMonkey it is in ~/.mozilla/seamonkey.

Just some ideas, not sure if it helps any, sorry.

Last edited by Sanne (2013-12-06 22:43:09)


If our currency were not money but appreciation and acknowledgement for what we do for others, for the community, for the benefit of all, we would have paradise on earth.

Offline

#30 2013-12-07 00:24:24

Nattgew
Member
Registered: 2013-10-09
Posts: 30

Re: SWF file weirdness

sqlpython thanks for your instructions on the standalone player, it's not any better than embedding the files manually but another option is good. At your link for version 11 I only found the plugin. I found the standalone player on this page (they call it a "projector"):
http://www.adobe.com/support/flashplayer/downloads.html
However it seems to need 32-bit support. It may just be easier installing flashplayer-standalone from the AUR, but that wants to install 125 MB of 32-bit libraries. Ugh.

Offline

#31 2013-12-07 18:22:53

r0b0t
Member
From: /tmp
Registered: 2009-05-24
Posts: 357

Re: SWF file weirdness

Guys , the problem here is not with firefox but with the system itself, I think it's related to how the file is handled on the system and we should search on that path hmm

Offline

#32 2013-12-10 10:24:33

kurt
Member
Registered: 2009-09-06
Posts: 91

Re: SWF file weirdness

stewie wrote:
Sanne wrote:

I just solved this problem in SeaMonkey, should work also in Firefox. I followed these instructions from the MozillaZine Knowledge Base. I don't have the entry from point 2, but found 3. Resetting that enabled drag-drop playing of swf files again.

I quote the essentials here for future reference:

  1. Type about:config into the address bar.

  2. Find the preference browser.download.pluginOverrideTypes and, if it is present, right-click on it and select reset.

  3. Find the preference plugin.disable_full_page_plugin_for_types and, if it is present, right-click on it and select reset.

I have tried what you suggested here and also deleted mimeTypes.rdf, but the result is the same. I was
also missing browser.download.pluginOverrideTypes, I'm not sure if that is what is causing the problem though.

I have also restarted firefox and the result is the same, it still wants to download and not run.

I am in the exact same boat.

Firefox 25/KDE4.11.4

Offline

#33 2013-12-11 01:51:08

von
Member
Registered: 2012-11-12
Posts: 6

Re: SWF file weirdness

r0b0t wrote:

Guys , the problem here is not with firefox but with the system itself, I think it's related to how the file is handled on the system and we should search on that path hmm

I agree. I've tried epiphany, chromium and firefox: all three download file:///*.swf urls and open http://*.swf
Also a friend of mine whose system is not contaminated with desktop environments says that he can perfectly run local flash files in his browsers.
Opera, on the other hand, seems to ignore that.

Last edited by von (2013-12-11 01:51:41)

Offline

#34 2014-01-24 19:43:39

kurt
Member
Registered: 2009-09-06
Posts: 91

Re: SWF file weirdness

I've finally tracked down the probem. It is not with firefox but with package:

shared-mime-info-1.2-1-x86_64.pkg.tar.xz

I downgraded to:

shared-mime-info-1.1-1-x86_64.pkg.tar.xz

And now opening local .swf files works again

Offline

#35 2014-01-24 21:50:19

Jodell
Member
Registered: 2009-10-09
Posts: 285

Re: SWF file weirdness

kurt wrote:

I've finally tracked down the probem. It is not with firefox but with package:

shared-mime-info-1.2-1-x86_64.pkg.tar.xz

I downgraded to:

shared-mime-info-1.1-1-x86_64.pkg.tar.xz

And now opening local .swf files works again

Great catch.

This is most likely the change.
http://cgit.freedesktop.org/xdg/shared- … fa94dc276d

Offline

#36 2014-01-25 08:22:44

von
Member
Registered: 2012-11-12
Posts: 6

Re: SWF file weirdness

Jodell wrote:

Great catch.

This is most likely the change.
http://cgit.freedesktop.org/xdg/shared- … fa94dc276d

I can confirm: reverting that change in /usr/share/mime/packages/freedesktop.org.xml and running update-mime-database fixes the issue.

Offline

#37 2014-01-25 13:18:29

Sanne
Member
Registered: 2012-03-13
Posts: 86

Re: SWF file weirdness

Seems to me more a workaround than a fix, because application/vnd.adobe.flash.movie looks to be the correct mime-type. Best would be if Firefox/Seamonkey and friends would support it instead of the non-standard application/x-shockwave-flash.

Great researching nonetheless!

This also explains why my solution in post #26 works for me, btw, because I'm holding back update to shared-mime-info-1.2, I'm still using 1.1, which still provides application/x-shockwave-flash.


If our currency were not money but appreciation and acknowledgement for what we do for others, for the community, for the benefit of all, we would have paradise on earth.

Offline

#38 2014-05-01 11:13:14

rabcor
Member
Registered: 2013-02-09
Posts: 495

Re: SWF file weirdness

So the workaround for this is to edit /usr/share/mime/packages/freedesktop.org.xml and change

<mime-type type="application/vnd.adobe.flash.movie">

to

<mime-type type="application/x-shockwave-flash">

and then run

update-mime-database /usr/share/mime

This info should be more visible to people who come accross the thread.

Offline

#39 2014-05-01 11:23:34

Ian_Jordan
Member
Registered: 2013-10-20
Posts: 2

Re: SWF file weirdness

rabcor wrote:

So the workaround for this is to edit /usr/share/mime/packages/freedesktop.org.xml and change

<mime-type type="application/vnd.adobe.flash.movie">

to

<mime-type type="application/x-shockwave-flash">

and then run

update-mime-database /usr/share/mime

This info should be more visible to people who come accross the thread.

Thanks for this, spent ages messing around trying different fixes and found this post, made the changes and was just looking into where the mime database was. I'm a bit bemused that browsers ship supporting non-standard mime types.

Offline

#40 2014-07-06 01:08:23

excitablesnowball
Member
Registered: 2012-03-02
Posts: 6

Re: SWF file weirdness

I don't like the approach of patching the MIME database: Adobe was given application/vnd.adobe.flash.movie, so their software should use it. So here's an alternate approach: https://aur.archlinux.org/packages/flashplugin-mimefix/. It's a binary patch against libflashplayer.so to make it accept application/vnd.adobe.flash.movie.

Offline

#41 2014-07-22 13:10:26

rabcor
Member
Registered: 2013-02-09
Posts: 495

Re: SWF file weirdness

excitablesnowball wrote:

I don't like the approach of patching the MIME database: Adobe was given application/vnd.adobe.flash.movie, so their software should use it. So here's an alternate approach: https://aur.archlinux.org/packages/flashplugin-mimefix/. It's a binary patch against libflashplayer.so to make it accept application/vnd.adobe.flash.movie.

Anyone who wnats their flash player to be up to date uses chrome's pepperflash, not adobe's flashplayer which is not being updated. But this should not require patching, it should just... work out of the box.

Last edited by rabcor (2014-07-22 13:10:55)

Offline

#42 2015-03-15 23:54:45

Neizthæm
Member
Registered: 2015-03-14
Posts: 1

Re: SWF file weirdness

I was able to solve this issue with the following approach:

echo "application/x-shockwave-flash       swf swfl" >> ~/.mime.types

It does not require reverting the package or updating the mimetype database. Although if you have multiple users, you would have to create this file for each of them...

Offline

#43 2015-11-02 11:18:06

Physicist1616
Member
Registered: 2015-02-16
Posts: 19

Re: SWF file weirdness

So I can't tell what the final fix is:  The last line of echoing into the .mime.types file didn't do it for me, but I'm running chromium and pepperflash. 

I tried standalone pepperflash, but it doesn't seem to have an executable (at least not an intuitively named one). 

How can I open local .swf files in Q4 2015? (preferably sticking with chromium and pepperflash.)

Edit:  Ok, I can see that rabcor's method for editing the mime-type above works.  All good.  Still strange that this doesn't *just work*; this seems a little beyond the scope of the Arch Way.

Last edited by Physicist1616 (2015-11-02 11:35:49)

Offline

Board footer

Powered by FluxBB