You are not logged in.

#1 2013-12-13 12:35:22

SuperV1234
Member
From: Italy
Registered: 2013-07-02
Posts: 14
Website

[SOLVED] Cannot build QT-Creator after updating this morning

This morning I ran a full-system update, and qt got updated.

When I try to build QT-Creator (either from official git repos or from AUR), I get this error:

Project ERROR: Unknown module(s) in QT: v8-private

Am I the only one having this issue? What can I do to troubleshoot?

Last edited by SuperV1234 (2013-12-13 15:05:31)

Offline

#2 2013-12-13 14:23:44

Raynman
Member
Registered: 2011-10-22
Posts: 1,111

Re: [SOLVED] Cannot build QT-Creator after updating this morning

Are you trying to build an older revision? Qt 5.2 was just released along with Qt Creator 3.0. This new version is also in [extra].

Qt 5.2 uses a new JS engine instead V8 (focussing on QML rather than web page performance), so the qt5-jsbackend package (with v8-private header) has been removed.

Last edited by Raynman (2013-12-13 14:39:47)

Offline

#3 2013-12-13 15:05:23

SuperV1234
Member
From: Italy
Registered: 2013-07-02
Posts: 14
Website

Re: [SOLVED] Cannot build QT-Creator after updating this morning

I solved the issue by removing/reinstalling all qt5 packages. Don't know what was wrong, but it works now.

Offline

Board footer

Powered by FluxBB