You are not logged in.

#1 2013-12-19 23:10:19

yYy
Member
Registered: 2013-12-19
Posts: 6

[SOLVED] Qt Creator can't debug anymore after system update

Hi,

I updated my system today and now I can't debug in Qt Creator anymore. When I start debugging I get this output:

Debugging starts
&"warning: GDB: Failed to set controlling terminal: Inappropriate ioctl for device\n"

The application runs, but it is not debugging. After a while I get a message window that says:

The gdb process has not responded to a command within 40 second(s). This could mean it is stuck in an endless loop or taking longer than expected to perform the operation.
You can choose between waiting longer or aborting debugging.

I also can't kill the application with the stop button in Qt Creator when debugging.
I have tried this with Qt 4 and Qt 5, in Debug and Release mode. I also created a new project and tried it, it had the same results.

Any suggestions? Please note that I am pretty new to Arch.

Last edited by yYy (2013-12-20 00:42:29)

Offline

#2 2013-12-19 23:21:30

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] Qt Creator can't debug anymore after system update

If you updated the kernel, reboot the system and try again.

Offline

#3 2013-12-19 23:27:14

yYy
Member
Registered: 2013-12-19
Posts: 6

Re: [SOLVED] Qt Creator can't debug anymore after system update

Thanks for the quick reply.

I already did that. I also read somewhere that sometimes reinstalling a package helps, so I removed and reinstalled any qt5 package, qtcreator and gdb. The behavior is still the same.
By the way, is there a way to see which packages were updated exactly? Qt Creator was updated for sure, since it now looks different. :-)

Offline

#4 2013-12-19 23:30:06

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] Qt Creator can't debug anymore after system update

Check pacman's log: /var/log/pacman.log

Offline

#5 2013-12-19 23:41:43

yYy
Member
Registered: 2013-12-19
Posts: 6

Re: [SOLVED] Qt Creator can't debug anymore after system update

Ok, here is the logfile

[2013-12-19 19:03] [PACMAN] Running 'pacman -S -y -u'
[2013-12-19 19:03] [PACMAN] synchronizing package lists
[2013-12-19 19:03] [PACMAN] starting full system upgrade
[2013-12-19 19:13] [PACMAN] upgraded linux-api-headers (3.10.6-1 -> 3.12.4-1)
[2013-12-19 19:13] [PACMAN] upgraded glibc (2.18-10 -> 2.18-11)
[2013-12-19 19:13] [PACMAN] upgraded binutils (2.23.2-3 -> 2.24-1)
[2013-12-19 19:13] [PACMAN] upgraded bison (3.0.1-1 -> 3.0.2-1)
[2013-12-19 19:13] [PACMAN] upgraded bluez (5.11-1 -> 5.12-2)
[2013-12-19 19:13] [PACMAN] upgraded bluez-libs (5.11-1 -> 5.12-2)
[2013-12-19 19:13] [PACMAN] upgraded coreutils (8.21-2 -> 8.22-2)
[2013-12-19 19:13] [PACMAN] upgraded util-linux (2.24-1 -> 2.24-2)
[2013-12-19 19:13] [PACMAN] upgraded systemd (208-2 -> 208-3)
[2013-12-19 19:13] [PACMAN] upgraded bluez-utils (5.11-1 -> 5.12-2)
[2013-12-19 19:13] [PACMAN] upgraded boost-libs (1.55.0-2 -> 1.55.0-3)
[2013-12-19 19:13] [PACMAN] upgraded cfitsio (3.350-2 -> 3.360-1)
[2013-12-19 19:13] [PACMAN] upgraded x264 (20131030-1 -> 20131030-2)
[2013-12-19 19:13] [PACMAN] upgraded ffmpeg (1:2.1.1-1 -> 1:2.1.1-2)
[2013-12-19 19:13] [PACMAN] upgraded file (5.15-1 -> 5.16-1)
[2013-12-19 19:13] [PACMAN] upgraded nss (3.15.3-1 -> 3.15.3.1-1)
[2013-12-19 19:13] [PACMAN] upgraded firefox (25.0.1-1 -> 26.0-2)
[2013-12-19 19:13] [PACMAN] upgraded flashplugin (11.2.202.327-1 -> 11.2.202.332-1)
[2013-12-19 19:13] [PACMAN] upgraded gcc-libs (4.8.2-5 -> 4.8.2-6)
[2013-12-19 19:13] [PACMAN] upgraded gcc (4.8.2-5 -> 4.8.2-6)
[2013-12-19 19:13] [PACMAN] upgraded gdb (7.6.1-1 -> 7.6.2-1)
[2013-12-19 19:13] [PACMAN] upgraded libjpeg-turbo (1.3.0-3 -> 1.3.0-4)
[2013-12-19 19:13] [PACMAN] upgraded gdk-pixbuf2 (2.30.1-1 -> 2.30.2-1)
[2013-12-19 19:13] [PACMAN] upgraded pcre (8.33-2 -> 8.34-1)
[2013-12-19 19:13] [PACMAN] upgraded git (1.8.5.1-1 -> 1.8.5.2-1)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10 (0.10.36-2 -> 0.10.36-3)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-base (0.10.36-1 -> 0.10.36-2)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-bad (0.10.23-5 -> 0.10.23-6)
[2013-12-19 19:13] [PACMAN] installed spandsp (0.0.6pre21-2)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-bad-plugins (0.10.23-5 -> 0.10.23-6)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-base-plugins (0.10.36-1 -> 0.10.36-2)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-ffmpeg (0.10.13-1 -> 0.10.13-2)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-good (0.10.31-3 -> 0.10.31-4)
[2013-12-19 19:13] [ALPM-SCRIPTLET] 
[2013-12-19 19:13] [ALPM-SCRIPTLET] (gconftool-2:31677): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
[2013-12-19 19:13] [ALPM-SCRIPTLET] /usr/bin/dbus-launch terminated abnormally with the following error: No protocol specified
[2013-12-19 19:13] [ALPM-SCRIPTLET] Autolaunch error: X11 initialization failed.
[2013-12-19 19:13] [ALPM-SCRIPTLET] 
[2013-12-19 19:13] [ALPM-SCRIPTLET] 
[2013-12-19 19:13] [ALPM-SCRIPTLET] (gconftool-2:31686): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
[2013-12-19 19:13] [ALPM-SCRIPTLET] /usr/bin/dbus-launch terminated abnormally with the following error: No protocol specified
[2013-12-19 19:13] [ALPM-SCRIPTLET] Autolaunch error: X11 initialization failed.
[2013-12-19 19:13] [ALPM-SCRIPTLET] 
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-good-plugins (0.10.31-3 -> 0.10.31-4)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-ugly (0.10.19-7 -> 0.10.19-8)
[2013-12-19 19:13] [PACMAN] upgraded gstreamer0.10-ugly-plugins (0.10.19-7 -> 0.10.19-8)
[2013-12-19 19:13] [PACMAN] upgraded imagemagick (6.8.7.9-1 -> 6.8.7.10-1)
[2013-12-19 19:13] [PACMAN] upgraded inetutils (1.9.1.341-1 -> 1.9.1.341-2)
[2013-12-19 19:13] [PACMAN] upgraded lib32-glibc (2.18-10 -> 2.18-11)
[2013-12-19 19:13] [PACMAN] upgraded lib32-gcc-libs (4.8.2-5 -> 4.8.2-6)
[2013-12-19 19:13] [PACMAN] upgraded lib32-libjpeg-turbo (1.3.0-3 -> 1.3.0-4)
[2013-12-19 19:13] [PACMAN] upgraded mesa (9.2.4-1 -> 10.0.1-1)
[2013-12-19 19:13] [PACMAN] upgraded lib32-mesa (9.2.4-1 -> 10.0.1-1)
[2013-12-19 19:13] [PACMAN] upgraded libreoffice-en-US (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [PACMAN] upgraded libreoffice-common (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [PACMAN] upgraded libreoffice-base (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [PACMAN] upgraded libreoffice-calc (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [PACMAN] upgraded libreoffice-draw (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [PACMAN] upgraded libreoffice-impress (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [PACMAN] upgraded libreoffice-kde4 (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [PACMAN] upgraded libreoffice-math (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [PACMAN] upgraded libreoffice-writer (4.1.3-2 -> 4.1.4-1)
[2013-12-19 19:15] [ALPM] warning: /etc/mkinitcpio.conf installed as /etc/mkinitcpio.conf.pacnew
[2013-12-19 19:15] [PACMAN] upgraded mkinitcpio (0.15.0-1 -> 16-1)
[2013-12-19 19:16] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2013-12-19 19:16] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Starting build: 3.12.5-1-ARCH
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Hook 'pata' is deprecated. Replace it with 'block' in your config
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Hook 'scsi' is deprecated. Replace it with 'block' in your config
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Hook 'sata' is deprecated. Replace it with 'block' in your config
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Hook 'usbinput' is deprecated. Replace it with 'keyboard' in your config
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux.img
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Starting build: 3.12.5-1-ARCH
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Hook 'pata' is deprecated. Replace it with 'block' in your config
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: smsmdtv
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Hook 'scsi' is deprecated. Replace it with 'block' in your config
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Hook 'sata' is deprecated. Replace it with 'block' in your config
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> WARNING: Hook 'usbinput' is deprecated. Replace it with 'keyboard' in your config
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-12-19 19:16] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
[2013-12-19 19:16] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-12-19 19:16] [PACMAN] upgraded linux (3.12.3-1 -> 3.12.5-1)
[2013-12-19 19:16] [PACMAN] upgraded make (4.0-1 -> 4.0-2)
[2013-12-19 19:16] [PACMAN] upgraded man-pages (3.54-1 -> 3.55-1)
[2013-12-19 19:16] [PACMAN] upgraded mpfr (3.1.2.p4-1 -> 3.1.2.p5-1)
[2013-12-19 19:16] [PACMAN] upgraded qt4 (4.8.5-6 -> 4.8.5-7)
[2013-12-19 19:16] [PACMAN] upgraded qtchooser (31-1 -> 39-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-base (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-xmlpatterns (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-declarative (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-sensors (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] installed qt5-location (5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-webkit (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-script (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-quick1 (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-translations (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qt5-tools (5.1.1-5 -> 5.2.0-1)
[2013-12-19 19:16] [PACMAN] installed qt5-quickcontrols (5.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded qtcreator (2.8.1-2 -> 3.0.0-2)
[2013-12-19 19:16] [PACMAN] upgraded raptor (2.0.10-3 -> 2.0.12-1)
[2013-12-19 19:16] [PACMAN] upgraded sdl2 (2.0.1-2 -> 2.0.1-3)
[2013-12-19 19:16] [PACMAN] upgraded systemd-sysvcompat (208-2 -> 208-3)
[2013-12-19 19:16] [PACMAN] upgraded thunderbird (24.1.1-1 -> 24.2.0-1)
[2013-12-19 19:16] [PACMAN] upgraded umlet (12.1-1 -> 12.2-1)
[2013-12-19 19:16] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2013-12-19 19:16] [PACMAN] upgraded virtualbox-host-modules (4.3.4-1 -> 4.3.6-1)
[2013-12-19 19:18] [PACMAN] upgraded virtualbox (4.3.4-1 -> 4.3.6-1)
[2013-12-19 19:18] [PACMAN] upgraded vlc (2.1.1-2 -> 2.1.2-1)
[2013-12-19 19:18] [PACMAN] upgraded xf86-input-synaptics (1.7.1-1 -> 1.7.2-1)
[2013-12-19 19:18] [PACMAN] upgraded xorg-server-common (1.14.4-1 -> 1.14.5-1)
[2013-12-19 19:18] [PACMAN] upgraded xorg-server (1.14.4-1 -> 1.14.5-1)
[2013-12-19 19:18] [PACMAN] upgraded zenity (3.10.0-1 -> 3.10.2-1)

Apparently everything related to Qt development was upgraded: qt4, qt5, qtcreator, gdb, make, gcc.

Offline

#6 2013-12-19 23:46:57

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] Qt Creator can't debug anymore after system update

Have you seen the warnings in the log? Your /etc/mkinitcpio.conf could use some love :-)

Try downgrading gdb and see if it helps. If not, see if downgrading qt packages helps.

Offline

#7 2013-12-20 00:05:54

yYy
Member
Registered: 2013-12-19
Posts: 6

Re: [SOLVED] Qt Creator can't debug anymore after system update

Yes I saw the warnings, but I don't know what they mean, and they were only warnings. Actually I still don't. Is there a wiki page or something so I can give it the love it needs?

I also didn't know downgrading was possible. Will try that now.

Offline

#8 2013-12-20 00:10:59

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] Qt Creator can't debug anymore after system update

yYy wrote:

Is there a wiki page or something so I can give it the love it needs?

Search to find out :-)
I suggest reading e.g. the man page or the wiki first before asking on the forums. Provided documentation should be sufficient and up to date.

Offline

#9 2013-12-20 00:24:12

yYy
Member
Registered: 2013-12-19
Posts: 6

Re: [SOLVED] Qt Creator can't debug anymore after system update

I did a quick search of course, but it didn't show up. Doing it again now does show a wiki page indeed, so I probably overlooked it or something the first time. ;-)

Downgrading gdb did not help, but downgrading qtcreator did.
I still get these messages, but debugging works anyway:

Debugging starts
&"warning: GDB: Failed to set controlling terminal: Inappropriate ioctl for device\n"
no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?

I upgraded gdb again, it still works. So now only qt creator is not up to date.
Can I tell pacman to exclude qtcreator from future system upgrades?
Should I create a bug report somewhere or something?
And of course: Thanks a lot!

Offline

#10 2013-12-20 00:28:55

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] Qt Creator can't debug anymore after system update

yYy wrote:

Can I tell pacman to exclude qtcreator from future system upgrades?

Read the man page for pacman.conf. I think you should familiarize yourself with all the basic commands and configs.

yYy wrote:

Should I create a bug report somewhere or something?

Yes, I think a bug report is in order.

Offline

#11 2013-12-20 00:42:05

yYy
Member
Registered: 2013-12-19
Posts: 6

Re: [SOLVED] Qt Creator can't debug anymore after system update

Ok, thanks again, I will do both.

Offline

#12 2014-01-17 08:05:08

Procedural
Member
Registered: 2013-09-27
Posts: 17
Website

Re: [SOLVED] Qt Creator can't debug anymore after system update

yYy wrote:

I still get these messages, but debugging works anyway:

Debugging starts
&"warning: GDB: Failed to set controlling terminal: Inappropriate ioctl for device\n"
no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?

I've created a separate thread for this issue, if anyone has an idea what might cause it please reply here: /viewtopic.php?pid=1371782

Offline

Board footer

Powered by FluxBB