You are not logged in.

#1 2013-06-10 17:11:25

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

[SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

Hello there!

I run a 64bit system and after the most recent pulseaudio update to 4.0-1 I experience problems (lib32-libpulse is installed):
First I encounterd crackling or even no sound in skype. After searching the web / wiki I turned the timer-based scheduling off by adding tsched=0 in /etc/pulse/default.pa, so that the relevant line reads as:

 
load-module module-udev-detect tsched=0

This made skype happy, it works as it should. However this "hack" completely confuses the output of moc (music on console): I hear a kind of echoed crackling, and the "music" runs about 3 times faster as it should.

Removing tsched=0 makes moc work again but then the skype issue reappears.

I already tried my search-fu and found for example https://bbs.archlinux.org/viewtopic.php?id=164906 but this didn't propose a suitable fix for me, did it?

Any hints appreceated!

Last edited by ball (2013-06-12 13:35:46)

Offline

#2 2013-06-10 19:02:01

Kn3cHt
Member
From: Germany
Registered: 2007-10-26
Posts: 13

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

I have a similar problem since updating to pulseaudio 4.0. If i try to play for example an mp3 with vlc (or the phonon-vlc backend) via pulseaudio it is crackling, using the alsa-sink it works however. Things like ac3 audio from a movie plays fine with vlc and pulseaudio.
Adding tsched=0 fixes these problems, however then the audio in chromium is played a lot faster.

I'm using an creative xfi soundcard, so it could have something to do with the drivers.

Offline

#3 2013-06-10 19:09:00

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,208

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

which resampling method so you use? I had to change from ffmpeg (which previously worked very well) to speex-float-0 (which is the new default) to make everything work fine.

I have also noticed that I have no sound in skype when I connect a usb headset and try to use it _after_ the call is in progress (or still waiting to be answered), it works fine if I plug the headset beforehand.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#4 2013-06-10 20:09:44

Kn3cHt
Member
From: Germany
Registered: 2007-10-26
Posts: 13

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

Changing resample-method from the previously working src-sinc-best-quality to speex-float-10 fixed the issue.

Offline

#5 2013-06-12 08:17:59

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

Thanks for the pointers, but they did not help: I already had speex-float-0 as default resampling method for I never played with the pulseaudio configuration. Changing it to speex-float-10 doesn't help either; I tried it with and without the tsched=0 option. In all cases either skype does not work or moc does not work.

Also I don't use a USB headset, just my laptop speakers/microphone or my phone connector headset...

I use a Lenovo Thinkpad T400 laptop, so it's a very low-end soundcard.

Last edited by ball (2013-06-12 08:18:53)

Offline

#6 2013-06-12 13:34:44

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

https://bugs.freedesktop.org/show_bug.cgi?id=50510#c4 suggests a workaround which works for me: Remove the tsched=0 option and start skype with

$ PULSE_LATENCY_MSEC=30 skype

Offline

#7 2013-06-13 17:54:52

swordfish
Member
Registered: 2012-01-14
Posts: 160

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

ball wrote:

https://bugs.freedesktop.org/show_bug.cgi?id=50510#c4 suggests a workaround which works for me: Remove the tsched=0 option and start skype with

$ PULSE_LATENCY_MSEC=30 skype

Wow, that's a good hint wink ! But one question: This is working pretty well when I start Skype from the command line. But how can I tell Gnome to launch the Skype starter with this option?

I've already tried to work on the file /usr/share/applications/skype.desktop like this:

[Desktop Entry]
Name=Skype
Comment=Skype Internet Telephony
Exec=PULSE_LATENCY_MSEC=30 skype %U
Icon=skype.png
Terminal=false
Type=Application
Encoding=UTF-8
Categories=Network;Application;
MimeType=x-scheme-handler/skype;
X-KDE-Protocols=skype

But that doesn't work - it just makes the skype button disppear yikes

Last edited by swordfish (2013-06-13 18:27:38)


Arch_x64 on Thinkpad Edge E520 (Intel Core i5, 4 GB RAM, 128 GB Crucial M4 SSD) + ITX-Desktop (Asrock H77M-ITX, Intel Core i3-2120T, 8GB RAM, 64 GB Samsung 830 SSD)

Offline

#8 2013-06-13 20:20:48

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

create a script, e.g. "myskype" somewhere in your path with the following content

#!/bin/bash
PULSE_LATENCY_MSEC=30 skype

Then make your launcher or whatever point to this script. Untested. (And don't forget to make the script executable)

Another option would be to make the setting PULSE_LATENCY_MSEC=30 permanent and system wide via the pulseaudio configuration (or in ~/.xinit... ), but I didn't test that for any negative effects on other audio applications.

Last edited by ball (2013-06-13 20:27:18)

Offline

#9 2013-06-13 22:37:08

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

Same problem here. Adding "tsched=0" doesn't help. Downgrading to pulseaudio 3.0-3 helps.

Offline

#10 2013-06-14 02:20:55

nticompass
Member
From: /home/nticompass/
Registered: 2009-12-08
Posts: 39
Website

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

Kn3cHt wrote:

Changing resample-method from the previously working src-sinc-best-quality to speex-float-10 fixed the issue.

This seemed to work for me.  speex-float-0 didn't but speex-float-10 does.

Offline

#11 2013-06-16 19:09:35

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

nticompass wrote:
Kn3cHt wrote:

Changing resample-method from the previously working src-sinc-best-quality to speex-float-10 fixed the issue.

This seemed to work for me.  speex-float-0 didn't but speex-float-10 does.

How do I apply that solution?

Do I have to load a module?

Offline

#12 2013-06-16 22:09:07

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

It is a setting you can find in /etc/pulse/daemon.conf

Offline

#13 2013-06-16 22:12:32

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

It doesn't work for me. In fact, I haven't found a working solution for either of my two Arch machines...

Offline

#14 2013-06-16 22:41:49

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

Did already try the workaround I proposed myself?

Last edited by ball (2013-06-16 22:42:03)

Offline

#15 2013-06-16 22:49:00

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

It works! Thanks!

In fact, one can just sudo vi `which skype` and modify the last line to read:

PULSE_LATENCY_MSEC=30 exec "$LIBDIR/skype/skype" "$@"

Offline

#16 2013-06-20 13:36:44

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

Thanks trsk,

That's a good solution unless the issue is fixed.

Offline

#17 2013-08-05 18:20:59

Tsu Jan
Member
Registered: 2012-02-28
Posts: 16

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

ball wrote:

https://bugs.freedesktop.org/show_bug.cgi?id=50510#c4 suggests a workaround which works for me: Remove the tsched=0 option and start skype with

$ PULSE_LATENCY_MSEC=30 skype

Thanks a lot! That worked for me in Debian after chaning the Exec line of Skype's desktop file to:

Exec=bash -c "PULSE_LATENCY_MSEC=30 skype %U"

Last edited by Tsu Jan (2013-08-05 18:23:55)

Offline

#18 2013-08-05 19:09:15

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

With skype 4.2.0.11-3 I do not have to apply any of the above workarounds. It works natively without a flaw.

Offline

#19 2013-08-30 12:46:12

GotMyMojoWorking
Member
Registered: 2013-08-30
Posts: 1

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

swordfish wrote:

I've already tried to work on the file /usr/share/applications/skype.desktop like this:

[Desktop Entry]
Name=Skype
Comment=Skype Internet Telephony
Exec=PULSE_LATENCY_MSEC=30 skype %U
Icon=skype.png
Terminal=false
Type=Application
Encoding=UTF-8
Categories=Network;Application;
MimeType=x-scheme-handler/skype;
X-KDE-Protocols=skype

But that doesn't work - it just makes the skype button disppear yikes

The fix to make the skype.desktop link work is here http://arunraghavan.net/2013/08/pulseau … and-skype/

If you are packaging Skype for your distribution, you need to change the Exec line in your Skype .desktop file as follows:

Exec=env PULSE_LATENCY_MSEC=60 skype %U

I found that the given '60' figure worked for me better than the '30' figure.

Offline

#20 2013-12-28 12:55:59

sudolee
Member
Registered: 2013-07-16
Posts: 1

Re: [SOLVED] Crackling sound -- Skype / moc / pulseaudio issue

I fixed this issue via setting phonon backend from phonon-vlc to phonon-gstream.

Offline

Board footer

Powered by FluxBB