You are not logged in.

#1 2013-12-30 15:31:14

drev
Member
Registered: 2010-02-26
Posts: 10

How to update an existing package

Hi,

There is a package that do not build because of deprecated gtk function  [https://aur.archlinux.org/packages/kanjipad/], the source of this package is located on a personal web site.

Since it's a really cool software and it's easy to update (the deprecated part that prevent it to be build is only concerning the toolbar menu), I found a github version of this project, forked and updated the code so it can now be build [https://github.com/odrevet/kanjipad/].

Since the original source code is on a personal site and unmaintained since 2006, It seems impossible to send the new code upstream.

Is it allowed to have duplicate package (kanjipad 2.0.0-7 and mine, kanjipad git ) ?
Should the unbuildable kanjipad be removed from AUR ?  How warn the Maintainer ?

Last edited by drev (2013-12-30 15:42:24)

Offline

#2 2013-12-30 15:40:34

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: How to update an existing package

Please change the title to something more informative.

You can e-mail the maintainer https://aur.archlinux.org/account/jinn and leave a comment on https://aur.archlinux.org/packages/kanjipad/

Offline

#3 2013-12-30 15:42:53

drev
Member
Registered: 2010-02-26
Posts: 10

Re: How to update an existing package

oops sorry

Offline

#4 2013-12-30 15:49:43

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: How to update an existing package

If you're still unsure what to do, please send an e-mail to the aur-general mailing list.

Offline

Board footer

Powered by FluxBB