You are not logged in.

#1 2014-01-02 13:14:34

jabol240
Member
From: Gdansk, Poland
Registered: 2011-02-18
Posts: 17

[REQUEST] EFL 1.8 / Enlightenment 18

Hi, has anybody done/is doing the recently released EFL 1.8 and E 0.18 or would like to kindly build them? In AUR, I'm only finding -git packages with versions numbered 0.17.99 or 1.8.99...

Offline

#2 2014-01-02 13:26:29

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,831
Website

Re: [REQUEST] EFL 1.8 / Enlightenment 18

What's your question here?  1.8 is available in the aur as you already note.  If you're wondering when 1.8 stable will be in the repositories, the answer is "when it's ready".  It's been 6 days since it was released.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2014-01-02 13:48:05

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: [REQUEST] EFL 1.8 / Enlightenment 18

jabol240 wrote:

Hi, has anybody done/is doing the recently released EFL 1.8 and E 0.18 or would like to kindly build them? In AUR, I'm only finding -git packages with versions numbered 0.17.99 or 1.8.99...

You can easily create stable packages from a git package. Just add the tagname or commit-id to the git url and remove -git from the name. And maybe remove the 17 from the name and only call it enlightenment.
Edit: Just download the source from enlightenment.org, it already ships with a PKGBUILD

Scimmia     wrote:

2013-11-25 16:46
For those that just want to follow the alpha/beta releases and not Git HEAD, a PKGBUILD is provided with each tarball. Just extract the tarball, cd into the <new dir>/pkgbuild and run makepkg.

Last edited by progandy (2014-01-02 13:53:50)

Offline

#4 2014-01-02 18:25:31

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [REQUEST] EFL 1.8 / Enlightenment 18

progandy wrote:
jabol240 wrote:

Hi, has anybody done/is doing the recently released EFL 1.8 and E 0.18 or would like to kindly build them? In AUR, I'm only finding -git packages with versions numbered 0.17.99 or 1.8.99...

You can easily create stable packages from a git package. Just add the tagname or commit-id to the git url and remove -git from the name. And maybe remove the 17 from the name and only call it enlightenment.
Edit: Just download the source from enlightenment.org, it already ships with a PKGBUILD

Scimmia     wrote:

2013-11-25 16:46
For those that just want to follow the alpha/beta releases and not Git HEAD, a PKGBUILD is provided with each tarball. Just extract the tarball, cd into the <new dir>/pkgbuild and run makepkg.

Since I made that post, the included PKGBUILD was changed so that it's setup to build from Git and not from the release tarballs. It can be made to work, but it'll take some modification.

@jabol240, I suggest just using enlightenment17-git right now as nothing major has been merged since the 0.18 release, so you're basically just getting 0.18 + bugfixes. Build it soon because a huge compositor rewrite will be merged very soon that will change that. Just change the 'elementary-git' dependency to 'elementary' and use EFL/Elm 1.8 is [testing].

Last edited by Scimmia (2014-01-02 18:34:54)

Offline

#5 2014-01-02 18:41:50

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: [REQUEST] EFL 1.8 / Enlightenment 18

Scimmia wrote:

Since I made that post, the included PKGBUILD was changed so that it's setup to build from Git and not from the release tarballs. It can be made to work, but it'll take some modification.

The shipped PKGBUILD uses the release tarball as source, even if "-git" is part of the package name. This is the PKGBUILD which is part of the 0.18.1 release of enlightenment. The only problems are the name and the pkgver-function.

# Maintainer: Enlightenment Developers <enlightenment-devel@enlightenment.org>>
pkgname=enlightenment-git
pkgver=0.18.0rc2.17382.ed1a5e4
pkgrel=1
pkgdesc="Enlightenment window manager - GIT development snapshot"
arch=('i686' 'x86_64' 'arm')
url="http://www.enlightenment.org"
license=('BSD')
depends=('elementary' 'xcb-util-keysyms' 'hicolor-icon-theme' 'pixman' 'mesa'
         'desktop-file-utils' 'udisks2' 'ttf-font' 'bluez-libs')
optdepends=('connman: network module'
            'acpid: power events on laptop lid close'
            'gdb: create backtraces on crash')
provides=("enlightenment17=$pkgver" 'notification-daemon')
conflicts=("enlightenment17")
backup=('etc/enlightenment/sysactions.conf'
        'etc/xdg/menus/enlightenment.menu')
options=('debug')
install=enlightenment.install

pkgver() {
  cd "../.."

  for _i in v_maj v_min v_mic; do
    local v_ver=$v_ver.$(grep -m1 $_i configure.ac | sed 's/m4//' | grep -o "[[:digit:]]*")
  done

  v_ver=$(awk -F , -v v_ver=${v_ver#.} '/^AC_INIT/ {gsub(/v_ver/, v_ver); gsub(/[\[\] -]/, ""); print $2}' configure.ac)

  printf "$v_ver.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}

build() {
  cd "../.."
  export CFLAGS="$CFLAGS -fvisibility=hidden -fomit-frame-pointer"
  [[ -e Makefile ]] && make clean distclean
  ./autogen.sh --prefix=/usr --sysconfdir=/etc --enable-wayland-clients --enable-wayland-egl
  make
}

package() {
  cd "../.."
  make -j1 DESTDIR="$pkgdir" install
  install -Dm644 AUTHORS "$pkgdir/usr/share/doc/${pkgname%-*}/AUTHORS"
  install -Dm644 ChangeLog "$pkgdir/usr/share/doc/${pkgname%-*}/ChangeLog"
  install -Dm644 NEWS "$pkgdir/usr/share/doc/${pkgname%-*}/NEWS"
  install -Dm644 README "$pkgdir/usr/share/doc/${pkgname%-*}/README"
  install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
  ln -sf "../../licenses/$pkgname/COPYING" "$pkgdir/usr/share/doc/${pkgname%-*}/COPYING"
}

Offline

#6 2014-01-02 18:44:49

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [REQUEST] EFL 1.8 / Enlightenment 18

I'm aware of it, I wrote most of it. As I said, it can work with some modification. The pkgver function will need changed or just removed and the pkgver updated manually.

Last edited by Scimmia (2014-01-02 18:45:54)

Offline

#7 2014-01-02 19:04:41

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: [REQUEST] EFL 1.8 / Enlightenment 18

Scimmia wrote:

I'm aware of it, I wrote most of it. As I said, it can work with some modification. The pkgver function will need changed or just removed and the pkgver updated manually.

What about this?

# create git package when run from inside a git tree.
_git=
git status >/dev/null 2>&1 && _git="-git"
pkgname=enlightenment$_git

pkgver() {
  cd "../.."

  for _i in v_maj v_min v_mic; do
    local v_ver=$v_ver.$(grep -m1 $_i configure.ac | sed 's/m4//' | grep -o "[[:digit:]]*")
  done

  v_ver=$(awk -F , -v v_ver=${v_ver#.} '/^AC_INIT/ {gsub(/v_ver/, v_ver); gsub(/[\[\] -]/, ""); print $2}' configure.ac)
  
  if [ "$_git" = "-git" ]; then 
    printf "$v_ver.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
  else
    printf "$v_ver"
  fi
}

Last edited by progandy (2014-01-02 19:08:58)

Offline

#8 2014-01-02 19:12:12

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [REQUEST] EFL 1.8 / Enlightenment 18

I would probably just use [[ -e .git]] to test if there is VCS data, but it works. I don't think changing the pkgname dynamically like that is a good thing, though, pacman could easily get confused. Easy enough to just leave it with -git and not worry about it.

Offline

#9 2014-01-03 01:49:26

jabol240
Member
From: Gdansk, Poland
Registered: 2011-02-18
Posts: 17

Re: [REQUEST] EFL 1.8 / Enlightenment 18

Okay guys, thanks for your replies and help. I'm sadly not smart enough to do any tricky PKGBUILD modifications; if EFL 1.8 / E18  are in [testing] then I'll simply wait for em to arrive in [extra].
@Scimmia, my sincere Thanks for maintaining the packages... it's really nice that some knowledgeable people do the technical work so that the less-knowledgeable ones can use it too.

Offline

#10 2014-01-05 06:28:48

boxofrox
Member
Registered: 2012-07-09
Posts: 7

Re: [REQUEST] EFL 1.8 / Enlightenment 18

Between Scimmia's git-based PKGBUILDs and http://www.enlightenment.org/p.php?p=download&l=en, it's really not that difficult to modify the PKGBUILDS to work with the E18 tarballs.

Here are a few I converted.  I have no interest in the window manager, jabol240, so you can either diff my PKGBUILDs against Scimmia's to learn what changed and do the same with any other packages of interest, or wait for the next kind samaritan to provide those missing packages.  For elementary-git, I split that into two: elementary-1.8.2 and elementary_test_app-1.8.2.  Scimmia did something there that threatened to traumatize my OCD, hence the two files.

efl-1.8.3/PKGBUILD
evas_generic_loaders-1.8.1/PKGBUILD
emotion_generic_players-1.8.0/PKGBUILD
elementary-1.8.2/PKGBUILD
elementary_test_app-1.8.2/PKGBUILD

I have no desire to commit myself as a maintainer, which is why these are posted in the forums instead of on AUR.  I also am a PKGBUILD newb and haven't RTFM, so there's likely improvements to be made.  Everyone is free to use these, and first one to step up is welcome to maintain these.

I have successfully built, installed, and run the elementary_test application, which verifies everything (except maybe emotion) works.

Offline

#11 2014-01-06 12:02:12

jabol240
Member
From: Gdansk, Poland
Registered: 2011-02-18
Posts: 17

Re: [REQUEST] EFL 1.8 / Enlightenment 18

Thanks!

Offline

#12 2014-02-01 16:07:27

Expatbrat
Member
Registered: 2014-01-28
Posts: 7

Re: [REQUEST] EFL 1.8 / Enlightenment 18

I see that as of yesterday enlightenment 0.18 is in the repository.

Offline

#13 2014-02-01 17:31:30

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [REQUEST] EFL 1.8 / Enlightenment 18

Actually it went in to the repos on the 8th, over three weeks ago and just days after this thread.

Offline

Board footer

Powered by FluxBB