You are not logged in.

#1 2006-01-20 22:52:46

Cub69
Member
From: Ottawa, Canada
Registered: 2006-01-20
Posts: 87
Website

Impressive!

Hey all,

I'm new to Arch but not new to Linux.  My notebook decided to take a dump and I've been fighting ever since to find a good distro to use.

I think I found it with Arch.  I'm quite impressed.

I do have a couple of problems that I hope will be easy to resolve.  The fonts aren't the best but I think I saw a topic on fonts here somewhere so I will look that up.

The bigger issue is 1) sound -- each time I reboot my sound is muted and PCM is turned down and muted.  I have to run alsamixer to turn everything up.  I have done an alsactl store to save my settings but they don't seem to be getting set on reboot.
2)  I'm running on a notebook and I want to compile a custom kernel with CPU freq and ACPI.  Is there a particular way I should do this or just download from kernel.org?

Thanks and keep up the great work!

Cub

Offline

#2 2006-01-20 23:00:34

kth5
Member
Registered: 2004-04-29
Posts: 655
Website

Re: Impressive!

1)
easy: install alsa-utils and add alsa to DAEMONS=() in rc.conf
hard: install alsa-utils adjust volume with alsamixer once, use alsactl store and add alsactl restore to your rc.local

2)
cpufreq is built into the standard kernel26 package, all you need are the proper modules loaded. on a centrino chipset use speedstep-centrino and cpufreq-userspace. then install powernowd and add it to DAEMONS=() in rc.conf. that should be the easiest. in any case, it should not be necessary to build your own kernel, instead probe modules according to your machine and use either cpufreq-<governour>, cpufreqd or powernowd

good luck!  big_smile


I recognize that while theory and practice are, in theory, the same, they are, in practice, different. -Mark Mitchell

Offline

#3 2006-01-21 06:11:28

Cub69
Member
From: Ottawa, Canada
Registered: 2006-01-20
Posts: 87
Website

Re: Impressive!

Thanks!

Both tips worked flawlessly.  I have acpi, centrino-speedstep and alsa all working perfectly now.

Now for those damn multimedia keys... hehe.. 

Thanks again.

Cub

Offline

#4 2006-01-21 18:09:59

mac57
Member
From: St. Somewhere
Registered: 2006-01-06
Posts: 302
Website

Re: Impressive!

Even easier, and no need to add alsa to your running daemons (why add more daemons than you need...):

1) From your command prompt, run aumix and set your levels as you like, then do the "s" command to save them to ~/.aumixrc

2) In your .bash_profile, add the line "aumix -L"

This is what I did. Everytime you login, aumix will restore your levels to what you saved earlier. This avoids having the alsa daemon running *just* to restore sound levels.

Can anyone tell us of any other benefits we would get from having the alsa daemon running. I haven't noticed ANY deficiencies in the operation of my system without it...


Cast off the Microsoft shackles Jan 2005

Offline

#5 2006-01-21 18:25:30

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: Impressive!

If you looked at alsa rc script, you'd see that this actually isn't a daemon (i.e. it doesn't stay running in background). It just restores the volume settings on start (i.e. boot) and saves them on stop (i.e. shutdown).

Offline

#6 2006-01-21 18:38:07

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Impressive!

The alsa daemon is not really a deamon like the cron daemon wich is continually running in the background. On boot up, the alsa daemon runs:
alsactl restore
to restore the sound levels and then quits.  At shutdown, it runs:
alsactl store
to store the sound levels.  The use of the daemon format here is to make it more user-friendly than having the user place these commands in the correct initscript files.

Offline

#7 2006-01-21 20:23:29

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: Impressive!

and besides of that, it restores the settings before user authentication which makes you hear the music (if you're running mpd e.g.) already before the login prompt... smile

Offline

#8 2006-02-04 12:23:51

sven
Member
Registered: 2005-02-01
Posts: 311

Re: Impressive!

Hey Cub69! Welcome to Arch! I've been using it solely for over a year now and it fits like a glove big_smile I have some recommendations for your fonts issue. I got used to those sharp fonts in Windows so here are some of my experience about a way to have something similar in Arch, too:

- in Firefox:
1) modify userChrome.css (in your .mozilla/firefox/something.default/chrome) and see you have something like this:

* {
  font-size: 9pt !important;
  font-family: Helvetica !important;
}

- make sure you have helvetica there. This fixes the menus font.
2) set all the fonts at Edit->Preferences->Content->Fonts&Colors->Advanced to helvetica, too. This made in my case all the webpages look nice and readable.

- in Thunderbird (your .thunderbird/something.default)
1) there you can also make the chrome dir and userChrome.css in there and then add the same font settings to there as to Firefox to fix the menus. I had to set the font-size to 15 instead of 9 for the menu fonts to look the same as in Firefox.
2) in preferences select again the helvetica fonts

- in window managers
I am using only KDE and in there I have set all the fonts to smoothansi. It is in artwiz-fonts package. For a short time I have tried Gnome/Xfce  -  helvetica looks great - Gnome/Xfce somehow renders helvetica differently than KDE. EDIT: I tried helvetica in KDE and fonts seemed too wide apart from each other and thus were hard to read - that is the reason why I soon switched back to smoothansi again.

- consoles
I use only Konsole and there I have selected Fixed [Misc]. It seems to be in my case most readable and all the proportions are right.

Offline

Board footer

Powered by FluxBB