You are not logged in.

#1 2006-01-22 07:18:23

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Making media:/ in KDE 3.5 play nicely

media:/ as of now lists only my CD/DVD and flopp drive. I have an external storage drive and need it to list that too so that I don't have to mount it manually. Actually, in KDE 3.4, all my hard disks were in media:/ and I prefer it that way. Now its only removable stuff... How do I change media:/ to list everything I need.

Also, I accidentally deleted the 'avahi' user. How do I get it back?

And for whatever odd reason, dvds will not eject unless I have ivman running along with dbus & hal.

Offline

#2 2006-01-22 08:21:33

dojo
Member
Registered: 2005-11-02
Posts: 96

Re: Making media:/ in KDE 3.5 play nicely

You just have to add a new line for your external drive like that

/dev/hda6               /mnt/hda6               ext3            user,noauto,exec        0       0

It's important to use user and noauto.

Greets

Sunnemer

Offline

#3 2006-01-22 09:36:16

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: Making media:/ in KDE 3.5 play nicely

user and noauto were there in /etc/fstab to start with.

Offline

#4 2006-01-22 18:24:23

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: Making media:/ in KDE 3.5 play nicely

The main reason I need this functionality is so that its easier to mount/umount removable media.. Actually I'm not even sure this is supposed to happen the way I want in KDE 3.5..similarly, when I check "Show Mounted Removable Media" and "Show Mounted Hard Disks" in Configure Desktop(Device icons), I don't see anything on the desktop.

Offline

#5 2006-01-27 00:49:05

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: Making media:/ in KDE 3.5 play nicely

anyone?

Offline

#6 2006-01-27 07:02:36

dojo
Member
Registered: 2005-11-02
Posts: 96

Re: Making media:/ in KDE 3.5 play nicely

Are the required modules loaded for your storage drive? What type of storage drive? What is the output of lsmod?

Greets

Sunnemer

Offline

#7 2006-01-27 08:55:38

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: Making media:/ in KDE 3.5 play nicely

A seagte 200GB IDE drive in a usb 2.0 enclosure. I would like all my HDDs to be seen in media actually.. as for modules, I've built everything into the kernel itself, and I'm able to access the drive with a regular mount. It only doesnt show up in media:/

Offline

#8 2006-01-27 12:58:32

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: Making media:/ in KDE 3.5 play nicely

Provided that you run the current udev/dbus/hal trio, and pmount is installed, just remove any fstab entries for removable devices, as well as custom udev rules for them.
Doing that they should appear at /media when plugged in. dbus and hal should be at the daemons array of /etc/rc.conf, in that particular order.


Microshaft delenda est

Offline

#9 2006-01-27 14:24:14

Snarkout
Member
Registered: 2005-11-13
Posts: 542

Re: Making media:/ in KDE 3.5 play nicely

That doesn't seem to work for firewire drives.  Neither my external firewire/usb2 drive nor my iPod appear in media when attached via firewire.  I've even played with udev rools and adding mount points back.  USB works w/o a hitch, but w/o udev rules, it grabs random sd* locations to mount as, generally incrementing the alpha char (sdb, sdc, sdd, etc) each time I remove and add it.

Is there someplace to read about all of this stuff?  As far as I can tell, the actual "Media Manager" for kde is completely broken, so I've forsaken it.  I'd rather figure out how to get it to work though.


Unthinking respect for authority is the greatest enemy of truth.
-Albert Einstein

Offline

#10 2006-01-27 20:08:13

budman7
Member
Registered: 2006-01-19
Posts: 10

Re: Making media:/ in KDE 3.5 play nicely

You could check out this wiki page.
http://wiki.archlinux.org/index.php/USB_Storage_Devices


Into the great wide open without a clue
Registered Linux user 375921
www.google.com/linux is your friend to find stuff.

Offline

#11 2006-01-28 01:20:16

Dager
Member
Registered: 2006-01-08
Posts: 7

Re: Making media:/ in KDE 3.5 play nicely

Go to kcontrol, go to the Storage Media peripheral, and disable "HAL Backending" as one of your options.

It worked for me. You might need to reboot KDE though.

Offline

#12 2006-01-28 01:55:48

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: Making media:/ in KDE 3.5 play nicely

Dager: works perfectly now, thanks!

Offline

Board footer

Powered by FluxBB