You are not logged in.

#1 2006-01-23 15:34:42

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Update broke me system

Hi,

Just updated system (kernel) & got this error when running lilo

WARNING: The system is unbootable !
         Run LILO again to correct this.Fatal: rename /boot/map~ /boot/map: Permission denied

Errr I loaded these packages ....

Targets: avahi-0.6.5-1 dhcp-3.0.3-2 dvd+rw-tools-6.0-1 gst-plugins-0.8.11-2
         kdelibs-3.5.0-8 kernel26-2.6.15.1-2 pciutils-2.2.1-1 tuxkart-0.4.0-2

Total Package Size:   45.3 MB

Proceed with upgrade? [Y/n] y

checking package integrity... done.
loading package data... done.
upgrading avahi... 
could not extract usr/include/howl: Is a directory
errors occurred while upgrading avahi
done.
reloading dbus configuration... done.

WARNING: The howl and mdnsresponder compatability is experimental.
         Do NOT build howl/mdnsresponder-dependant packages intended for
         distribution while avahi is installed.

upgrading dhcp... done.
upgrading dvd+rw-tools... done.
upgrading gst-plugins... done.
upgrading kdelibs... done.
upgrading kernel26... done.
>>>
>>> If you use the LILO bootloader, you should run 'lilo' before rebooting.
>>>
>>> Generating initial ramdisk.   Please wait...
>>> Generating fallback ramdisk.  Please wait...
upgrading pciutils... done.
upgrading tuxkart... done.

Now I'm do not think I will be able to reboot system ;-(


Mr Green

Offline

#2 2006-01-23 15:51:29

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: Update broke me system

Did you remember to run LILO before rebooting?


oz

Offline

#3 2006-01-23 16:11:52

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: Update broke me system

Yeah thats how I got error above .....


Mr Green

Offline

#4 2006-01-23 16:33:45

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: Update broke me system

oops... I missed the "error" portion of your post.  You can use the installation CD to boot into your installation and maybe fix the problem.  Here's the howto right out of the installation handbook:

How do I reconfigure LILO from the rescue system?

As a first step you simply boot from the Arch Install CD or disks. If your partitions are intact and don't need checking, you should supply the root= kernel boot parameter as the instructions tell you. That will boot directly into your system, and you can skip all but the last step of actually reconfiguring and running lilo.

If you cannot boot your old root directly, boot the CD as if you were going to start an installation. Once you're in a shell, you mount the root partition of your harddisk into the /mnt directory, for example like this:

# mount /dev/hda3 /mnt

Then you mount any other partitions to their respective mount points within that root of yours, for example a /boot partition:

# mount /dev/hda1 /mnt/boot

Now you need to mount a /dev tree in the /mnt area, where lilo will be able to find it:

# /mnt/bin/mount --bind /dev /mnt/dev

Once everything is mounted, make this /mnt directory your new root with the chroot /mnt command. This will start a new shell and drop you into the /mnt directory, which will be considered your / from then on.

Now you can edit /etc/lilo.conf to your liking and run lilo to fix anything that needs fixing. Simply type exit when you want to break out of this root again, back into the original file tree. You can now reboot and test your changes.


oz

Offline

#5 2006-01-23 16:53:08

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: Update broke me system

thanks for that .... emmm is that in wiki .... /looks


Mr Green

Offline

#6 2006-01-24 09:28:22

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: Update broke me system

Well system boots ok

but I cannot remove map~ even as root (which worries me a little!)

no idea whats going on


Mr Green

Offline

Board footer

Powered by FluxBB