You are not logged in.

#1 2006-01-17 00:09:45

fatbird
Member
From: Springboro, PA
Registered: 2005-12-20
Posts: 17

Continual HD activity, high CPU usage when idle

I got my first notebook, a Compaq V2000, a few weeks ago and have Arch set up pretty well on it but I have a few issues.  Even when the machine is sitting idle it sounds like the HD is doing a read (or whatever) about every 5 seconds.  This only starts after I log into Gnome and stops if I log out.

I tried a couple of things with hdparm:

If I try 'hdparm -y /dev/hda' the drive goes to standby but immediately spins up again.

'hdparm -B 255 /dev/hda' disables APM and stops the cyclic behavior.  This would seem to be good but during the 5 second cycle the drive alternates between quiet and noisy and this leaves it in the noisy state.

I tried to determine what might be causing all this disk activity so I edited lilo.conf to remove "acpi=on apm=off" from the "append=" line and in rc.conf I put a ! in front of all modules and daemons and rebooted.  I removed the applets from task bar.  No change.

I ran top to see if I could tell what was accessing the HD but I'm not knowledgable enough to make much sense of it.  I did notice that on my notebook the top summary shows:

CPU: ~30% user, ~10% system, ~60% idle with 'wait' bouncing between 0 and 5% 

On my main computer, also running Arch/Gnome, I get

CPU: ~2% user, ~1% system, ~97% idle with 'wait' solid at 0%

On the notebook, if I run hdparm -B 255 /dev/hda the CPU #'s for user and system remain high but the wait # drops to zero and stays there.

I don't think all this HD activity could be good for my machine, and I know I find it very annoying.  If anyone could help me stop all the HD accesses and understand the high CPU usage I would appreciate it.

Offline

#2 2006-01-17 12:54:50

fatbird
Member
From: Springboro, PA
Registered: 2005-12-20
Posts: 17

Re: Continual HD activity, high CPU usage when idle

Update: By going to the system monitor applet and changing the colors for the HD monitor to make read and write activities easier to distinguish I have determined that my system is writing to the HD every 5 seconds.  Any ideas/suggestions?

Offline

#3 2006-01-25 22:02:08

fatbird
Member
From: Springboro, PA
Registered: 2005-12-20
Posts: 17

Re: Continual HD activity, high CPU usage when idle

Further update: running the Ubuntu live CD and the Knoppix live CD I didn't get the HD activity and CPU useage was normal.  My machine was much quieter and the cooling fan ran much less frequently.

I installed Ubuntu and Vector Linux (w/KDE) and have the same behavior as with Arch.  I don't know if this is normal or not but I feel that my HD is taking an unnecessary beating and battery life is suffering.

Does anyone have any insights?

Offline

#4 2006-01-25 22:17:40

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: Continual HD activity, high CPU usage when idle

Are you taking advantage of "laptop mode"?

Anyway, maybe lsof (pacman -S lsof) would help you track down the cuprit.

Offline

#5 2006-01-26 12:53:26

fatbird
Member
From: Springboro, PA
Registered: 2005-12-20
Posts: 17

Re: Continual HD activity, high CPU usage when idle

I loaded lsof and frankly it scared me.  It listed what looked like a couple hundred files and I didn't know exactly how to use that information.

Then I tried laptop-mode-tools.  The man pages didn't sound too promising since it uses, among other things, hdparm, which I already tried with mixed results.  I gave it a try anyway and right out of the box, with no configuration, it worked.  HD access when idle dropped to essentially none, the drive spins down and the cooling fan runs much less frequently.

So far all I have changed in the config file are the HD idle timeouts.  The default of 5 seconds was starting and stopping the HD too often so I changed that to 20 seconds for now.

Whatever laptop-mode did to stop the 5-second HD accesses the effect persists even if I run 'laptop_mode stop' and '/etc/rc.d/laptop-mode stop'.  When I get the time I should be able to use 'laptop_mode status' and laptop-mode.conf settings to determine exactly what the magic bullet was.

Thanks, lucke.  I never would have tried laptop-mode on my own because I thought it only duplicated functionality that I already had with hdparm and powernowd.

Offline

#6 2006-01-26 18:03:14

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: Continual HD activity, high CPU usage when idle

Glad I could be of some help.

As for lsof, I actually thought about using it by pointing to some (home, root?) partition (lsof /dev/hdXX). That way hopefully you'd be able to determine what causes that read/write operation.

Offline

#7 2006-01-26 18:23:06

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Re: Continual HD activity, high CPU usage when idle

I never recognized the laptop-mode-tools. Good to know.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#8 2006-02-02 16:22:39

fatbird
Member
From: Springboro, PA
Registered: 2005-12-20
Posts: 17

Re: Continual HD activity, high CPU usage when idle

Update:

I finally had time to experiment with the laptop-mode.conf settings.  I enabled verbosity and disabled just about everything else and tracked it down to the fact that laptop-mode remounted my root partition with the command 'mount /dev/hda2 -t ext3 / -o remount,rw,commit=360'.  Without running laptop-mode I can eliminate the 5 sec HD writes by issuing this command in a terminal or by changing 'defaults' to 'defaults,commit=360' in /etc/fstab.

In 'man mount' under 'Mount options for ext3' it says the following:

commit=nrsec
              Sync  all  data  and  metadata  every nrsec seconds. The default
              value is 5 seconds. Zero means default.

Now that I know what is happening I have gone back to letting laptop-mode control things because of the other functionality it provides.

Offline

Board footer

Powered by FluxBB