You are not logged in.

#1 2014-03-05 10:41:26

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

[SOLVED] Docked laptop goes to sleep when booting with closed lid

After booting up, my Thinkpad T400 goes immediately to sleep if it is attached to the docking station and if the lid is closed.  When pressing a key on the external keyboard the laptop wakes up for a second then goes to sleep again.  This behaviour did not occur until the latest update; until then the laptop would not go to sleep when booting with the lid closed.

The system is perfectly usable by having the lid opened, but I don't like to do that.  This is only a minor inconvenience, but pointers are very much appreciated -- I am at loss here.

The following packages have been updated:

[2014-03-05 11:25] [PACMAN] Running 'pacman -Syu'
[2014-03-05 11:25] [PACMAN] synchronizing package lists
[2014-03-05 11:25] [PACMAN] starting full system upgrade
[2014-03-05 11:26] [PACMAN] installed libseccomp (2.1.1-1)
[2014-03-05 11:26] [ALPM-SCRIPTLET] :: systemd has not been reexecuted. It is recommended that you
[2014-03-05 11:26] [ALPM-SCRIPTLET]    reboot at your earliest convenience.
[2014-03-05 11:26] [ALPM-SCRIPTLET] :: Network device naming is now controlled by udev's net_setup_link
[2014-03-05 11:26] [ALPM-SCRIPTLET]    builtin. Refer to the NETWORK LINK CONFIGURATION section of the
[2014-03-05 11:26] [ALPM-SCRIPTLET]    udev manpage for a full description.
[2014-03-05 11:26] [ALPM-SCRIPTLET] :: No changes have been made to your network naming configuration.
[2014-03-05 11:26] [ALPM-SCRIPTLET]    Interfaces should continue to maintain the same names.
[2014-03-05 11:26] [PACMAN] upgraded systemd (208-11 -> 210-2)
[2014-03-05 11:26] [PACMAN] upgraded lib32-systemd (208-2 -> 210-1)
[2014-03-05 11:26] [PACMAN] upgraded libunique (1.1.6-5 -> 1.1.6-6)
[2014-03-05 11:26] [PACMAN] upgraded orbit2 (2.14.19-2 -> 2.14.19-3)
[2014-03-05 11:26] [PACMAN] upgraded seed (3.8.1-2 -> 3.8.1-3)
[2014-03-05 11:26] [PACMAN] upgraded systemd-sysvcompat (208-11 -> 210-2)
[2014-03-05 11:26] [PACMAN] upgraded xterm (301-1 -> 302-1)

Last edited by ball (2014-03-07 09:38:08)

Offline

#2 2014-03-05 11:53:21

aluemku
Member
Registered: 2014-03-05
Posts: 2

Re: [SOLVED] Docked laptop goes to sleep when booting with closed lid

Same Problem on my Lenovo B560. Fixed problem by downgrading packages systemd and systemd-sysvcompat to 208-11 from pgk-cache.

sudo pacman -U /var/cache/pacman/pkg/systemd-208-11-x86_64.pkg.tar.xz /var/cache/pacman/pkg/systemd-sysvcompat-208-11-x86_64.pkg.tar.xz

For now it's working ... (no time to investigate more)

Last edited by aluemku (2014-03-05 11:54:01)

Offline

#3 2014-03-05 12:05:17

frank
Member
From: Karlsruhe/Germany
Registered: 2014-02-06
Posts: 6

Re: [SOLVED] Docked laptop goes to sleep when booting with closed lid

Hello,

I have the same problem (Lenovo T500 + docking station). I think it's related to the latest systemd update (version 210).
logind suspends the system if it detects that the lid is closed and, according to Lennart Poettering, ACPI docking stations doesn't implement the SW_DOCK switch, which would prevent logind from doing so.

You can find more info here: http://lists.freedesktop.org/archives/s … 17362.html

Offline

#4 2014-03-05 12:07:53

gegenschall
Member
From: Munich, Germany
Registered: 2013-10-09
Posts: 33

Re: [SOLVED] Docked laptop goes to sleep when booting with closed lid

Same problem here. This is due to a change in systemd-logind (see here). Systemd-logind now watches the laptop lid's state continously, not only for events. There are two commits (here and here) that should fix this behaviour for us. For the meantime it should suffice adding the two patches to systemd-210, but I didn't test it.

I'll file a bug against systemd with the Arch bugtracker, when I've got time.

edit: It gets better if you set lidSwitchIgnoreInhibited=no in /etc/systemd/logind.conf

Last edited by gegenschall (2014-03-05 12:10:01)

Offline

#5 2014-03-05 12:21:31

aluemku
Member
Registered: 2014-03-05
Posts: 2

Re: [SOLVED] Docked laptop goes to sleep when booting with closed lid

The following setting in "/etc/systemd/logind.conf" worked for me, even after updating to systemd-210-2 again.

HandleLidSwitch=ignore

Thanks to @frank (my mistake) @gegenschall.

Last edited by aluemku (2014-03-05 20:33:46)

Offline

#6 2014-03-05 17:19:19

frank
Member
From: Karlsruhe/Germany
Registered: 2014-02-06
Posts: 6

Re: [SOLVED] Docked laptop goes to sleep when booting with closed lid

I can confirm your solution, @aluemku. Thanks for the hint!
Setting LidSwitchIgnoreInhibited=no didn't work for me.

Offline

Board footer

Powered by FluxBB