You are not logged in.

#1 2014-03-04 09:38:51

LiquidityC
Member
From: Sweden
Registered: 2011-09-24
Posts: 11

[SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

After performing my morning routine (pacman -Syu) at work I noticed eclipse started crashing alot which it hasn't been doing before. Narrowed it down to the webkitgtk2 upgrade that had occured during the last upgrade.

Downgrading (2.2.5-2 => 1.10.2-8) solved the issue, and at the moment that is the only solution I am aware of. Anyone else got any lead on this?

I'm running AwesomeWM, no gnome or KDE packages installed. This issue might not occur if you are using a more "extensive" wm.

Last edited by LiquidityC (2014-10-22 07:14:47)

Offline

#2 2014-03-04 14:23:41

Spider.007
Member
Registered: 2004-06-20
Posts: 1,150
Website

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

This happens on Gnome too. Not sure where to report this; would a rebuild of the eclipse package fix this?

Offline

#3 2014-03-04 14:54:54

LiquidityC
Member
From: Sweden
Registered: 2011-09-24
Posts: 11

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

Perhaps, I'll try a rebuild through ABS and see if that fixes the issue. Not sure it will though...


EDIT: Nope, totally didn't work sad

Last edited by LiquidityC (2014-03-04 15:02:38)

Offline

#4 2014-03-04 14:58:40

Spider.007
Member
Registered: 2004-06-20
Posts: 1,150
Website

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

Actually, I don't expect it as the PKGBUILD simply fetches the jar from eclipse and doesn't really compile anything

Offline

#5 2014-03-04 15:15:06

LiquidityC
Member
From: Sweden
Registered: 2011-09-24
Posts: 11

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

I think this one will just have to wait for a new Eclipse package. Just have to ignore the webkitgtk2 upgrade until then I guess

Offline

#6 2014-03-05 07:44:26

LiquidityC
Member
From: Sweden
Registered: 2011-09-24
Posts: 11

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

New eclipse package arrived today which solves this issue, so I'm marking this one as solved.

Offline

#7 2014-03-05 10:37:26

milonimrod
Member
Registered: 2014-03-05
Posts: 1

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

LiquidityC wrote:

New eclipse package arrived today which solves this issue, so I'm marking this one as solved.

Upgrading to the new eclipse (extra/eclipse 4.3.2-2) didn't solve the problem still had to downgrade webkitgtk2 to solve the issue.

Offline

#8 2014-03-05 10:39:24

LiquidityC
Member
From: Sweden
Registered: 2011-09-24
Posts: 11

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

Spoke too soon, tested properly again and milonimrod is right.

Offline

#9 2014-03-05 12:54:44

yupi
Member
Registered: 2012-12-10
Posts: 17

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

A temporary solution is to put

-Dorg.eclipse.swt.browser.DefaultType=mozilla

into eclipse.ini.

From http://wyldeplayground.net/eclipse-kepl … log-entry/

Offline

#10 2014-03-05 17:43:43

darose
Member
Registered: 2004-04-13
Posts: 120

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

Sounds like this could use a bug ticket

Offline

#11 2014-03-05 17:46:10

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,122

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

Offline

#12 2014-03-20 13:27:48

neo007
Member
Registered: 2012-09-10
Posts: 10

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

I also have this issue. I can confirm that using -Dorg.eclipse.swt.browser.DefaultType=mozilla helps.

Offline

#13 2014-03-21 09:03:01

jancici
Member
From: Kalinovo,SK
Registered: 2011-12-04
Posts: 119

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

I am starting eclipse from console like this:

eclipse -Dorg.eclipse.swt.browser.DefaultType=mozilla

and eclipse is still crashing

I am not able to find eclipse.ini, can you give me a path?

well, I am not able to downgrade webkitgtk because I have not older file in cache, can someone give me a link to download?

thanks

Offline

#14 2014-03-21 09:07:35

student975
Member
From: Russian Federation
Registered: 2011-03-05
Posts: 603

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

jancici wrote:

I am starting eclipse from console like this:

eclipse -Dorg.eclipse.swt.browser.DefaultType=mozilla

The option must be added to eclipse.ini.


"I exist" is the best myth I know..

Offline

#15 2014-03-21 11:44:04

jancici
Member
From: Kalinovo,SK
Registered: 2011-12-04
Posts: 119

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

aha, I was trying to find eclipse.ini in home directory
but it is here:  /usr/share/eclipse/eclipse.ini

looks that this helped, I will see what happen in time ...

Offline

#16 2014-10-21 09:00:44

RazZziel
Member
From: Spain
Registered: 2007-07-13
Posts: 35

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

Got this error again after last system upgrade, which updated webkitgtk2 from 2.4.5-1 to 2.4.6-2

The -Dorg.eclipse.swt.browser.DefaultType=mozilla workaround seems to solve the issue.

Offline

#17 2014-10-21 09:23:14

LiquidityC
Member
From: Sweden
Registered: 2011-09-24
Posts: 11

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

I got it too. But in my case it was the fact that eclipse upgraded to "Luna" and that replaced my old eclipse.ini file with a new one so I had to add the workaround into the new eclipse.ini file

Offline

#18 2014-10-21 18:18:29

jancici
Member
From: Kalinovo,SK
Registered: 2011-12-04
Posts: 119

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

- well, I am running eclipse luna for a while, no problems.
- I did check eclipse.ini and it is NOT contait this workaround.
-

pacman -Qs webkitgtk2
local/webkitgtk2 2.4.6-3

Offline

#19 2014-10-22 07:12:53

LiquidityC
Member
From: Sweden
Registered: 2011-09-24
Posts: 11

Re: [SOLVED~] Upgrading to webkitgtk2-2.2.5-2 causes Eclipse crash

I still have the crash issue on my machine in eclipse when hovering 'String' or any other javadoc object. Workaround mentioned above removes the issue though

Name           : webkitgtk2
Version        : 2.4.6-3
Description    : GTK+ Web content engine library for GTK2
Architecture   : x86_64
URL            : http://webkitgtk.org/
Licenses       : custom
Groups         : None
Provides       : libwebkit=2.4.6
Depends On     : libxt  libxslt  sqlite  libsoup  enchant  libgl  geoclue2  gst-plugins-base-libs  libsecret  libwebp  harfbuzz-icu  gtk2
Optional Deps  : gst-plugins-base: free media decoding [installed]
                 gst-plugins-good: media decoding
                 gst-libav: nonfree media decoding
Required By    : eclipse
Optional For   : gimp
Conflicts With : libwebkit
Replaces       : libwebkit
Installed Size : 44561.00 KiB
Packager       : Felix Yan <felixonmars@archlinux.org>
Build Date     : 2014-10-17T09:14:19 CEST
Install Date   : 2014-10-21T08:47:47 CEST
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By   : Signature

Offline

Board footer

Powered by FluxBB