You are not logged in.

#1 2014-03-06 09:41:22

adoa
Member
Registered: 2012-02-08
Posts: 22

Miro is broken and has no maintainer

After having been away for a week and doing the usual upgrading afterwards, I realized yesterday that miro no longer starts … again. The error messages look a lot like some time ago, cf. https://bbs.archlinux.org/viewtopic.php?id=151873
The solution then was to make webkitgtk2 use gstreamer0.10 (https://bugs.archlinux.org/task/32424) since miro is still incompatible with gstreamer1.0 nonetheless – their team is working on that, cf. http://bugzilla.pculture.org/show_bug.cgi?id=19716
I guess now almost everything except miro is using gstreamer1.0, so I guess this is hard to fix for any user or maintainer. However, I was not able to find the indirect dependency on gstreamer1.0. Is it actually webkitgkt2 again, although miro does not seem to depend on that?

Moreover, Miro has no maintainer anymore and it was pushed from [extra] or [community] to the AUR– does that mean this is not going to be fixed? I would maybe do that but I have no idea what to do and I will not have time to find out before May/June.

Is there anyone else around with the same error messages, or at least using miro? Using an orphaned package is never a good idea :-/

Last edited by adoa (2014-03-08 08:49:11)

Offline

#2 2014-03-06 10:07:01

adoa
Member
Registered: 2012-02-08
Posts: 22

Re: Miro is broken and has no maintainer

Downgrading webkitgkt2 (2.2.5-2 => 1.10.2-8) solves the issue. However that feels like a very bad workaround.

[edit:] I now opened another thread with questions about webkitgtk2, which is somewhat related to this: https://bbs.archlinux.org/viewtopic.php?id=17809
Nonetheless, I think the question about maintenance of miro is still a separate issue.

Last edited by adoa (2014-03-06 10:37:34)

Offline

#3 2014-03-06 14:58:12

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: Miro is broken and has no maintainer

Offline

#4 2014-03-08 08:49:58

adoa
Member
Registered: 2012-02-08
Posts: 22

Re: Miro is broken and has no maintainer

So it looks like Miro is broken for quite some time. It is a pity that it is unusable in Arch :-/

Offline

#5 2014-03-08 14:55:02

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 318

Re: Miro is broken and has no maintainer

adoa wrote:

So it looks like Miro is broken for quite some time. It is a pity that it is unusable in Arch :-/

Not to state the obvious - miro is in the AUR and therefore only requires you to "adopt" it and it's yours to maintain...?

Offline

#6 2014-03-08 15:14:24

adoa
Member
Registered: 2012-02-08
Posts: 22

Re: Miro is broken and has no maintainer

I very much aware of the fact that everyone could adopt the package. Nonetheless, I am not a developer and never maintained any package. Moreover, I will not have time digging into this before June.

But as far as I understood, this is not so much a maintenance issue: Miro is just very basically incompatible with gstreamer1.0 while this is the only gstreamer version supported by webkitgtk in Arch. To me this sounds like the only proper solution is to fix the ticket http://bugzilla.pculture.org/show_bug.cgi?id=19716 and basically port Miro to gstreamer1.0.

My knowledge is not sufficient to do anything like that and I have by far not enough expertise to come up with another solution or workaround. Using an old and possibly dangerous version of webkitgtk (which, out of necessity, I currently do) definitely is not a solution for the long term. I think I will have to move away from Miro, even though I really like the program.

Offline

#7 2014-03-08 15:42:24

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,414

Re: Miro is broken and has no maintainer

Moving to AUR issues.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#8 2014-03-12 20:24:25

Strubbl
Member
Registered: 2013-12-10
Posts: 8

Re: Miro is broken and has no maintainer

adoa wrote:

Using an old and possibly dangerous version of webkitgtk (which, out of necessity, I currently do) definitely is not a solution for the long term. I think I will have to move away from Miro, even though I really like the program.

Can you post this workaround to make Miro work again?

Offline

#9 2014-03-12 20:41:06

adoa
Member
Registered: 2012-02-08
Posts: 22

Re: Miro is broken and has no maintainer

You just have to downgrade webkitgtk2 to an older version using pacman:

 pacman -U /var/cache/pacman/pkg/webkitgtk2<in-the-right-version> 

Not entirely sure whether I got the path right (not sitting at my Arch machine right now). This obviously only works if your package cache was not cleaned recently. In order for miro to keep working, you must not upgrade webkitgtk2 as long as this problem is present – which might be forever. Please be aware that this is dangerous! Your system might face severe problems. Partial upgrades are not supported in Archlinux.

You should only use this temporarily to export your feedlist as OPML and move to a different podcatcher. Seriously.

Offline

Board footer

Powered by FluxBB