You are not logged in.

#1 2014-03-09 06:20:00

Jeol
Member
Registered: 2014-03-09
Posts: 5
Website

Building Wireless Driver

I wasn't sure exactly where to put this, but I decided since it has to do with idiotic wireless laptop hardware it fit in this forum.

My problem is, I have an ultrabook, the Lenovo Yoga 13. It ships with the Realtek RTL8723au. Most distros I've done fine with, since I have the driver on an external hard drive that I can build pre-installation if needed, or even post-installation. I really want to use Arch, but it turns out that not only do you have to be connected to the Internet to install the system, it doesn't even ship with the 'make' system: to be able to use 'make', I'd have to install it from the package manager. There's just one tiny problem with that. I can't get the package without the driver, and I can't install the driver without the package.

And as brilliantly as these ultrabooks are designed, they don't come with a built-in ethernet port. I could get one by USB, but I'd prefer to work with the base system as much as possible. Besides, I wouldn't mind the experience if I could get it to work, which was the reason I decided to pick up Arch in the first place.

My question is, is there a way I can build my wireless driver without condoning the use of third-party hardware?

Offline

#2 2014-03-09 09:24:01

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,835

Re: Building Wireless Driver

Boot with some live iso that includes the necessary build tools, build your driver on that, get online, install Arch this way, build your driver on Arch, reboot.

Optional extras - create a package for your driver so that pacman can manage it, submit that package to the AUR to make it easier for others in the same circumstances.

Offline

#3 2014-03-10 05:25:08

Jeol
Member
Registered: 2014-03-09
Posts: 5
Website

Re: Building Wireless Driver

Okay, thanks! I have Archlinux installed now, but I still don't have the wireless card working. I gave up and plugged in my ethernet adapter to be surprised that it actually works without any driver issues. In fact, I didn't have to do anything. But, I still have to get my wireless card working somehow.

I got the make package installed and installed the linux headers so as to be able to build it, and used dkms like the readme tells me to for legacy's sake, but it won't let me make a new connection, and sometimes it acts like it doesn't even see it. lscpi | grep -i net comes up with nothing, iw dev shows nothing, and ip link doesn't really give any crucial information either - most of the stuff I can find is just about the ethernet port that is already working, and when I unplug it and look again, it acts exactly how I don't want it to, like nothing's there. I really don't understand, since I made sure the driver didn't return any errors during building. Any ideas?

Offline

#4 2014-03-10 07:52:45

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,835

Re: Building Wireless Driver

What does dmesg show when you load the driver?

Offline

#5 2014-03-10 19:49:38

Jeol
Member
Registered: 2014-03-09
Posts: 5
Website

Re: Building Wireless Driver

I'll c/p what I saw when I was going through it.

[...]
[ 1.859114] usbcore: registered new interface driver rtl8723au
[ 1.876146] systemd-udevd[148]: starting version 210
[ 1.884909] usb 3-1.3: new high-speed USB device number 3 using ehci-pci
[ 1.916706] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20131115/utaddress-251)
[ 1.916713] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 1.916717] ACPI Warning: 0x0000000000000530-0x000000000000053f SystemIO conflicts with Region \GPIO 1 (20131115/utaddress-251)
[ 1.916720] ACPI Warning: 0x0000000000000530-0x000000000000053f SystemIO conflicts with Region \_SB_.PCI0.LPCB.H_EC.GPIO 2 (20131115/utaddress-251)
[ 1.916722] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 1.916723] ACPI Warning: 0x0000000000000500-0x000000000000052f SystemIO conflicts with Region \GPIO 1 (20131115/utaddress-251)
[ 1.916725] ACPI Warning: 0x0000000000000500-0x000000000000052f SystemIO conflicts with Region \_SB_.PCI0.LPCB.H_EC.GPIO 2 (20131115/utaddress-251)
[ 1.916728] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[...]
[ 2.816491] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[...]
[ 4.826065] RTL8723AU: ERROR nolinked power save enter
[...]

Offline

#6 2014-03-11 09:30:20

Arup
Member
From: Earth
Registered: 2014-02-20
Posts: 38

Re: Building Wireless Driver

https://github.com/lwfinger/rtl8723au Download this and make and install, remember to repeat process with every new kernel.

Offline

#7 2014-03-11 11:29:22

Jeol
Member
Registered: 2014-03-09
Posts: 5
Website

Re: Building Wireless Driver

Do I have to delete all instances of the driver throughout the filesystem first?

Still didn't work. I tried updating my Linux-headers too, which did update, but it didn't help. hmm

-----

I decided to check dmesg again, ran dmesg | grep -i net , and noticed the interfaces were actually up, just not being mentioned by iw dev. I downloaded NetworkManager, and fancy that, all the local networks came up! The only problem now is that NM won't connect to anything (I can make a connection, but it 'disconnects'), and I can't connect to my ethernet (which is why I know it's NM), but I'll probably figure it out in time. Thanks for all your help!

Last edited by Jeol (2014-03-11 13:43:36)

Offline

Board footer

Powered by FluxBB