You are not logged in.

#1 2014-03-12 18:23:47

PatronMaster
Member
Registered: 2013-12-15
Posts: 10

[Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

Hello guys,

I need five minutes of your knowledge.

I can not get to work the cgminer, Steam works fine.
I am using:
AMD/ATI       Open source      xf86-video-ati     lib32-ati-dri     ATI
I do not like AMD Catalyst drivers, very slow

ERROR of CGminer

Started cgminer 4.1.0
Loaded configuration file /home/user/.cgminer/cgminer.conf
Fatal JSON error in configuration file
Configuration file could not be used.
a1_board_selector_init() cold not open i2c-1.39: Permission denied
Failed to init board selector
SPI: Can not open SPI device /dev/spidev0.0modprobe : FATAL: Module i2c-bcm2708 not found
BlackArrowBitFuryGPIO failed to modprobe i2c-bcm2708 (256) - you need to be root?
Minion BlackArrow: failed to modprobe i2c-bcm2708 (256) - you need to be root?
No devices detected!
Waiting for USB hotplug devices or press q to quit
lspci | grep VGA
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cayman XT [Radeon HD 6970]

pacman -Q xf86-video-ati
xf86-video-ati 1:7.3.0-1

pacman -Q lib32-ati-dri
lib32-ati-dri 10.1.0-2

Please help me
I tried find in the forum and wiki the solution

I'm new in archlinux, explain in detail
Thanks for the help

Last edited by PatronMaster (2014-03-24 17:53:43)

Offline

#2 2014-03-13 10:58:17

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,149

Re: [Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

https://bitcointalk.org/index.php?topic=28402.0

cgminer faq wrote:

Q: What happened to CPU and GPU mining?
A: Their efficiency makes them irrelevant in the bitcoin mining world today
and the author has no interest in supporting alternative coins that are better
mined by these devices.

Looks like latest version of cgminer only works with special hardware.

You will need to build https://aur.archlinux.org/packages/cgminer-gpu/ from AUR, check https://wiki.archlinux.org/index.php/AUR .

You will also face another issue, official mesa/ati-dri don't have OpenCL support yet.
Currently there are 3 options to run mesa with opencl on archlinux :

AUR mesa-cl
based on official mesa version
https://aur.archlinux.org/packages/mesa-cl/

AUR mesa-r300-r600-radeonsi-git
development version for radeon cards only
https://aur.archlinux.org/packages/mesa … eonsi-git/

[mesa-git]
unofficial  repo maintained by arch developer LordHeavy
development version
http://pkgbuild.com/~lcarlier/


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2014-03-13 15:14:45

okubax
Member
From: London
Registered: 2010-04-24
Posts: 181
Website

Re: [Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

PatronMaster wrote:

Hello guys,

I need five minutes of your knowledge.

I can not get to work the cgminer, Steam works fine.
I am using:
AMD/ATI       Open source      xf86-video-ati     lib32-ati-dri     ATI
I do not like AMD Catalyst drivers, very slow

ERROR of CGminer

Started cgminer 4.1.0
Loaded configuration file /home/user/.cgminer/cgminer.conf
Fatal JSON error in configuration file
Configuration file could not be used.
a1_board_selector_init() cold not open i2c-1.39: Permission denied
Failed to init board selector
SPI: Can not open SPI device /dev/spidev0.0modprobe : FATAL: Module i2c-bcm2708 not found
BlackArrowBitFuryGPIO failed to modprobe i2c-bcm2708 (256) - you need to be root?
Minion BlackArrow: failed to modprobe i2c-bcm2708 (256) - you need to be root?
No devices detected!
Waiting for USB hotplug devices or press q to quit
lspci | grep VGA
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cayman XT [Radeon HD 6970]

pacman -Q xf86-video-ati
xf86-video-ati 1:7.3.0-1

pacman -Q lib32-ati-dri
lib32-ati-dri 10.1.0-2

Please help me
I tried find in the forum and wiki the solution

I'm new in archlinux, explain in detail
Thanks for the help

Or just use bfgminer. It's what I've been using since my GPU stopped working with cgminer, and it supports CPU or GPU mining

Offline

#4 2014-03-13 21:40:50

PatronMaster
Member
Registered: 2013-12-15
Posts: 10

Re: [Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

Hi okubax and Lone_Wolf

Thanks for the reply, but still with the same problem.

First tried the easiest solution:

pacman -Q bfgminer 
bfgminer 3.10.0-1


 Connected to litecoinpool.org diff 64 with stratum as user XXX
 Block: ...b84af96315fd4b81  Diff:4.72k (33.78Gh/s)  Started: [21:01:33]
 ST:2  F:0  NB:1  AS:0  BW:[ 76/ 19 B/s]  E:0.00  I: 0.00 BTC/hr  BS:0
 0            |   0.0/  0.0/  0.0 h/s | A:0 R:0+0(none) HW:0/none
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
NO DEVICES FOUND: Press 'M' and '+' to add
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 [2014-03-13 21:01:05] Waiting for devices; press 'M+' to add, or 'Q' to quit
 [2014-03-13 21:01:05] Need to specify at least one pool server.
Input server details.
 [2014-03-13 21:01:32] Pool 0 stratum+tcp://litecoinpool.org:3333 alive
 [2014-03-13 21:01:32] Probing for an alive pool
 [2014-03-13 21:01:32] Pool 0 stratum+tcp://litecoinpool.org:3333 alive
 [2014-03-13 21:01:33] Network difficulty changed to 4.72k (33.78Gh/s)

But have the same issue like cgminer


AUR mesa-r300-r600-radeonsi-git

Install or build missing dependencies for mesa-r300-r600-radeonsi-git:
error: target not found: libclc-git

I could not find this package.The closest I found was libclc-svn


AUR mesa-cl

Found some errors due to lack of packages as presentproto and dri3proto.
I install first presentproto and dri3proto
But a new error appeared

:: mesa-cl and mesa are in conflict. Remove mesa? [y/N] y
:: mesa-libgl-cl and mesa-libgl are in conflict. Remove mesa-libgl? [y/N] y
:: ati-dri-cl and ati-dri are in conflict. Remove ati-dri? [y/N] y

Packages (10): ati-dri-10.1.0-2 [removal]  mesa-10.1.0-2 [removal]  mesa-libgl-10.1.0-2 [removal]  ati-dri-cl-10.1.0-1  intel-dri-cl-10.1.0-1  mesa-cl-10.1.0-1  mesa-libcl-10.1.0-1  mesa-libgl-cl-10.1.0-1  nouveau-dri-cl-10.1.0-1
               svga-dri-cl-10.1.0-1

Total Installed Size:   99.73 MiB
Net Upgrade Size:       41.86 MiB

:: Proceed with installation? [Y/n] y
(7/7) checking keys in keyring                                                                                                                 [########################################################################################] 100%
(7/7) checking package integrity                                                                                                               [########################################################################################] 100%
(7/7) loading package files                                                                                                                    [########################################################################################] 100%
(7/7) checking for file conflicts                                                                                                              [########################################################################################] 100%
error: failed to commit transaction (conflicting files)
mesa-libcl: /usr/lib/libOpenCL.so exists in filesystem
mesa-libcl: /usr/lib/libOpenCL.so.1 exists in filesystem
mesa-libcl: /usr/lib/libOpenCL.so.1.0.0 exists in filesystem
Errors occurred, no packages were upgraded.

I already have installed cgminer 3.7.2 but without AUR mesa-cl or AUR mesa-r300-r600-radeonsi-git does not work like you said

 [2014-03-13 21:30:07] Started cgminer 3.7.2
 [2014-03-13 21:30:07] Loaded configuration file /home/user/.cgminer/cgminer.conf
 [2014-03-13 21:30:07] Fatal JSON error in configuration file.
 [2014-03-13 21:30:07] Configuration file could not be used.
 [2014-03-13 21:30:07] Error -1001: clGetPlatformsIDs failed (no OpenCL SDK installed?)
 [2014-03-13 21:30:07] clDevicesNum returned error, no GPUs usable
 [2014-03-13 21:30:07] No devices detected!
 [2014-03-13 21:30:07] Waiting for USB hotplug devices or press q to quit
 [2014-03-13 21:30:07] Probing for an alive pool
 [2014-03-13 21:30:07] Pool 0 difficulty changed to 64
 [2014-03-13 21:30:08] Network diff set to 4.72K

Offline

#5 2014-03-14 13:12:02

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,149

Re: [Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

libclc-git comes from lordheavy's unofficial [mesa-git] repo, see http://pkgbuild.com/~lcarlier/mesa-git/ .

(it also has llvm/clang svn versions, so saves buiding time).

the mesa-cl file conflicts suggests it hasn' been updated to work with latest changes in official mesa packages, you should post something on it's aur page.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#6 2014-03-15 17:43:12

PatronMaster
Member
Registered: 2013-12-15
Posts: 10

Re: [Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

Hi again,

Thanks for the tips.
I tried to install without success.
I manually installed:

pacman -Q llvm-svn
llvm-svn 202852-1

pacman -Q llvm-libs-svn
llvm-libs-svn 202852-1

pacman -Q lib32-llvm-libs-svn
lib32-llvm-libs-svn 202858-1

pacman -Q lib32-llvm-svn
lib32-llvm-svn 202858-1

pacman -Q libclc-git
libclc-git 116.20140304-1

All these packages are required to install:
AUR mesa-r300-r600-radeonsi-git


But it gave this error:

In the
:: clang-svn and llvm-svn are in conflict (llvm). Remove llvm-svn? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: lib32-llvm-svn: requires llvm-svn
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-patron
==> Restart building mesa-r300-r600-radeonsi-git ? [y/N]
==> ----------------------------------------------------
==> 

At the end of these packages had to be removed.
First I need to install to run, then I have to remove.
Seen what I've done stupid things so I stopped.

Offline

#7 2014-03-15 19:19:16

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,149

Re: [Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

PatronMaster,

first some general tips :
- before building any AUR package, always run pacman -Syu.
especially when using git/svn packages you always want your system to have latest versions.
for example, latest llvm/clang versions in mesa-git repo are 204002-1 .

- when there are building problems with yaourt (or other AUR he[pers), try building with makepkg instead.

About the problem :
clang-svn and llvm-svn from mesa-git don't conflict, but i'm not sure about AUR llvm-svn & clang-svn.
If you used 1 of those, then there may be something wrong with the provides in AUR clang-svn package.

summary :
run pacman -Syu
download latest mesa-r* tarball from aur
extract it to a build folder somewhere in your home folder
(i use ~/Documents/WIP/pkgbuilds/ )
cd into the folder where you extracted the tarball
run makepkg

Incase you feel building mesa-r* is to much work, you can also use ati-dri-git and companions from mesa-git repo.
pacman -S ati-dri-git opencl-mesa-git libclc-git
should be enough to pull in everything that's needed from mesa-git repo.


Edit (also posted on mesa-r300-r600-radeonsi-git aur page) :

for reference (see below) i've just build the package again on my own system with makepkg, and have no conflict between clang-svn and llvm-svn (both from mesa-git repo).


[panoramix@obelix mesa-r300-r600-radeonsi-git]$ makepkg
==> Making package: mesa-r300-r600-radeonsi-git 61886.7554539-2 (zo mrt 16 15:00:10 CET 2014)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Missing dependencies:
-> llvm-svn
-> libclc-git
-> clang-svn
==> ERROR: Could not resolve all dependencies.
[panoramix@obelix mesa-r300-r600-radeonsi-git]$ sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
LoneVVolf is up to date
mesa-git is up to date
:: Starting full system upgrade...
there is nothing to do
[panoramix@obelix mesa-r300-r600-radeonsi-git]$ sudo pacman -S llvm-svn libclc-git clang-svn
resolving dependencies...
looking for inter-conflicts...

Packages (3):

Name New Version Net Change

mesa-git/clang-svn 204002-1 113.04 MiB
mesa-git/libclc-git 116.20140315-1 10.27 MiB
mesa-git/llvm-svn 204002-1 78.93 MiB

Total Installed Size: 202.24 MiB

:: Proceed with installation? [Y/n]
(3/3) checking keys in keyring [#############################################] 100%
(3/3) checking package integrity [#############################################] 100%
(3/3) loading package files [#############################################] 100%
(3/3) checking for file conflicts [#############################################] 100%
(3/3) checking available disk space [#############################################] 100%
(1/3) installing llvm-svn [#############################################] 100%
(2/3) installing libclc-git [#############################################] 100%
(3/3) installing clang-svn [#############################################] 100%
[panoramix@obelix mesa-r300-r600-radeonsi-git]$ makepkg
==> Making package: mesa-r300-r600-radeonsi-git 61886.7554539-2 (zo mrt 16 15:01:18 CET 2014)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Updating mesa-r300-r600-radeonsi-git git repo...
Fetching origin
remote: Counting objects: 51, done.
remote: Compressing objects: 100% (36/36), done.
remote: Total 36 (delta 31), reused 0 (delta 0)
Unpacking objects: 100% (36/36), done.
From git://anongit.freedesktop.org./git/mesa/mesa
7554539..2e36116 master -> master
-> Found LICENSE
==> Validating source files with md5sums...
mesa-r300-r600-radeonsi-git ... Skipped
LICENSE ... Passed
==> Extracting sources...
-> Creating working copy of mesa git repo...
Cloning into 'mesa-r300-r600-radeonsi-git'...
done.
Checking out files: 100% (4218/4218), done.
Branch makepkg set up to track remote branch master from origin.
Switched to a new branch 'makepkg'
==> Starting pkgver()...
==> Updated version: mesa-r300-r600-radeonsi-git 61891.2e36116-1
==> Removing existing pkg/ directory...
==> Starting build()...

Last edited by Lone_Wolf (2014-03-16 14:07:50)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#8 2014-03-22 17:00:15

PatronMaster
Member
Registered: 2013-12-15
Posts: 10

Re: [Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

hi there,
thanks for the support and explain to new users, it has not been easy for me to solve this problem.


After ading pacman.conf,

[mesa-git]
Server = http://pkgbuild.com/~lcarlier/$repo/$arch 

and

pacman -Syu
pacman -U mesa-r300-r600-radeonsi-git-61996.4c79f08-1-x86_64.pkg.tar.xz

It's work well the instalation

pacman -Q mesa-r300-r600-radeonsi-git 
mesa-r300-r600-radeonsi-git 61996.4c79f08-1

Cgminer recognizes the card

cgminer -n

 [2014-03-22 19:49:51] CL Platform 0 vendor: Mesa                    
 [2014-03-22 19:49:51] CL Platform 0 name: Default                    
 [2014-03-22 19:49:51] CL Platform 0 version: OpenCL 1.1 MESA 10.2.0-devel                    
 [2014-03-22 19:49:51] Platform 0 devices: 1                    
 [2014-03-22 19:49:51] 	0	AMD CAYMAN                    
 [2014-03-22 19:49:51] 1 GPU devices max detected                    
 [2014-03-22 19:49:51] USB all: found 10 devices - listing known devices                    
 [2014-03-22 19:49:51] No known USB devices     

You can mark with solve
Without you, it was impossible

Last edited by PatronMaster (2014-03-22 20:26:50)

Offline

#9 2014-03-23 13:03:44

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,149

Re: [Solved] Cgminer not working with AMD/ATI Open source xf86-video-ati

Getting OpenCL with open source drivers to work on archlinux is tricky, glad you got it working, PatronMaster .

Please edit the title of your first post in this thread to include [solved].


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB