You are not logged in.

#1 2014-03-17 01:11:21

polson136
Member
Registered: 2012-03-03
Posts: 39

SOLVED: error: libEGL.so.1 not found

After a recent update, several of my graphical applications are broken.

They all give the same error message: libEGL.so.1: cannot open shared object file: No such file or directory

Affected programs: firefox, thunderbird, lightdm-gtk2-greeter, lightdm-gtk3-greeter, and probably many more, these are the ones I am aware of.

I don't even know where to begin with this. Any thoughts? I don't even know what package would provide this.

Last edited by polson136 (2014-03-17 01:30:59)

Offline

#2 2014-03-17 01:13:26

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,291

Re: SOLVED: error: libEGL.so.1 not found

You didn't tell us what graphics driver you use. If catalyst, check the AMD bar and grill, otherwise, update your system, including the *-libgl package.

Offline

#3 2014-03-17 01:13:55

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: SOLVED: error: libEGL.so.1 not found

What's the output of 'ls /usr/lib/libEGL.so.1'?
https://bugs.archlinux.org/task/39374

Offline

#4 2014-03-17 01:14:22

anatolik
Developer
Registered: 2012-09-27
Posts: 437

Re: SOLVED: error: libEGL.so.1 not found

This bug seems related https://bugs.archlinux.org/task/39374

Offline

#5 2014-03-17 01:20:40

polson136
Member
Registered: 2012-03-03
Posts: 39

Re: SOLVED: error: libEGL.so.1 not found

I am using nvidia-173xx from the AUR. I'll take a look to see if any of the packages are broken.

The file you mention does not exist.

I'll take a look at the bug you mentioned.

Any progress will be slow because I only have links and mobile firefox.

Offline

#6 2014-03-17 01:23:45

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,291

Re: SOLVED: error: libEGL.so.1 not found

If you're using an AUR package, you need to talk to it's maintainer to fix this. The mesa packaging has changed and the driver package needs to keep up.

Offline

#7 2014-03-17 01:23:57

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: SOLVED: error: libEGL.so.1 not found

Read the comments for that package.

Offline

#8 2014-03-17 01:30:26

polson136
Member
Registered: 2012-03-03
Posts: 39

Re: SOLVED: error: libEGL.so.1 not found

I found the answer in the comments in the nvidia-173xx package. It said to "ln -s /usr/lib/mesa/libEGL.so.1 /usr/lib". Thanks so much for the help. I didn't know that it was a driver issue. I assumed it was a library issue.

Offline

#9 2014-03-17 01:36:35

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: SOLVED: error: libEGL.so.1 not found

These symlinks need to be added to the PKGBUILD https://aur.archlinux.org/packages/nvidia-173xx-utils/ otherwise you will run into issues when updating the package, as pacman won't know about them.

Offline

Board footer

Powered by FluxBB