You are not logged in.

#1 2006-01-31 15:01:41

From: Antwerpen, Belgium
Registered: 2005-08-24
Posts: 247

stock kernel won't boot

I'm using archck 2.6.14, but since i'm using archck my system clock is running too fast (it runs +-29s too fast on half an hour, rather irritating)
I noticed it since I moved form 2.6.14 tot 2.6.14archck, so I think archck might be the problem, but I'm not shure.
So I want to try stock arch kernel to see if it has the same problems, but it won't boot :-(
Did archck something to my system that makes stock kernel no longer work?
my /etc/mkinitrd.conf and /etc/initramfs.conf are the same, except the fbsplash part. I'm also using software raid0, but that's normally no problem, everything should be configured right.

the error I get:

pivot_root: pivot_root: No such file or directory
umount: /initrd: No such file or directory
umount: /initrd: No such file or directory
initial RAMDISK Loading Completed...
Freeing unused kernel memory: 252k freed

Busybox v1.01(2006.01.03-14:16+000) Built-in shell (ash)
Enter 'help' for a list of build-in commands

/bin/sh: can't access tty; job control turned off

I did a reinstall of kernel26, and afterwards a "mkinitrd kernel_version=2.6.15-ARCH"

my /boot/grub/menu.lst:

# (2) Arch Linux
title  Arch Linux  backup
root   (hd0,2)
kernel /vmlinuz26 root=/dev/md0 ro vga=795
initrd /initrd-2.6.15-ARCH.img


# Initial Ramdisk setup
# Attention:
# You need only the stuff to be able to mount your root device!
# USB/FW are only needed if you boot from such devices!

# REMOVE_IDE:         removes the complete IDE subsystem
# REMOVE_SCSI:         removes the complete SCSI subsystem
# REMOVE_SATA:         removes the complete SATA subsystem
# REMOVE_CDROM:     removes cdrom support
# REMOVE_USB:         removes the complete USB subsystem
# REMOVE_FW:         removes the complete Firewire subsystem
# REMOVE_RAID:         removes the complete Software RAID subsystem
# REMOVE_DM:        removes the complete device-mapper/LVM subsystem
# REMOVE_FS:         removes the complete Filesystems
#            (you have to include the filesystem in kernel then!)
# AUTODETECT:        enables Arch Linux autodetection 
# HOSTCONTROLLER_*:     specify the modules you need to setup the subsystem "moduleX moduleY",
#                       empty means all modules are included
# FILESYSTEMS:        specify your filesystem modules here, eg. "ext3 reiserfs"
#            empty means all modules are included
# USB_TIMEOUT:        value means  seconds to wait for bringing up usb disks
# CRYPT_DEVICE:     the path to your encrypted root device, if you use one
# RAID_DEVICES:         a space-delimited list of the devices belonging in
#                       your /dev/md0 (root) RAID array
#                           (eg, "/dev/hda3 /dev/hdc3")
# ADD_MODULE:         adds modules e.g. "moduleX moduleY"
# REMOVE_MODULE:     removes modules e.g. "moduleX moduleY"
# To rebuild initrd for Arch standard kernel just rerun 'mkinitrd auto'

# Disable whole subsystems by setting to "1"

# Enable auto-detection of HOSTCONTROLlER and FILESYSTEMS (set to "1")
#   (NOTE: This is still experimental, so it is disabled by default)

# Define which modules are needed by adding "moduleX moduleY"
# If left empty, all modules are included if they are not disabled above

# Number of seconds to wait for USB devices to settle

# If you have an encrypted root filesystem, set it here (eg, /dev/hda4)

# If you use software RAID for your root device then list all the devices
# that belong to your root array here.  If your root RAID device is
# something other than md0, then change the RAID_ROOT_ARRAY setting.
#    eg, RAID_ROOT_DEVICES="/dev/hda3 /dev/hdc3"
RAID_ROOT_DEVICES="/dev/sda1 /dev/sdb1"

# Define additional modules here

can anyone help?


#2 2006-01-31 16:39:16

From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: stock kernel won't boot

Are you sure you're using the correct name of the initrd image? Unless you changed it yourself, it defaults to initrd26.img...

You can also try the initrd26-full.img and see if that helps.

I am a gated community.


#3 2006-01-31 17:04:41

From: Antwerpen, Belgium
Registered: 2005-08-24
Posts: 247

Re: stock kernel won't boot

when you create an initrd with kernel-version=xx it will make initrd-xx.img instead of initrd26.img wink
But I created an image using mkinitrd auto and mkinitrd full, the mkinitrd auto gives the same problem, the full gives a hard lockup when he tries to load some scsi driver (I do have a scsi card for my scanner, but it was on another driver it freezes)


#4 2006-02-01 00:29:32

Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: stock kernel won't boot

mkdir /initrd

Also as for the time problem, give the latest ArchCK a shot.

Check out the thread here for details on installation and usage.



#5 2006-02-01 08:55:13

From: Antwerpen, Belgium
Registered: 2005-08-24
Posts: 247

Re: stock kernel won't boot

Thank iphitus, that solved my problem!

I just wanted to try stock kernel first to see if my hardware clock running to fast is due to the archck patchset or not. Now it seems I have the same problems running stock kernel.
So it has to be a problem with the stock kernel, or something has gone wrong with my hardware  :cry:


Board footer

Powered by FluxBB