You are not logged in.

#1 2006-02-02 04:15:54

thunderwolf318
Member
Registered: 2005-05-30
Posts: 54

Gtk apps not compiling

I get the following when compiling gtk apps.
It seams like every one does it.

checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.6.0 gtk+-2.0 >= 2.6.0 gthread-2.0 pango... configure: error: Cannot find glib2/gtk2/pango
make: *** No targets specified and no makefile found.  Stop.

Offline

#2 2006-02-02 07:22:59

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,636

Re: Gtk apps not compiling

You're running a pure archlinux using only packages from current? Nothing from testing and no self compiled software?

Offline

#3 2006-02-02 11:16:40

mpie
Member
From: 404 Not found
Registered: 2005-03-06
Posts: 649

Re: Gtk apps not compiling

run ldconfig as root....

Offline

#4 2006-02-02 11:57:55

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Gtk apps not compiling

What version of pkgconfig do you have? Is your system up2date? There's a version of pkgconfig around that doesn't include /usr/lib/pkgconfig by default in the PKG_CONFIG_PATH.

Offline

#5 2006-02-02 14:04:32

jaboua
Member
Registered: 2005-11-05
Posts: 634

Re: Gtk apps not compiling

Do you have all the packages it checks for (glib2, gtk2 and pango) installed? If not, try installing the missing one(s) and rebuild.

Offline

#6 2006-02-02 22:17:39

thunderwolf318
Member
Registered: 2005-05-30
Posts: 54

Re: Gtk apps not compiling

i have the following installed from testing

:: arts: local (1.5.0-4) appears to be newer than repo (extra/1.5.0-2)
:: cairo: local (1.0.2-2) appears to be newer than repo (current/1.0.2-1)
:: cmatrix: local (1.2a-2) appears to be newer than repo (extra/1.2a-1)
:: control-center: local (2.12.2-2) appears to be newer than repo (extra/2.12.2-1)
:: evolution-data-server: local (1.4.2.1-2) appears to be newer than repo (extra/1.4.2.1-1)
:: ghostscript: local (8.15.1-2) appears to be newer than repo (current/7.07.1-5)
:: gimp: local (2.2.10-2) appears to be newer than repo (current/2.2.10-1)
:: glut: local (3.7-5) appears to be newer than repo (current/3.7-4)
:: gtk: local (1.2.10-6) appears to be newer than repo (current/1.2.10-5)
:: gtk-theme-switch: local (1.0.1-2) appears to be newer than repo (extra/1.0.1-1)
:: gtk-theme-switch2: local (2.0.0rc2-2) appears to be newer than repo (extra/2.0.0rc2-1)
:: jasper: local (1.701.0-4) appears to be newer than repo (extra/1.701.0-3)
:: kde-common: local (3.5.0-2) appears to be newer than repo (extra/3.5.0-1)
:: kdeaccessibility: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdeaddons: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdeadmin: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdeartwork: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdebase: local (3.5.0-6) appears to be newer than repo (extra/3.5.0-4)
:: kdebindings: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdeedu: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdegames: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdegraphics: local (3.5.0-5) appears to be newer than repo (extra/3.5.0-4)
:: kdemultimedia: local (3.5.0-4) appears to be newer than repo (extra/3.5.0-3)
:: kdenetwork: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdesdk: local (3.5.0-4) appears to be newer than repo (extra/3.5.0-3)
:: kdetoys: local (3.5.0-3) appears to be newer than repo (extra/3.5.0-2)
:: kdeutils: local (3.5.0-4) appears to be newer than repo (extra/3.5.0-3)
:: kernel26-2.6.14.5-1: ignoring package upgrade (2.6.15.2-2)
:: lesstif: local (0.94.4-4) appears to be newer than repo (current/0.94.4-3)
:: libbonoboui: local (2.10.1-2) appears to be newer than repo (extra/2.10.1-1)
:: libgtop: local (2.12.2-1) appears to be newer than repo (extra/2.12.0-1)
:: libsm: local (1.0.0-1) appears to be newer than repo (current/0.9.9-1)
:: libx11: local (1.0.0-1) appears to be newer than repo (current/0.9.9-1)
:: libxcursor: local (1.1.5.2-1) appears to be newer than repo (current/0.9.9-1):: libxext: local (1.0.0-1) appears to be newer than repo (current/0.9.9-1)
:: libxi: local (1.0.0-1) appears to be newer than repo (current/0.9.9-1)
:: libxinerama: local (1.0.0-1) appears to be newer than repo (current/0.9.9-1)
:: libxklavier: local (2.1-2) appears to be newer than repo (extra/2.0-3)
:: libxrandr: local (1.1.0.2-1) appears to be newer than repo (current/0.9.9-1)
:: libxt: local (1.0.0-3) appears to be newer than repo (current/0.9.9-1)
:: mesa: local (6.4.1-2) appears to be newer than repo (extra/6.4.1-1)
:: mplayer: local (1.0pre7-3) appears to be newer than repo (current/1.0pre7-2)
:: openexr: local (1.2.2-5) appears to be newer than repo (extra/1.2.2-4)
:: openldap: local (2.3.11-1) appears to be newer than repo (current/2.2.30-1)
:: pango: local (1.10.2-2) appears to be newer than repo (current/1.10.2-1)
:: qt: local (3.3.5-6) appears to be newer than repo (extra/3.3.5-2)
:: sdl: local (1.2.9-2) appears to be newer than repo (current/1.2.9-1)
:: smbclient: local (3.0.21a-1) appears to be newer than repo (current/3.0.20-1):: startup-notification: local (0.8-4) appears to be newer than repo (current/0.8-3)
:: tk: local (8.4.11-2) appears to be newer than repo (current/8.4.11-1)
:: udev: local (080-3) appears to be newer than repo (current/079-1)
:: vlc: local (0.8.4a-3) appears to be newer than repo (extra/0.8.4a-1)
:: wine: local (0.9.6-3) appears to be newer than repo (extra/0.9.6-1)
:: xmms: local (1.2.10-5) appears to be newer than repo (current/1.2.10-4)
:: xscreensaver: local (4.23-2) appears to be newer than repo (current/4.23-1)

i also have the xfce4-svn packages from shadowhands repo and some the kde eyecand from the ikde one.

I ran ldconfig and it didnt work.

i have pkgconfig 0.19-1

i tryed -syuing up and it asked

:: avahi conflicts with nss-mdns. Remove nss-mdns? [Y/n] y

it was going to install

avahi-0.6.6-2 fontconfig-2.3.2-5 kernel26archck-2.6.15.archck3-1
         koffice-1.4.2-5 subversion-1.3.0-2 transcode-1.0.2-3

but it said error

this will break the following dependencies:
  nss-mdns: is required by kdelibs.

im running makepkg so it should tell me if they arnt installed (and yes they are all installed)

Offline

#7 2006-02-02 22:29:57

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Gtk apps not compiling

What gtk app are you trying to compile?
BTW, to upgrade:
pacman -S nss-mdns
pacman -Syu

Offline

#8 2006-02-02 22:34:39

thunderwolf318
Member
Registered: 2005-05-30
Posts: 54

Re: Gtk apps not compiling

im trying to compile audacious but it does it with all gtk apps

Offline

#9 2006-02-03 00:42:05

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Gtk apps not compiling

What does "pkg-config --cflags gtk+-2.0" return?

Offline

#10 2006-02-03 01:29:11

thunderwolf318
Member
Registered: 2005-05-30
Posts: 54

Re: Gtk apps not compiling

Package xrender was not found in the pkg-config search path.
Perhaps you should add the directory containing `xrender.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xrender', required by 'cairo', not found

Offline

#11 2006-02-04 04:10:48

thunderwolf318
Member
Registered: 2005-05-30
Posts: 54

Re: Gtk apps not compiling

i tryed compiling audacious and it exited with a error. thought it might help

make[2]: Entering directory `/home/patrick/temp/src/audacious-0.2/libaudacious'
if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0     -I.. -I../intl  -I/usr/X11R6/include  -march=i686 -O2 -pipe -Wall -Wpointer-arith -finline-functions -ffast-math -fomit-frame-pointer -funroll-all-loops  -MT beepctrl.lo -MD -MP -MF ".deps/beepctrl.Tpo" -c -o beepctrl.lo beepctrl.c;
then mv -f ".deps/beepctrl.Tpo" ".deps/beepctrl.Plo"; else rm -f ".deps/beepctrl.Tpo"; exit 1; fi
gcc -DHAVE_CONFIG_H -I. -I. -I.. -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I.. -I../intl -I/usr/X11R6/include -march=i686 -O2 -pipe -Wall -Wpointer-arith -finline-functions -ffast-math -fomit-frame-pointer -funroll-all-loops -MT beepctrl.lo -MD -MP -MF .deps/beepctrl.Tpo -c beepctrl.c  -fPIC -DPIC -o .libs/beepctrl.o
In file included from /usr/include/linux/errno.h:4,
                 from /usr/include/bits/errno.h:25,
                 from /usr/include/errno.h:36,
                 from beepctrl.c:30:
/usr/include/asm/errno.h:4:31: error: asm-generic/errno.h: No such file or directory
make[2]: *** [beepctrl.lo] Error 1
make[2]: Leaving directory `/home/patrick/temp/src/audacious-0.2/libaudacious'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/patrick/temp/src/audacious-0.2'
make: *** [all] Error 2

Offline

#12 2006-02-04 04:31:59

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Gtk apps not compiling

/usr/src/linux-2.6.15-ARCH/include/asm-generic/errno.h is a kernel header. Are you using a custom kernel? If so, make sure that the headers are installed.

Offline

#13 2006-02-04 06:25:38

thunderwolf318
Member
Registered: 2005-05-30
Posts: 54

Re: Gtk apps not compiling

Im using .14 from the repos because of stability issues.with .15
I have it in the .14 src dir but my .15 dir dosent have it

Offline

#14 2006-02-04 09:58:00

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Gtk apps not compiling

Hmm, the pkgconfig error points at a missing libxrender. On testing, this is a standalone lib, in current, this is a dummy package, which depends on xorg, which has the xrender.pc files. I guess you should reinstall xorg then.

Offline

#15 2006-02-04 16:52:08

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: Gtk apps not compiling

I too have the same exact problem, compiling GTK apps. I get:

Package xrender was not found in the pkg-config search path.
Perhaps you should add the directory containing `xrender.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xrender', required by 'cairo', not found

I'm using xorg 7 and I have libxrender 0.9.0.2-1 installed.


I am a gated community.

Offline

#16 2006-02-04 18:07:02

thunderwolf318
Member
Registered: 2005-05-30
Posts: 54

Re: Gtk apps not compiling

I have libxrender 0.9.0.2-1 installed.
Are you by chance using the ati drivers?

Offline

#17 2006-02-04 18:58:56

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: Gtk apps not compiling

Me? Nope.


I am a gated community.

Offline

#18 2006-02-05 01:14:24

dingus
Member
From: London
Registered: 2006-02-02
Posts: 18

Re: Gtk apps not compiling

I think I was having the same issue with compiling gtk apps, I seem to have fixed it by just reinstalling libxrender from testing (I am using Xorg 7.0).

Offline

#19 2006-02-05 01:51:59

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: Gtk apps not compiling

dingus wrote:

I think I was having the same issue with compiling gtk apps, I seem to have fixed it by just reinstalling libxrender from testing (I am using Xorg 7.0).

I don't know why I didn't try that  roll

Thanks, that fixed the issue.


I am a gated community.

Offline

#20 2006-02-05 04:43:30

thunderwolf318
Member
Registered: 2005-05-30
Posts: 54

Re: Gtk apps not compiling

http://pastebin.com/539588

the problems go on! I was told I need the x11 dev packages.
Im using xorg7.

Offline

#21 2006-02-05 09:47:13

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: Gtk apps not compiling

Hi

please  check your $PKG_CONFIG_PATH carefully. An unknown weird issue
once caused mine to be castrated and left /usr out of it.
BTW, answering JGC's question will help you to narrow down to the real problem.

-neri

Offline

#22 2006-02-23 23:08:50

aeneas
Member
Registered: 2006-02-17
Posts: 14

Re: Gtk apps not compiling

I'm having a very similar problem here. I tried to compile my in-progress gtkmm program and it failed right away:

...
In file included from /usr/include/gtk-2.0/gdk/gdkgc.h:30,
                 from /usr/include/gtk-2.0/gdk/gdkdrawable.h:30,
                 from /usr/include/gdkmm-2.4/gdkmm/drawable.h:28,
                 from /usr/include/gdkmm-2.4/gdkmm/window.h:28,
                 from /usr/include/gdkmm-2.4/gdkmm/event.h:29,
                 from /usr/include/gtkmm-2.4/gtkmm/widget.h:32,
                 from /usr/include/gtkmm-2.4/gtkmm/container.h:29,
                 from /usr/include/gtkmm-2.4/gtkmm/bin.h:30,
                 from /usr/include/gtkmm-2.4/gtkmm/window.h:32,
                 from /usr/include/gtkmm-2.4/gtkmm/dialog.h:30,
                 from aboutdialog.cc:27:
/usr/include/gtk-2.0/gdk/gdkcolor.h:30:19: error: cairo.h: No such file or directory
/usr/include/gtk-2.0/gdk/gdkdrawable.h:196: error: ISO C++ forbids declaration of 'cairo_surface_t' with no type
...

Cairo headers are in /usr/include/cairo/ - what's the problem? Here's my

bash-3.00$ printenv PKG_CONFIG_PATH
:/opt/gnome/lib/pkgconfig:/opt/mozilla/lib/pkgconfig

///

edit:  :oops: sorry it was late night i forgot to run the configure script.

Offline

Board footer

Powered by FluxBB