You are not logged in.

#1 2014-03-13 12:46:36

suvendu
Member
Registered: 2014-03-13
Posts: 1

unable to load firmware

Hi,

This is my first time posting on the forum.

I am using 3.13.6-1-ARCH x86_64 on a Thinkpad T440s with an Intel 7260 ac card. The network seems to disconnect randomly and reconnecting solves the problem temporarily until next disconnect. So I got the latest firmware iwlwifi-7260-8.ucode from Intel http://www.intel.com/support/wireless/w … 034398.htm and placed it in /lib/firmware.

ls /lib/firmware/ | grep iwlwifi

LICENSE.iwlwifi-7260-ucode
README.iwlwifi-7260-ucode
iwlwifi-100-5.ucode
iwlwifi-1000-3.ucode
iwlwifi-1000-5.ucode
iwlwifi-105-6.ucode
iwlwifi-135-6.ucode
iwlwifi-2000-6.ucode
iwlwifi-2030-6.ucode
iwlwifi-3160-7.ucode
iwlwifi-3160-8.ucode
iwlwifi-3945-2.ucode
iwlwifi-4965-2.ucode
iwlwifi-5000-1.ucode
iwlwifi-5000-2.ucode
iwlwifi-5000-5.ucode
iwlwifi-5150-2.ucode
iwlwifi-6000-4.ucode
iwlwifi-6000g2a-5.ucode
iwlwifi-6000g2a-6.ucode
iwlwifi-6000g2b-5.ucode
iwlwifi-6000g2b-6.ucode
iwlwifi-6050-4.ucode
iwlwifi-6050-5.ucode
iwlwifi-7260-7.ucode
iwlwifi-7260-8.ucode

However, the problem did not go away. So when I tried to probe available firmware and it looks like the older version of the firmware is being used

modinfo iwlwifi | grep firmware

firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-3160-7.ucode
firmware:       iwlwifi-7260-7.ucode
parm:           fw_restart:restart firmware in case of error (default true) (bool)
cat .config | grep CONFIG_FW

CONFIG_FW_LOADER=y
CONFIG_FW_LOADER_USER_HELPER=y

What should I do so that the latest firmware iwlwifi-7260-8.ucode is loaded and not the old one iwlwifi-7260-7.ucode ? Please let me know if you need any more information. Any help would be greatly appreciated.

Cheers

Offline

#2 2014-04-02 00:41:29

jflanglois
Member
Registered: 2013-01-16
Posts: 4

Re: unable to load firmware

I also have this problem on a Lenovo X1 (Haswell) on kernels 3.13.7 and 3.13.8. dmesg reports that it is loading firmware 22.24.8.0, but modinfo iwlwifi doesn't list iwlwifi-7260-8.ucode and the connection is not consistent.

As a temporary solution, linux-lts (3.10.34) using ucode 22.1.7.0 seems to work consistently.


Julien.

Offline

#3 2014-04-02 11:23:34

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: unable to load firmware

suvendu, jflanglois

iwlwifi-7260-8.ucode is included in linux-firmware 20140316.dec41bc-1 .

I do agree it seems like iwlwifi kernel module doesn't pick up that firmware version which may be  a bug, but you'd need help from someone much more knowledgeable about kernel modules to get further.

Last edited by Lone_Wolf (2014-04-02 11:28:14)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2014-04-02 20:43:22

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: unable to load firmware

Since this impacts me as well I have entered a report for this at: https://bugs.archlinux.org/task/39722


Mike C

Offline

#5 2014-04-02 23:00:31

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: unable to load firmware

If the module doesn't list the .8 firmware in the modinfo output, it's never going to use it. File a bug with the people who can fix this (hint: this isn't Arch), assuming that it's actually a bug and not some other incompatible firmware.

Offline

#6 2014-04-03 08:40:01

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: unable to load firmware

falconindy wrote:

If the module doesn't list the .8 firmware in the modinfo output, it's never going to use it. File a bug with the people who can fix this (hint: this isn't Arch), assuming that it's actually a bug and not some other incompatible firmware.

Yes I expect this needs to be on the kernel bugzilla and the arch flyspray ticket can then follow it.  I will check the kernel bug list later today and report there if nobody has already done so.

I have added in some info to the kernel bug at https://bugzilla.kernel.org/show_bug.cgi?id=72601

It was commented the the kernel bug above was not related to this issue so I entered a new bug at https://bugzilla.kernel.org/show_bug.cgi?id=73441

Thomas Bächler has clarified the issue of reporting the older firmware in that  Intel chooses to list the oldest usable firmware even though the module does in fact load the later firmware, so the points I raised are not relevant. The output is confusing but this is not the problem underlying the wireless problems being seen. So I have closed the bug I quoted above.

Last edited by mcloaked (2014-04-03 09:56:56)


Mike C

Offline

#7 2014-04-04 02:04:02

s3vv4
Member
Registered: 2011-08-03
Posts: 13

Re: unable to load firmware

Have the same error, using linux-lts fixes it for me. I also tried the new 3.14 kernel, same error.

Offline

#8 2014-04-04 08:51:00

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: unable to load firmware

suvendu wrote:

Hi,

This is my first time posting on the forum.

I am using 3.13.6-1-ARCH x86_64 on a Thinkpad T440s with an Intel 7260 ac card. The network seems to disconnect randomly and reconnecting solves the problem temporarily until next disconnect.

Upgrade to linux 3.14 from testing. I had the same problem on some networks (especially, my home network), but it went away completely since I upgraded.

So I got the latest firmware iwlwifi-7260-8.ucode from Intel http://www.intel.com/support/wireless/w … 034398.htm and placed it in /lib/firmware.

Latest firmware is already shipped with the linux-firmware package. No need to grab it.

What should I do so that the latest firmware iwlwifi-7260-8.ucode is loaded and not the old one iwlwifi-7260-7.ucode ?

It loads the -8 firmware already.

[    7.091677] iwlwifi 0000:03:00.0: loaded firmware version 22.24.8.0 op_mode iwlmvm
[    7.185178] iwlwifi 0000:03:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144

Version 22.24.8.0 is iwlwifi-7260-8.ucode.

Offline

#9 2014-04-04 23:18:56

jflanglois
Member
Registered: 2013-01-16
Posts: 4

Re: unable to load firmware

brain0 wrote:

Upgrade to linux 3.14 from testing. I had the same problem on some networks (especially, my home network), but it went away completely since I upgraded.

This seems to have worked for me (kernel 3.14.0-3). There was a moment of hanging after I got an initial connection the first time I booted, but now it seems stable.

Offline

#10 2014-05-07 22:55:51

amiara
Member
Registered: 2013-01-16
Posts: 21

Re: unable to load firmware

I have the same issue with Thinkpad T440s as of kernel version 3.14.2-1. Any update on a solution?

Last edited by amiara (2014-05-07 22:56:06)

Offline

Board footer

Powered by FluxBB