You are not logged in.

#1 2014-04-03 12:54:05

Registered: 2014-04-03
Posts: 17

[SOLVED]Unable to perform cryptsetup luksFormat when doing LVM on LUKS

Hi everyone. I'm currently going through the beginner's guide to setup LVM on LUKS. I have so far made the necessary partitions. The problem occurs when I try to enter the command 'cryptsetup luksFormat /dev/sda3'. The error message I get is the following:

    [64255.689399] device-mapper: table: 254:2: crypt: Device lookup failed
    device-mapper: reload ioctl on  failed: Invalid argument
    Failed to setup dm-crypt key mapping for devide /dev/sda3
    Check that kernel supports aes-xts-plain64 cipher (check syslog for more info)

So far I have tried using the extra option '-c aes-xts-plain', with no luck. Also I checked /proc/crypto/, and it seems to have the necessary entry:

name         : xts(aes)
driver       : xts-aes-aesni
module       : kernel
priority     : 400
refcnt       : 1
selftest     : passed
type         : givcipher
async        : yes
blocksize    : 16
min keysize  : 32
max keysize  : 64
ivsize       : 16
geniv        : eseqiv

In any case, I don't see why the kernel would not support the cipher. The output of 'cryptsetup benchmark' is:

# Tests are approximate using memory only (no storage IO).
PBKDF2-sha1       810336 iterations per second
PBKDF2-sha256     498372 iterations per second
PBKDF2-sha512     391259 iterations per second
PBKDF2-ripemd160  479239 iterations per second
PBKDF2-whirlpool  186446 iterations per second
#  Algorithm | Key |  Encryption |  Decryption
     aes-cbc   128b   490.0 MiB/s  1669.7 MiB/s
 serpent-cbc   128b    62.8 MiB/s   245.0 MiB/s
 twofish-cbc   128b   141.0 MiB/s   266.6 MiB/s
     aes-cbc   256b   364.2 MiB/s  1281.6 MiB/s
 serpent-cbc   256b    62.5 MiB/s   242.4 MiB/s
 twofish-cbc   256b   140.4 MiB/s   266.3 MiB/s
     aes-xts   256b  1439.4 MiB/s  1465.1 MiB/s
 serpent-xts   256b   253.2 MiB/s   241.1 MiB/s
 twofish-xts   256b   261.7 MiB/s   263.6 MiB/s
     aes-xts   512b  1123.4 MiB/s  1142.2 MiB/s
 serpent-xts   512b   253.3 MiB/s   241.1 MiB/s
 twofish-xts   512b   261.5 MiB/s   263.4 MiB/s

Any help greatly appreciated.

Last edited by JamesLens (2014-04-03 13:46:36)


#2 2014-04-03 13:46:22

Registered: 2014-04-03
Posts: 17

Re: [SOLVED]Unable to perform cryptsetup luksFormat when doing LVM on LUKS

As suggested elsewhere, for some reason a reboot fixes the problem. Marking as solved.


Board footer

Powered by FluxBB