You are not logged in.

#1 2014-04-03 19:11:11

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 1,238

[SOLVED]journalctl truncates lines in Konsole

I have a fully up to date arch system running systemd 212-1, and if I run:

# journalctl --full

in a Konsole in KDE the lines still truncate at the end of each line. I thought that this was supposed to be fixed in systemd a long time ago but I have not seen this working properly in recent times.  Does anyone know if there is a work around, and is this behaviour a remaining bug?

Last edited by mcloaked (2014-04-03 21:10:08)


Mike C

Offline

#2 2014-04-03 21:00:43

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED]journalctl truncates lines in Konsole

I'm not using Konsole, but I don't see this. Does it work in other terminal emulators? Please post the output.
I can scroll with the cursor keys. https://bbs.archlinux.org/viewtopic.php … 2#p1327072

Offline

#3 2014-04-03 21:09:48

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 1,238

Re: [SOLVED]journalctl truncates lines in Konsole

karol wrote:

I'm not using Konsole, but I don't see this. Does it work in other terminal emulators? Please post the output.
I can scroll with the cursor keys. https://bbs.archlinux.org/viewtopic.php … 2#p1327072

Thank you for that link - I was unaware that you can scroll left/right with the arrow keys - and this does work perfectly well in Konsole, as I have just checked it.  Also journalctl -b --no-pager | less works just fine too.

So that solves this issue that I had been somewhat frustrated with for ages - I didn't see this option in the man page for journalctl. I'll mark this as solved.


Mike C

Offline

Board footer

Powered by FluxBB