You are not logged in.

#1 2013-06-10 08:53:27

From: Hungary
Registered: 2009-10-01
Posts: 442

apcupsd fails to start

As in the title.

I get this when I start apcupsd :

jún 09 20:12:00 router systemd[1]: Starting APC UPS Monitor...
jún 09 20:12:00 router systemd[1]: Started APC UPS Monitor.
jún 09 20:12:00 router apcupsd[625]: Valid lock file for pid=128, but not ours pid=625
jún 09 20:12:00 router systemd[1]: apcupsd.service: main process exited, code=exited, status=1/FAILURE
jún 09 20:12:00 router systemd[1]: Unit apcupsd.service entered failed state.

the lockfile is specified as

LOCKFILE /etc/apcupsd

and it is there (ls -la /etc/apcupsd | grep LCK)

-rw-r--r--  1 root root    11 jún    7 06.50 LCK..ttyS0

I've changed the lockfile to /var/lock/ in the config file. Now it works.

Why does it not work at the default location?
Is it a bug?

Last edited by scar (2013-06-10 08:54:03)

“The future has already arrived. It's just not evenly distributed yet.”
― William Gibson


#2 2013-10-08 22:21:27

From: United States
Registered: 2013-10-08
Posts: 21

Re: apcupsd fails to start

I had this same issue. Deleting the lock file in /etc/apcupsd/ fixed it, but then it eventually happened again. I switched the location to /var/lock/ and it's working again. Will post back if it fails again.


#3 2014-04-04 05:12:49

From: Australia
Registered: 2009-12-23
Posts: 1

Re: apcupsd fails to start

Same problem, same fix!

Thanks for the thread/posts with the solution...


#4 2014-04-04 14:36:50

From: Pasadena, CA
Registered: 2009-07-13
Posts: 19,766

Re: apcupsd fails to start

Welcome to Arch Linux.    I am going  to go ahead and close this old post
Glad your problem is solved.

Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
How to Ask Questions the Smart Way


Board footer

Powered by FluxBB