You are not logged in.

#1 2014-04-19 16:27:11

yungtrizzle
Member
From: Nanjing, China
Registered: 2011-04-24
Posts: 136

[SOLVED] Qt Multimedia module broken after update

Today after I updated qt5-multimedia (along with the rest of Qt)  it proceeded to break my mini (homemade) media player which depends on it. So far it seems that it cannot find any gstreamer plugins. Incidentally, I have both legacy and current gstreamer on my system but they shouldn't conflict. Did something go wrong during the upgrade?

edit: based on what I got from #qt it seems that a .so file is missing (libgstmediaplayer.so)

Last edited by yungtrizzle (2014-04-19 17:28:36)


No trees No codes : equal exchange

Offline

#2 2014-04-19 18:24:17

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [SOLVED] Qt Multimedia module broken after update

Could be.
I replaced gstreamer (legacy 0.10) dependencies with gst (1.0), maybe this broke something then.

Offline

#3 2014-04-20 05:21:00

yungtrizzle
Member
From: Nanjing, China
Registered: 2011-04-24
Posts: 136

Re: [SOLVED] Qt Multimedia module broken after update

I noticed but I haven't seen any indication of upstream moving it.


No trees No codes : equal exchange

Offline

#4 2014-04-23 10:25:51

Benwa
Member
From: France
Registered: 2014-04-23
Posts: 2
Website

Re: [SOLVED] Qt Multimedia module broken after update

Hy. I have the same problem. All worked well with Qt multimedia before the upgrade but went wrong after.

After recompiling the programm using Qt multmedia I got this error message ( even with Qt exemples ) :

defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"

I have both version of GStreamer installed.

Is there a way to fix it?

Offline

#5 2014-04-23 13:43:31

jnhieber
Member
From: Germany
Registered: 2011-02-01
Posts: 23

Re: [SOLVED] Qt Multimedia module broken after update

i also have this problem with qt multimedia. system is up to date.
should i provide further information?

Offline

#6 2014-04-23 14:58:52

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 113

Re: [SOLVED] Qt Multimedia module broken after update

I too am having issues with this.  My alarm clock in the AUR spits the same error message out and wont play any audio.  libgstmediaplayer.so is no longer on the system.

Last edited by piratebill (2014-04-23 15:04:15)

Offline

#7 2014-04-24 14:33:40

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 113

Re: [SOLVED] Qt Multimedia module broken after update

Down grading qt multimedia adds libgstmediaplayer.so back to the system and the problem stops. Looking here at other distros it looks like libgstmediaplayer should be installed with qt5-multimedia 5-2-1.1.  I'm going to file a bug when I get off work.

Offline

#8 2014-04-28 17:21:18

Benwa
Member
From: France
Registered: 2014-04-23
Posts: 2
Website

Re: [SOLVED] Qt Multimedia module broken after update

It was fixed with the upgrade to qt5-multimedia-5.2.1-4 ^^

Offline

Board footer

Powered by FluxBB