You are not logged in.

#1 2014-04-19 16:13:57

tian.tian098
Member
From: Canada
Registered: 2013-08-08
Posts: 2

LightDM won't start KDE after logging in

I've been using KDM previously, but have decided to try LightDM.

So I installed lightdm and lighdm-kde-greeter, then I
systemctl disable kdm
systemctl enable lightdm

However, when I type in my username and password, the login window disappears and nothing happens. The log (when I try using --testmode-debug) shows:

[+20.67s] DEBUG: Session pid=2565: User ... authorized
[+21.34s] DEBUG: Session pid=2565: Greeter requests session kde-plasma
[+21.34s] CRITICAL: g_dbus_connection_call_sync_internal: assertion 'object_path != NULL && g_variant_is_object_path (object_path)' failed
[+21.34s] DEBUG: Writing /home/.../.dmrc
[+21.39s] DEBUG: Seat: Returning to existing user session ...
[+21.39s] DEBUG: Session pid=2575: Sending SIGTERM
[+21.39s] DEBUG: Session pid=2575: Terminated with signal 15
[+21.39s] DEBUG: Seat: Session stopped

Any idea how to fix this?

Offline

#2 2014-04-24 18:14:06

Götz
Member
Registered: 2009-02-16
Posts: 23

Re: LightDM won't start KDE after logging in

Did you follow all the instruction from the wiki?
https://wiki.archlinux.org/index.php/LightDM

You may try to delete all the configuration files (/etc/lightdm/), reinstall lightdm and lighdm-kde-greeter, and try again.

Also, try with another greeter to see if it works.


What I hear, I forget. What I say, I remember. What I do, I understand.  –Tao Te Ching/Laozi

Offline

Board footer

Powered by FluxBB