You are not logged in.

#1 2011-07-02 08:12:15

finarfin
Member
Registered: 2010-03-15
Posts: 24

Cups and "waiting for printer to become available"

Hi all,

i have a problem with cups (i don't know since when),
when i try to print something i receive the message:

"waiting for printer to become available"

And i'm aware that this problem happens when you have usblp loaded. So first of all i checked if the usblp module is loaded and here the result:

usblp                   9311  0 
usbcore               119004  8 usblp,uvcvideo,uas,usb_storage,usbhid,ohci_hcd,ehci_hcd

But if i go to check the /etc/rc.conf file the MODULES line is:

MODULES=(lib80211_crypt_tkip wl radeon vboxdrv vboxnetflt powernow-k8 cpufreq_ondemand !snd-pcm-oss !b43 !ssb !usblp)

And it seems that usblp module is not loaded.
Now the question is:
What's wrong?
I did something wrong? I forgot somethin?

Thanks,
Ivan

Offline

#2 2011-07-02 10:12:26

BlueDarknezz
Member
From: Germany
Registered: 2008-12-21
Posts: 14

Re: Cups and "waiting for printer to become available"

Modules must now be blacklisted through /etc/modprobe.d/*.conf. For a detailed description see: http://www.archlinux.org/news/changes-t … cklisting/.

Best regards,

BD

Offline

#3 2011-07-19 07:45:48

ananthp
Member
Registered: 2011-06-18
Posts: 8

Re: Cups and "waiting for printer to become available"

I'm configuring a new Brother HL-2140 printer. I'm getting the same message. I've blocklisted usblp in modprobe.d way and the module is not loaded at present.

Installed the driver using this pkgbuild: https://aur.archlinux.org/packages.php?ID=27024

Offline

#4 2011-08-06 11:47:54

fubar0
Member
Registered: 2009-10-05
Posts: 18

Re: Cups and "waiting for printer to become available"

Downgrading "file" solved all my printing problems with my brother printer:
https://bbs.archlinux.org/viewtopic.php?pid=967337

Or full guide on how to install a Brother Printer
http://bleedux.wordpress.com/?p=476

Offline

#5 2011-08-14 02:23:49

asuamo
Member
Registered: 2011-08-12
Posts: 6

Re: Cups and "waiting for printer to become available"

My Brother DCP-7030 worked well couple of days, but now I'm getting the same error message.  After I deleted printer it didn't come back in administration window; that's interesting.

 # pacman -Q file
file 5.04-3
# lsmod| grep usblp
# 

Update:

- My problem was caused by bad contact.
- New "file" version works fine.

Last edited by asuamo (2011-08-14 12:00:43)

Offline

#6 2012-03-14 20:12:26

integer
Member
From: Toronto, Canada
Registered: 2011-08-22
Posts: 19
Website

Re: Cups and "waiting for printer to become available"

I apologize for reviving an old thread, but this is the first thing that comes up when searching for "cups waiting for printer", so I thought my note might be useful.

I had the same problem with a Brother DCP-7065DN.
After some searching, the problem turned out to be wrong ownership of the device node after reboot.

You need to make sure your printer /dev/bus/usb node has ownership root:lp as per:
https://wiki.archlinux.org/index.php/CU … ermissions

Offline

#7 2014-04-27 03:42:22

ansak
Member
Registered: 2013-03-23
Posts: 9

Re: Cups and "waiting for printer to become available"

Oddly enough...

I couldn't find usblp in my lsmod output but I was also getting this "cups waiting for printer". My file utility is version 5.18 and although I considered downgrading it, that just felt too much like thrashing about. (My printer is a USB HP LaserJet 1020)

In the end, I did something else that felt like almost as much thrashing about. I followed the "changes to module blacklisting" page with usblp, restarted cups and cycled power on the printer. Now it's working again. I wish I entirely new why.

I think what happened was the automatic power up of the printer (or of the computer) loaded usblp but the fooz file for LaserJet was unloading it so (a) I never saw it in the lsmod output and (b) it was in the system long enough to snarl things, followed by (c) if only it was blacklisted at the time that the system saw the printer it would not be there and not foul things up. Does that sound like a reasonable chain of events.

one more reason to resent (grumble, grumble, grr grr) systemd over the older (admittedly clunkier, more manual -- but more CONTROLLABLE!) initscripts. (Okay, I'm over 45)

cheers...ank

Last edited by ansak (2014-04-27 03:43:41)

Offline

#8 2014-04-27 10:03:28

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,787
Website

Re: Cups and "waiting for printer to become available"


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB