You are not logged in.

#1 2014-04-28 13:33:56

pittedmetal
Member
Registered: 2014-04-28
Posts: 9

[SOLVED] VDPAU and VAAPI problems

Hey guys

I have a problem that I can't seem to sort out by myself. So I wanted hardware acceleration for my videos through mplayer. Read the arch wiki on VDPAU and VAAPI including the one under catalyst since I am using that as my graphics driver. So I followed all the instructions carefully and checked vdpauinfo to see whether it was working or not. It wasn't working. This is what it spewed out-

 
display: :0.0 screen: 0 
Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory 
Error creating VDPAU device: 1 

This is what vainfo gives-

 
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'vdpau'
libva info: Trying to open /usr/lib/dri/vdpau_drv_video.so
libva info: Found init function __vaDriverInit_0_33
Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory
Floating point exception (core dumped)

It says can't find libvdpau_r600.so which is strange I think because I'm using catalyst. So that shoudn't come right? Anyways, tried playing a video through mplayer with the vaapi:gl option, didn't work. What did I do wrong? Been working on this issue for the past two days reading up on some few other distro's forums. They said something about compiling mesa with vdpau support. Ubuntu in particular has this package which when installed solves the issues which I've been having. It's libg3dvl-mesa.

Lastly this is what mplayer gives-

MPlayer SVN-r36265-4.8.2 (C) 2000-2013 MPlayer Team
203 audio & 423 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/sda2/Movies/Frozen/Frozen.mp4.
libavformat version 55.12.102 (internal)
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang eng
VIDEO:  [H264]  1920x856  24bpp  23.976 fps  2191.4 kbps (267.5 kbyte/s)
Clip info:
 major_brand: isom
 minor_version: 1
 compatible_brands: isomavc1
 creation_time: 2014-02-27 06:26:54
Load subtitles in /mnt/sda2/Movies/Frozen/
[vo_vaapi] Using OpenGL rendering
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'vdpau'
libva info: Trying to open /usr/lib/dri/vdpau_drv_video.so
libva info: Found init function __vaDriverInit_0_33
Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory


MPlayer interrupted by signal 8 in module: preinit_libvo
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

I am using an AMD Radeon HD6670 1GB DDR3 from Sapphire. I installed mesa-git and checked whether the problem was solved but the same error messages popped up.

Thanks

P.S- I posted this on the archlinux sub reddit. They asked me to post here too so please don't lock this thread.

Last edited by pittedmetal (2014-04-28 16:53:00)

Offline

#2 2014-04-28 13:42:23

Rexilion
Member
Registered: 2013-12-23
Posts: 784

Re: [SOLVED] VDPAU and VAAPI problems

VDPAU tries to open the opensource libvdpau_r600.so, I think.

It appears that libva-vdpau-driver is installed and detected. Maybe you also need libvdpau-va-gl?


fs/super.c : "Self-destruct in 5 seconds.  Have a nice day...\n",

Offline

#3 2014-04-28 13:45:21

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [SOLVED] VDPAU and VAAPI problems

The only thing Catalyst supports is XvBA. No VDPAU, no VAAPI. You can install xvba-video from AUR, it's an XvBA->VAAPI bridge, so in theory VAAPI players (VLC, mplayer-vaapi, mpv) should work. Emphasis on "theory" and "should", xvba-video hasn't been actively developed for some time, there's no guarantee it still works.

Offline

#4 2014-04-28 14:49:23

pittedmetal
Member
Registered: 2014-04-28
Posts: 9

Re: [SOLVED] VDPAU and VAAPI problems

Rexilion wrote:

VDPAU tries to open the opensource libvdpau_r600.so, I think.

It appears that libva-vdpau-driver is installed and detected. Maybe you also need libvdpau-va-gl?

I have libvdpau-va-gl installed already.

Offline

#5 2014-04-28 15:02:04

pittedmetal
Member
Registered: 2014-04-28
Posts: 9

Re: [SOLVED] VDPAU and VAAPI problems

Gusar wrote:

The only thing Catalyst supports is XvBA. No VDPAU, no VAAPI. You can install xvba-video from AUR, it's an XvBA->VAAPI bridge, so in theory VAAPI players (VLC, mplayer-vaapi, mpv) should work. Emphasis on "theory" and "should", xvba-video hasn't been actively developed for some time, there's no guarantee it still works.

But in the wiki, different packages are given for both catalyst and open source. So I think catalyst does support VDPAU and VAAPI.
https://wiki.archlinux.org/index.php/VA-API
https://wiki.archlinux.org/index.php/VDPAU

I do have XvBA installed that is, libva-xvba-driver as per the wiki. I'll install xvba-video and see if that works out.

Offline

#6 2014-04-28 15:11:08

pittedmetal
Member
Registered: 2014-04-28
Posts: 9

Re: [SOLVED] VDPAU and VAAPI problems

Installed xvba-driver. Same problem. Switched back to libva-xvba-driver . I also installed mesa-libgl and removed catalyst-libgl. X wouldn't run and it would terminate without an error. So I reverted back to catalyst-libgl and X started. Here is the Xorg.0.log -

http://pastebin.com/tbaNKCVu

Last edited by pittedmetal (2014-04-28 15:43:05)

Offline

#7 2014-04-28 15:37:27

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [SOLVED] VDPAU and VAAPI problems

pittedmetal wrote:

So I think catalyst does support VDPAU and VAAPI.

It does not. It only supports XvBA. There's XvBA-VAAPI bridges, but like I said, the chance that they still work is low.

If you want hardware decoding, use the open driver. It should work very well on your GPU and it uses VDPAU, which has the widest and best support in various applications.

EDIT: Do you have libva-vdpau-driver installed? Considering vainfo tries to open /usr/lib/dri/vdpau_drv_video.so, it seems you do. Remove it.

Last edited by Gusar (2014-04-28 15:42:23)

Offline

#8 2014-04-28 15:53:17

pittedmetal
Member
Registered: 2014-04-28
Posts: 9

Re: [SOLVED] VDPAU and VAAPI problems

Gusar wrote:
pittedmetal wrote:

So I think catalyst does support VDPAU and VAAPI.

It does not. It only supports XvBA. There's XvBA-VAAPI bridges, but like I said, the chance that they still work is low.

If you want hardware decoding, use the open driver. It should work very well on your GPU and it uses VDPAU, which has the widest and best support in various applications.

EDIT: Do you have libva-vdpau-driver installed? Considering vainfo tries to open /usr/lib/dri/vdpau_drv_video.so, it seems you do. Remove it.

I removed libva-vdpau-driver. vdpauinfo, gives me the same error. But, vainfo's error has changed-

libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'vdpau'
libva info: Trying to open /usr/lib/dri/vdpau_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

I did check mplayer. This time the audio worked but not the video. This is what came up in the terminal-

MPlayer SVN-r36265-4.8.2 (C) 2000-2013 MPlayer Team
203 audio & 423 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/sda2/Movies/Frozen/Frozen.mp4.
libavformat version 55.12.102 (internal)
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang eng
VIDEO:  [H264]  1920x856  24bpp  23.976 fps  2191.4 kbps (267.5 kbyte/s)
Clip info:
 major_brand: isom
 minor_version: 1
 compatible_brands: isomavc1
 creation_time: 2014-02-27 06:26:54
Load subtitles in /mnt/sda2/Movies/Frozen/
[vo_vaapi] Using OpenGL rendering
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'vdpau'
libva info: Trying to open /usr/lib/dri/vdpau_drv_video.so
libva info: va_openDriver() returns -1
[vo_vaapi] vaInitialize(): unknown libva error
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 55.18.102 (internal)
AUDIO: 48000 Hz, 2 ch, floatle, 93.7 kbit/3.05% (ratio: 11714->384000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A:   2.4 (02.3) of 6133.1 ( 1:42:13.0)  0.8% 
[1]+  Stopped                 mplayer -vo vaapi:gl /mnt/sda2/Movies/Frozen/Frozen.mp4

EDIT: Wine performance on the open source drivers is iffy. So staying with catalyst until open source drivers are better or equal to catalyst in wine performance.

Last edited by pittedmetal (2014-04-28 16:04:18)

Offline

#9 2014-04-28 16:05:05

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [SOLVED] VDPAU and VAAPI problems

vainfo is still trying to open vdpau_drv_video.so. Did you do "export LIBVA_DRIVER_NAME=vdpau" somewhere? If yes, remove that too, of course. Even better, change it to LIBVA_DRIVER_NAME=xvba

Offline

#10 2014-04-28 16:26:38

pittedmetal
Member
Registered: 2014-04-28
Posts: 9

Re: [SOLVED] VDPAU and VAAPI problems

Gusar wrote:

vainfo is still trying to open vdpau_drv_video.so. Did you do "export LIBVA_DRIVER_NAME=vdpau" somewhere? If yes, remove that too, of course. Even better, change it to LIBVA_DRIVER_NAME=xvba

I followed your suggestion and typed into the terminal unset LIBVA_DRIVER_NAME and then typed export LIBVA_DRIVER_NAME=xvba. vainfo seems to have no error this time-

libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'xvba'
libva info: Trying to open /usr/lib/dri/xvba_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.0)
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.8.0
vainfo: Supported profile and entrypoints
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD

On the other hand, vdpauinfo still has the same error-

display: :0.0   screen: 0
Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

Mplayer now is displaying video and audio. So I think that fixed a part of the problem. Should I still be worried about the error vdpauinfo is reporting or just carry on with vaapi playback?

This is what Mplayer gives when I play a video through vdpau

MPlayer SVN-r36265-4.8.2 (C) 2000-2013 MPlayer Team
203 audio & 423 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/sda2/Movies/Frozen/Frozen.mp4.
libavformat version 55.12.102 (internal)
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang eng
VIDEO:  [H264]  1920x856  24bpp  23.976 fps  2191.4 kbps (267.5 kbyte/s)
Clip info:
 major_brand: isom
 minor_version: 1
 compatible_brands: isomavc1
 creation_time: 2014-02-27 06:26:54
Load subtitles in /mnt/sda2/Movies/Frozen/
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 55.18.102 (internal)
AUDIO: 48000 Hz, 2 ch, floatle, 93.7 kbit/3.05% (ratio: 11714->384000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A:   1.2 (01.2) of 6133.1 ( 1:42:13.0)  0.7% 
[2]+  Stopped                 mplayer -vo vdpau -fs /mnt/sda2/Movies/Frozen/Frozen.mp4

Thanks a lot :)

Last edited by pittedmetal (2014-04-28 16:41:16)

Offline

#11 2014-04-28 16:38:50

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [SOLVED] VDPAU and VAAPI problems

VDPAU has its own environment variable to choose the driver. You have libvdpau-va-gl installed, now we just need to tell the system to use it:

export VDPAU_DRIVER=va_gl

I'm really curious to know if it'll work. If it does, we'll be doing VDPAU->VAAPI->XvBA. Talk about indirection smile

Offline

#12 2014-04-28 16:45:05

pittedmetal
Member
Registered: 2014-04-28
Posts: 9

Re: [SOLVED] VDPAU and VAAPI problems

Gusar wrote:

VDPAU has its own environment variable to choose the driver. You have libvdpau-va-gl installed, now we just need to tell the system to use it:

export VDPAU_DRIVER=va_gl

I'm really curious to know if it'll work. If it does, we'll be doing VDPAU->VAAPI->XvBA. Talk about indirection smile

big_smile it worked ! Thank you so much. How do you know all this? The wiki doesn't even mention them (sorry for my ignorance). Anyway, thank you once again.

Offline

#13 2015-01-04 11:45:17

batot
Member
From: Poland
Registered: 2012-08-15
Posts: 31

Re: [SOLVED] VDPAU and VAAPI problems

I was this same problem past update.
"Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory"
You must install "mesa-git" from AUR. He can depend uninstall some other drivers package. Don't worry it's safe and normal.
[...]
[2015-01-04 03:57] [ALPM] removed svga-dri-git (10.1.0_devel.60653-1)
[2015-01-04 03:57] [ALPM] removed nouveau-dri-git (10.1.0_devel.60653-1)
[2015-01-04 03:57] [ALPM] removed intel-dri-git (10.1.0_devel.60653-1)
[2015-01-04 03:57] [ALPM] removed ati-dri-git (10.1.0_devel.60653-1)

$ yaourt -Q mesa-git
local/mesa-git 10.5.0_devel.67137-1

$ vainfo
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/r600_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

$ lspci |grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320]

You don't need VAAPI or XvBA.
For me (E-450) R600 very good working VDPAU.
Without HW acceleraton 1080p my cpu (E-450) usage ~100% and ony about 5~10 frame video.
With HW not enough switch run mplayer witch option -vo vdpau *.mkv".
Full HW you will be that you use example "mplayer -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,ffodivxvdpau, -lavdopts threads=2"
But becouse for me this freeze frame mus add "-ao alsa:device=hw=1.1" and CPU usage 4% with 1080p video wink GREAT.
If somebody have problem with full decode HW VDPAU write me I try help.
I use all time smplayer and working excellence wink

Last edited by batot (2015-01-04 11:48:13)

Offline

#14 2015-01-04 12:28:06

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [SOLVED] VDPAU and VAAPI problems

batot, you're using the open driver, so your problem is not related to this thread, because pittedmetal is using the closed catalyst driver.

But anyway, the solution for you isn't mesa-git from AUR, it's installing mesa-vdpau. You can of course use mesa-git from AUR, but there's no need for compiling AUR stuff when you can just use mesa and mesa-vdpau from the main repositories.

Offline

#15 2015-01-04 14:00:38

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,699
Website

Re: [SOLVED] VDPAU and VAAPI problems

Batot, this is the second thread you've tried to hijack in two days, and now it's on an older solved thread.  Stop.

Please continue the discussion in your thread which I split off from your previous hijacking attempt here:
https://bbs.archlinux.org/viewtopic.php?id=191826

You can certainly add links to threads you think may be related - particularly if you are describing what solutions you've already tried.

Thread Closed.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB