You are not logged in.

#1 2014-04-29 18:02:19

persio
Member
Registered: 2014-04-29
Posts: 15

[SOLVED] can't install google-earth because lib32 is missing

I downloaded google-earth 7.1.2.2041-2 from AUR and when I try to install it, I can't because these dependencies are missing:

ld-lsb>=3-5
lib32-fontconfig
lib32-glu
lib32-libgl
lib32-libsm
lib32-libxrender
lib32-mesa

I have tried searching the forums and apparently this lib32 comes with some nvidia drivers. In fact, I have an Nvidia graphics card (geforce 9800M GTS) but I'm using nouveau drivers, and if I try to install something like nvidia-304xx-libgl, it says I can't because it conflicts with mesa-libgl, which is needed by nouveau-dri. How can I solve this?

Thanks in advance.

Last edited by persio (2014-04-29 19:42:19)

Offline

#2 2014-04-29 18:06:22

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,796

Re: [SOLVED] can't install google-earth because lib32 is missing

Offline

#3 2014-04-29 18:25:49

persio
Member
Registered: 2014-04-29
Posts: 15

Re: [SOLVED] can't install google-earth because lib32 is missing

I'm a little bit confused. Why do I need to enable multilib if I'm using 32-bit? I forgot to mention that in the original post.

Offline

#4 2014-04-29 18:34:55

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,796

Re: [SOLVED] can't install google-earth because lib32 is missing

If you're on i686, then the package should not be asking for lib32 libs. Report it to the maintainer.

Offline

#5 2014-04-29 18:41:28

o_caino
Member
Registered: 2013-06-06
Posts: 159

Re: [SOLVED] can't install google-earth because lib32 is missing

Are you using AUR helpers? There are a lot of comments reporting the same or similar problems with lib32-* dependencies.
Try to build the package just by using makepkg.

Offline

#6 2014-04-29 18:42:34

persio
Member
Registered: 2014-04-29
Posts: 15

Re: [SOLVED] can't install google-earth because lib32 is missing

Scimmia wrote:

If you're on i686, then the package should not be asking for lib32 libs. Report it to the maintainer.

OK, done.

o_caino wrote:

Are you using AUR helpers? There are a lot of comments reporting the same or similar problems with lib32-* dependencies.
Try to build the package just by using makepkg.

I'm not, I used makepkg.

Offline

#7 2014-04-29 18:45:58

o_caino
Member
Registered: 2013-06-06
Posts: 159

Re: [SOLVED] can't install google-earth because lib32 is missing

Then edit the PKGBUILD yourself. The correct dependencies for i686 are in line 37 of the PKGBUILD

Offline

#8 2014-04-29 18:49:19

persio
Member
Registered: 2014-04-29
Posts: 15

Re: [SOLVED] can't install google-earth because lib32 is missing

o_caino wrote:

Then edit the PKGBUILD yourself. The correct dependencies for i686 are in line 37 of the PKGBUILD

I'd gladly do it, but I don't know what I'm supposed to do. Line 37 says:

depends=('desktop-file-utils' 'fontconfig' 'glu' 'hicolor-icon-theme' 'ld-lsb>=3-5' 'libgl' 'libsm' 'libxrender' 'mesa' 'shared-mime-info' 'xdg-utils')

Offline

#9 2014-04-29 18:52:47

o_caino
Member
Registered: 2013-06-06
Posts: 159

Re: [SOLVED] can't install google-earth because lib32 is missing

Replace line 15 (the one containing the lib32-* stuff) by line 37. You can also replace the optdepends variable the same way.

Offline

#10 2014-04-29 19:00:14

persio
Member
Registered: 2014-04-29
Posts: 15

Re: [SOLVED] can't install google-earth because lib32 is missing

I replaced line 15 with line 37, and now I only get "target not found: ld-lsb>=3-5" (the rest of the dependencies are not showing up).

?¿

Offline

#11 2014-04-29 19:10:17

o_caino
Member
Registered: 2013-06-06
Posts: 159

Re: [SOLVED] can't install google-earth because lib32 is missing

Do you have all the dependencies installed? e.g. ld-lsb?
If you get more errors do as Scimmia said on #4 and contact the mantainer.

Offline

#12 2014-04-29 19:17:45

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,714

Re: [SOLVED] can't install google-earth because lib32 is missing

I suggest using the in browser version instead. It is actually faster for most people than the dedicated client (and much less trouble with sig11's etc...)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#13 2014-04-29 19:19:35

persio
Member
Registered: 2014-04-29
Posts: 15

Re: [SOLVED] can't install google-earth because lib32 is missing

Mr.Elendig wrote:

I suggest using the in browser version instead. It is actually faster for most people than the dedicated client (and much less trouble with sig11's etc...)

Their website says: "the Google Earth Plugin is currently only available on Windows and Mac OS X 10.6+".

o_caino wrote:

Do you have all the dependencies installed? e.g. ld-lsb?
If you get more errors do as Scimmia said on #4 and contact the mantainer.

I downloaded ld-lsb from AUR, but when I try to install it I get again "target not found: lib32-glibc". My system is 32-bit, shouldn't I have this library installed?

Last edited by persio (2014-04-29 19:25:23)

Offline

#14 2014-04-29 19:29:23

persio
Member
Registered: 2014-04-29
Posts: 15

Re: [SOLVED] can't install google-earth because lib32 is missing

OH OH OH!!

I'm terribly sorry to you all. I don't know why but I just found out that... I'm running 64 bit. I don't know when I chose that. Please forgive me, I was proud for being able to install arch in an encrypted environment yesterday and get everything up and running, but I didn't realize I was on 64.

Sorry and thanks everyone for your help!

Offline

#15 2014-04-29 19:30:24

o_caino
Member
Registered: 2013-06-06
Posts: 159

Re: [SOLVED] can't install google-earth because lib32 is missing

persio wrote:

My system is 32-bit, shouldn't I have this library installed?

No.

Edit:

persio wrote:

I just found out that... I'm running 64 bit.

That explains a lot...
Please, mark your thread as solved by editing your first post.

Last edited by o_caino (2014-04-29 19:34:46)

Offline

Board footer

Powered by FluxBB