You are not logged in.

#1 2014-04-14 04:49:07

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,292

haskell update broken: any news?

Hi,

Research:
haskell update
[SOLVED] haskell-transformers: requires ghc=7.6.3-1
Somehow, the ideas above are not applicable. Is there a general way to set things to rights? It's just haskell-pandoc and aura which I use.

$ sudo aura -Syy
:: Synchronizing package databases...
 core                                                                                                                    110.9 KiB   178K/s 00:01 [##########################################################################################] 100%
 haskell-core                                                                                                            194.4 KiB   314K/s 00:01 [##########################################################################################] 100%
 haskell-core.sig                                                                                                         96.0   B  0.00B/s 00:00 [##########################################################################################] 100%
 haskell-happstack                                                                                                        57.5 KiB   236K/s 00:00 [##########################################################################################] 100%
 haskell-happstack.sig                                                                                                   287.0   B  0.00B/s 00:00 [##########################################################################################] 100%
 extra                                                                                                                  1571.4 KiB   753K/s 00:02 [##########################################################################################] 100%
 community                                                                                                                 2.1 MiB  1174K/s 00:02 [##########################################################################################] 100%
 multilib                                                                                                                115.5 KiB   186K/s 00:01 [##########################################################################################] 100%
$ checkupdates                   
alex
blender
cups
dart
device-mapper
ditaa
ffmpeg
file
geany
geany-plugins
ghc
gnutls
happy
haskell-aeson
haskell-asn1-encoding
haskell-asn1-parse
haskell-asn1-types
haskell-attoparsec
haskell-base-unicode-symbols
haskell-base64-bytestring
haskell-blaze-builder
haskell-blaze-html
haskell-blaze-markup
haskell-byteable
haskell-case-insensitive
haskell-cereal
haskell-cipher-aes
haskell-cipher-rc4
haskell-conduit
haskell-connection
haskell-cookie
haskell-cprng-aes
haskell-crypto-cipher-types
haskell-crypto-numbers
haskell-crypto-pubkey
haskell-crypto-pubkey-types
haskell-crypto-random
haskell-cryptohash
haskell-data-default
haskell-data-default-class
haskell-data-default-instances-base
haskell-data-default-instances-containers
haskell-data-default-instances-dlist
haskell-data-default-instances-old-locale
haskell-digest
haskell-dlist
haskell-exceptions
haskell-extensible-exceptions
haskell-hashable
haskell-highlighting-kate
haskell-hslua
haskell-http
haskell-http-client
haskell-http-client-tls
haskell-http-conduit
haskell-http-types
haskell-json
haskell-lifted-base
haskell-mmorph
haskell-monad-control
haskell-mtl
haskell-nats
haskell-network
haskell-pandoc
haskell-pandoc-types
haskell-parsec
haskell-pem
haskell-primitive
haskell-publicsuffixlist
haskell-random
haskell-regex-base
haskell-regex-pcre
haskell-resourcet
haskell-scientific
haskell-securemem
haskell-semigroups
haskell-socks
haskell-syb
haskell-tagsoup
haskell-temporary
haskell-texmath
haskell-text
haskell-tls
haskell-transformers-base
haskell-unordered-containers
haskell-utf8-string
haskell-vector
haskell-void
haskell-x509
haskell-x509-store
haskell-x509-system
haskell-x509-validation
haskell-xml
haskell-yaml
haskell-zip-archive
haskell-zlib
imagemagick
intel-dri
lib32-libdrm
libcups
libdrm
libreoffice-base
libreoffice-calc
libreoffice-common
libreoffice-draw
libreoffice-en-US
libreoffice-gnome
libreoffice-impress
libreoffice-kde4
libreoffice-math
libreoffice-postgresql-connector
libreoffice-sdk
libreoffice-sdk-doc
libreoffice-writer
linux
linux-headers
lvm2
mesa
mesa-libgl
pcre
python2-setuptools

Last edited by Llama (2014-05-06 02:11:23)

Offline

#2 2014-04-14 13:21:55

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: haskell update broken: any news?

What errors do you get?
Are you using a 32-bit system or a 64-bit one?

Offline

#3 2014-04-14 13:37:05

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,292

Re: haskell update broken: any news?

karol wrote:

What errors do you get?

$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 haskell-core is up to date
 haskell-happstack is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: haskell-transformers: local (0.3.0.0-27) is newer than extra (0.3.0.0-4)
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-binary: requires ghc=7.6.3-1
:: haskell-failure: requires ghc=7.6.3-1
:: haskell-http-client-conduit: requires ghc=7.6.3-1
:: haskell-http-client-conduit: requires haskell-conduit=1.0.13-1
:: haskell-http-client-conduit: requires haskell-http-client=0.2.3-1
:: haskell-http-client-conduit: requires haskell-resourcet=0.4.10-3
:: haskell-pcre-light: requires ghc=7.6.3-1
:: haskell-transformers: requires ghc=7.6.3-1
:: haskell-zlib-bindings: requires ghc=7.6.3-1
:: haskell-zlib-bindings: requires haskell-zlib=0.5.4.1-2
$ 
karol wrote:

Are you using a 32-bit system or a 64-bit one?

x86_64

Offline

#4 2014-04-14 13:40:27

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,408
Website

Re: haskell update broken: any news?

You are using unofficial haskell repos.  Either they need fixed, or those packages are AUR ones and you need to fix it.

Offline

#5 2014-04-14 13:40:55

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: haskell update broken: any news?

I see https://aur.archlinux.org/packages/hask … t-conduit/ in the AUR, but not in any repo - where did you get it?

Edit:

Llama wrote:
karol wrote:

Are you using a 32-bit system or a 64-bit one?

x86_64

You're using [multilib] so I should have figured that out, sorry.

Last edited by karol (2014-04-14 13:42:22)

Offline

#6 2014-04-14 14:18:39

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: haskell update broken: any news?

I would post on the the arch-haskell mailing list:

http://www.haskell.org/mailman/listinfo/arch-haskell

In the meantime, try commenting out [haskell-core] in pacman.conf and if pacman tries to overwrite anything with haskell stuff from the extra/community, put it (them) in IgnorePkg.

Last edited by skottish (2014-04-14 14:30:02)

Offline

#7 2014-04-15 04:38:19

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,292

Re: haskell update broken: any news?

skottish wrote:

I would post on the the arch-haskell mailing list:

Thanks!

skottish wrote:

In the meantime, try commenting out [haskell-core] in pacman.conf and if pacman tries to overwrite anything with haskell stuff from the extra/community, put it (them) in IgnorePkg.

I guess I'll have to do it. It's a longish list to put in IgnorePkg.

Offline

#8 2014-04-18 12:34:30

Aton
Member
Registered: 2013-04-02
Posts: 63

Re: haskell update broken: any news?

The problem seems to be that haskell-transformers has been removed
from [haskell-core] and basically been replaced with haskell-transformers-base.

haskell-transformers was an indirect dependency of pandoc.
The [extra] repository contains an older version of haskell-transformers which is
why you see that error message.

If it's only two packages you have from [haskell-core], I'd simply remove them
and reinstall.

Offline

#9 2014-04-19 00:01:08

donuon
Member
Registered: 2013-08-28
Posts: 31

Re: haskell update broken: any news?

Same issues here. I tried commenting out [haskell-core] and still got error messages.
Also tried commenting out [extra] just to see what would happen and its the same as if it is left in.
My main requirements for haskell are xmonad, xmobar, and pandoc.

With [haskell-core] enabled

error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-binary: requires ghc=7.6.3-1
:: haskell-pcre-light: requires ghc=7.6.3-1
:: haskell-transformers: requires ghc=7.6.3-1
:: haskell-xmonad-contrib: requires ghc=7.6.3-1
:: haskell-xmonad-contrib: requires haskell-x11=1.6.1.1-5
:: haskell-xmonad-contrib: requires haskell-x11-xft=0.3.1-31
:: haskell-xmonad-contrib: requires haskell-extensible-exceptions=0.1.1.4-27
:: haskell-xmonad-contrib: requires haskell-mtl=2.1.2-27
:: haskell-xmonad-contrib: requires haskell-random=1.0.1.1-27
:: haskell-xmonad-contrib: requires haskell-utf8-string=0.3.7-27
:: haskell-xmonad-contrib: requires haskell-xmonad=0.11-7

Commenting out [haskell-core]

error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-aeson: requires haskell-mtl=2.1.2-27
:: haskell-aeson: requires haskell-text=0.11.3.1-1
:: haskell-aeson: requires haskell-vector=0.10.9.1-1
:: haskell-attoparsec: requires haskell-text=0.11.3.1-1
:: haskell-blaze-builder: requires haskell-text=0.11.3.1-1
:: haskell-blaze-html: requires haskell-text=0.11.3.1-1
:: haskell-blaze-markup: requires haskell-text=0.11.3.1-1
:: haskell-conduit: requires haskell-mtl=2.1.2-27
:: haskell-conduit: requires haskell-text=0.11.3.1-1
:: haskell-conduit: requires haskell-transformers=0.3.0.0-27
:: haskell-exceptions: requires haskell-mtl=2.1.2-27
:: haskell-exceptions: requires haskell-transformers=0.3.0.0-27
:: haskell-hashable: requires haskell-text=0.11.3.1-1
:: haskell-highlighting-kate: requires haskell-mtl=2.1.2-27
:: haskell-highlighting-kate: requires haskell-parsec=3.1.5-1
:: haskell-hslua: requires haskell-mtl=2.1.2-27
:: haskell-json: requires haskell-mtl=2.1.2-27
:: haskell-json: requires haskell-parsec=3.1.5-1
:: haskell-json: requires haskell-text=0.11.3.1-1
:: haskell-mmorph: requires haskell-transformers=0.3.0.0-27
:: haskell-monad-control: requires haskell-transformers=0.3.0.0-27
:: haskell-pandoc: requires haskell-http=4000.2.10-3
:: haskell-pandoc: requires haskell-mtl=2.1.2-27
:: haskell-pandoc: requires haskell-network=2.4.2.2-2
:: haskell-pandoc: requires haskell-parsec=3.1.5-1
:: haskell-pandoc: requires haskell-text=0.11.3.1-1
:: haskell-pandoc: requires haskell-vector=0.10.9.1-1
:: haskell-regex-base: requires haskell-mtl=2.1.2-27
:: haskell-resourcet: requires haskell-mtl=2.1.2-27
:: haskell-resourcet: requires haskell-transformers=0.3.0.0-27
:: haskell-scientific: requires haskell-text=0.11.3.1-1
:: haskell-semigroups: requires haskell-text=0.11.3.1-1
:: haskell-tagsoup: requires haskell-text=0.11.3.1-1
:: haskell-temporary: requires haskell-transformers=0.3.0.0-27
:: haskell-texmath: requires haskell-parsec=3.1.5-1
:: haskell-transformers-base: requires haskell-transformers=0.3.0.0-27
:: haskell-xml: requires haskell-text=0.11.3.1-1
:: haskell-xmonad: requires haskell-mtl=2.1.2-27
:: haskell-xmonad-contrib: requires haskell-mtl=2.1.2-27
:: haskell-yaml: requires haskell-text=0.11.3.1-1
:: haskell-yaml: requires haskell-transformers=0.3.0.0-27
:: haskell-yaml: requires haskell-vector=0.10.9.1-1
:: haskell-zip-archive: requires haskell-mtl=2.1.2-27
:: haskell-zip-archive: requires haskell-text=0.11.3.1-1

Offline

#10 2014-04-19 13:46:29

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,549

Re: haskell update broken: any news?

I had the same problem with haskell-transformers and haskell-xmonad-contrib. Here's how I solved it on my system.

The problem,

sudo pacman -Su
:: Starting full system upgrade...
warning: haskell-transformers: local (0.3.0.0-27) is newer than extra (0.3.0.0-4)
warning: qiv: ignoring package upgrade (2.2.4-2 => 2.3.1-1)
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-transformers: requires ghc=7.6.3-1
:: haskell-xmonad-contrib: requires ghc=7.6.3-1
:: haskell-xmonad-contrib: requires haskell-x11=1.6.1.1-5
:: haskell-xmonad-contrib: requires haskell-x11-xft=0.3.1-31
:: haskell-xmonad-contrib: requires haskell-extensible-exceptions=0.1.1.4-27
:: haskell-xmonad-contrib: requires haskell-mtl=2.1.2-27
:: haskell-xmonad-contrib: requires haskell-random=1.0.1.1-27
:: haskell-xmonad-contrib: requires haskell-utf8-string=0.3.7-27
:: haskell-xmonad-contrib: requires haskell-xmonad=0.11-7

So step one, I removed haskell-transformers. Since haskell-mtl depends on it, I had to use -Rdd. Then I removed haskell-xmonad-contrib with good old fashioned -R.

For step two, pacman -Su. Nothing seems to depend on haskell-transformers-base. I installed it anyways as I might want to use it for my own stuff.

Step three, haskell-xmonad-contrib in the repos changed without a version bump.

sudo pacman -S haskell-xmonad-contrib
resolving dependencies...
looking for inter-conflicts...

Packages (1): haskell-xmonad-contrib-0.11.2-2

Total Installed Size:   71.02 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                                                                                             [-----------------------------------------------------------------------------------------------] 100%
(1/1) checking package integrity                                                                                                                           [-----------------------------------------------------------------------------------------------] 100%
error: haskell-xmonad-contrib: signature from "ArchHaskell (Magnus Therning) <magnus@therning.org>" is invalid
:: File /var/cache/pacman/pkg/haskell-xmonad-contrib-0.11.2-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.



sudo pacman -U /var/cache/pacman/pkg/haskell-xmonad-contrib-0.11.2-2-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "haskell-x11=1.6.1.1-5", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-x11-xft=0.3.1-31", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-extensible-exceptions=0.1.1.4-27", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-mtl=2.1.2-27", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-random=1.0.1.1-27", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-utf8-string=0.3.7-27", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-xmonad=0.11-7", a dependency of "haskell-xmonad-contrib"
:: The following package cannot be upgraded due to unresolvable dependencies:
      haskell-xmonad-contrib

:: Do you want to skip the above package for this upgrade? [y/N] N
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-xmonad-contrib: requires haskell-x11=1.6.1.1-5
:: haskell-xmonad-contrib: requires haskell-x11-xft=0.3.1-31
:: haskell-xmonad-contrib: requires haskell-extensible-exceptions=0.1.1.4-27
:: haskell-xmonad-contrib: requires haskell-mtl=2.1.2-27
:: haskell-xmonad-contrib: requires haskell-random=1.0.1.1-27
:: haskell-xmonad-contrib: requires haskell-utf8-string=0.3.7-27
:: haskell-xmonad-contrib: requires haskell-xmonad=0.11-7

I had to download it and install with -U.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#11 2014-04-19 14:48:25

donuon
Member
Registered: 2013-08-28
Posts: 31

Re: haskell update broken: any news?

So I followed in fsckd footsteps and started forcefully removing packages to try and get an upgrade. I was successfull but I needed to remove the following:

haskell-transformers
haskell-xmonad-contrib
haskell-pandoc
haskell-zip-archive
haskell-binary
haskell-pcre-light

I then ran pacman -Su and successfully completed a system upgrade, however there were many many non crticial warnings/errors related to upgraded misc. haskell packages. Once upgraded haskell-transformers-base had been installed, haskell-binary was part of ghc-7.8.2-1 and haskell-pcre-light was no longer found. I reinstalled haskell-pandoc which also installed haskell-zip-archive as a dependency.

The only thing I am unable to reinstall is haskell-xmonad-contrib for which I get the following error:

resolving dependencies...
warning: cannot resolve "ghc=7.6.3-1", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-x11=1.6.1.1-5", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-x11-xft=0.3.1-31", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-extensible-exceptions=0.1.1.4-27", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-mtl=2.1.2-27", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-random=1.0.1.1-27", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-utf8-string=0.3.7-27", a dependency of "haskell-xmonad-contrib"
warning: cannot resolve "haskell-xmonad=0.11-7", a dependency of "haskell-xmonad-contrib"
:: The following package cannot be upgraded due to unresolvable dependencies:
      haskell-xmonad-contrib

:: Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-xmonad-contrib: requires ghc=7.6.3-1
:: haskell-xmonad-contrib: requires haskell-x11=1.6.1.1-5
:: haskell-xmonad-contrib: requires haskell-x11-xft=0.3.1-31
:: haskell-xmonad-contrib: requires haskell-extensible-exceptions=0.1.1.4-27
:: haskell-xmonad-contrib: requires haskell-mtl=2.1.2-27
:: haskell-xmonad-contrib: requires haskell-random=1.0.1.1-27
:: haskell-xmonad-contrib: requires haskell-utf8-string=0.3.7-27
:: haskell-xmonad-contrib: requires haskell-xmonad=0.11-7

That was after trying to pacman -U the package file as I get the same invalid or corrupted package (PGP signature) as mentioned by fsckd.

Offline

#12 2014-04-19 16:47:45

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,549

Re: haskell update broken: any news?

donuon wrote:

That was after trying to pacman -U the package file as I get the same invalid or corrupted package (PGP signature) as mentioned by fsckd.

The package in the repo was updated without changing the version. One needs to remove the package from one's pacman cache. Then pacman will download it again and that should install without errors.

(I downloaded it with wget and installed with pacman -U. Hence my description in my previous post was confusing. Sorry about that.)


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#13 2014-04-19 23:22:24

donuon
Member
Registered: 2013-08-28
Posts: 31

Re: haskell update broken: any news?

Ahh my bad, sorted it out with

pacman -Sc
pacman -S haskell-xmonad-contrib

Confirmed that fsckd solution works.
Not OP,  so can't mark solved.

Offline

#14 2014-04-25 04:31:27

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,292

Re: haskell update broken: any news?

It won't work for me, donuon. At least, with

[haskell-core]
Server = http://xsounds.org/~haskell/core/$arch

[haskell-happstack]
 Server = ftp://noaxiom.org/$repo/$arch

on. Do you use something else?

Offline

#15 2014-04-25 09:27:05

silverbucket
Member
From: Prague, Czech Republic
Registered: 2013-05-17
Posts: 11
Website

Re: haskell update broken: any news?

I had the same issue and can confirm this worked for me as well!

@Llama - I think the working solution is what fsckd explained here: https://bbs.archlinux.org/viewtopic.php … 8#p1406438

Offline

#16 2014-04-25 15:40:42

donuon
Member
Registered: 2013-08-28
Posts: 31

Re: haskell update broken: any news?

Llama

Here is that section of my pacman.conf

[core]
Include = /etc/pacman.d/mirrorlist

[haskell-core]
Server = http://xsounds.org/~haskell/core/$arch

[haskell-happstack]
Server = ftp://noaxiom.org/$repo/$arch

[extra]
Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

What I did notice after the fact was I left  [extra] commented out, not sure if that had anything to do with my success.

However, I just noticed an additional issue where dependencies for aura are now broken. I'll create a new post for this issue and link it here incase you run into similar issues.

Edit: The issue was a bonehead mistake on my part, I didn't have [haskell-happstack] in the conf. Once added everything was fine. I've updated the code block above to include it aswell.

Last edited by donuon (2014-04-25 15:59:21)

Offline

#17 2014-04-27 04:36:27

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,292

Re: haskell update broken: any news?

Sorry, short of pacman -Rsc everything nothing worked in my case. Can't mark it solved.

Last edited by Llama (2014-04-29 05:05:21)

Offline

#18 2014-04-29 04:51:48

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,292

Re: haskell update broken: any news?

Maintainers did a fine job of it.

Offline

#19 2014-04-30 21:24:36

eFFeeMMe
Member
Registered: 2009-04-10
Posts: 9

Re: haskell update broken: any news?

Sooooo I -Rdd'ed all the offending packages and then -Syu'ed. The upgrade seemed to go fine. Am I safe?

Offline

#20 2014-05-06 02:12:52

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,292

Re: haskell update broken: any news?

eFFeeMMe wrote:

Sooooo I -Rdd'ed all the offending packages and then -Syu'ed. The upgrade seemed to go fine. Am I safe?

Not quite, probably. At it again on my box.

Offline

#21 2014-05-17 16:36:09

donuon
Member
Registered: 2013-08-28
Posts: 31

Re: haskell update broken: any news?

Yup I'm back at it now too.

error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-mime-types: requires haskell-text=1.1.0.1-3

however the output of pacman -Qs is

local/haskell-text 1.1.0.1-3
    An efficient packed Unicode text type.

Offline

#22 2014-05-18 00:21:42

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: haskell update broken: any news?

I think you're reading the error message wrong: haskell-mime-types blocks the update of haskell-text from version 1.1.0.1-3 to some other, because it needs this particular version.
How did you get this error? Did you run 'pacman -Syu' or some other command?
Where did you get haskell-mime-types from? haskell-core for both 32 and 64-bit packages shows that haskell-mime-types 0.1.0.4-2 requires ghc=7.8.2-1 and haskell-text=1.1.1.2-1.

Offline

#23 2014-05-18 01:58:16

donuon
Member
Registered: 2013-08-28
Posts: 31

Re: haskell update broken: any news?

You're right I was reading the error message wrong.
I'm running 64-bit and the error message was the result of 'pacman -Syu'.
The haskell-mime-types package is 0.1.0.4-2 from haskell-core and my output for 'pacman -Qi' says it is dependent on ghc=7.8.2-1 haskell-text=1.1.0.1-3.

Offline

#24 2014-05-18 02:09:47

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: haskell update broken: any news?

Post the output of

pacman -Si haskell-mime-types
pacman -Q haskell-mime-types

Offline

#25 2014-05-18 02:56:55

donuon
Member
Registered: 2013-08-28
Posts: 31

Re: haskell update broken: any news?

'pacman -Si haskell-mime-types' shows a different version dependency requirement like you had said above.

Repository     : haskell-core
Name           : haskell-mime-types
Version        : 0.1.0.4-2
Description    : Basic mime-type handling types and functions
Architecture   : x86_64
URL            : https://github.com/yesodweb/wai
Licenses       : MIT
Groups         : None
Provides       : None
Depends On     : ghc=7.8.2-1  haskell-text=1.1.1.2-1
Optional Deps  : None
Conflicts With : None
Replaces       : None
Download Size  : 525.86 KiB
Installed Size : 8635.00 KiB
Packager       : Magnus Therning <magnus@therning.org>
Build Date     : Fri 09 May 2014 06:10:12 PM EDT
Validated By   : MD5 Sum  SHA256 Sum  Signature

pacman -Q haskell-mime-types

haskell-mime-types 0.1.0.4-2

Offline

Board footer

Powered by FluxBB