You are not logged in.

#1 2014-05-13 16:55:04

stupidus
Member
Registered: 2012-02-27
Posts: 124

Libreoffice in KDE does not use KDE file dialogs

Hello,

I have libreoffice-4.2.4-1 from [extra] installed, together with libreoffice-kde4 4.2.4-1. But it still shows the GTK file open/save dialog instead of the KDE one.

I tried starting libreoffice with the following command that I got from the wiki:

SAL_USE_VCLPLUGIN=kde4 lowriter

But that does not change anything. I guess, the autodetection of libreoffice works well, and it is already using the QT style even without the SAL_USE_VCLPLUGIN variable set. It is just not using the right file dialogs. There is a setting libreoffice options (Tools--> Options --> General --> Use Libreoffice dialogs), but it is unchecked.

I checked the forums about this, but the only thing I could find were some threads about a bug with Libreoffice crashing on start. I experienced that bug too, and it seems to be gone now. Unfortunately, I find the missing KDE file dialogs even more annoying.

Offline

#2 2014-05-13 17:53:32

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,644

Re: Libreoffice in KDE does not use KDE file dialogs

Offline

#3 2014-05-13 18:23:06

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,359
Website

Re: Libreoffice in KDE does not use KDE file dialogs

Try OOO_FORCE_DESKTOP=kde.


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#4 2014-05-13 20:41:42

Götz
Member
Registered: 2009-02-16
Posts: 25

Re: Libreoffice in KDE does not use KDE file dialogs

I experience the same problem since version 4.2.4

With

OOO_FORCE_DESKTOP=kde4

nothing changes. And when using kde as the variable, everything is smaller and it seems that without a theme.

arojas' link is for sure the explanation for the missing dialog.


What I hear, I forget. What I say, I remember. What I do, I understand.  –Tao Te Ching/Laozi

Offline

#5 2014-05-14 11:03:05

stupidus
Member
Registered: 2012-02-27
Posts: 124

Re: Libreoffice in KDE does not use KDE file dialogs

For me OOO_FORCE_DESKTOP=kde4 does not solve the problem either.

About arojas' link: Do I understand this correctly, that they disabled the KDE file dialog because it is possible that the application crashes in certain conditions due to some QT component? And they hardcoded that, so you cannot reactivate it using some option?

Offline

#6 2014-05-14 14:29:33

FernandoBasso
Member
From: Brazil
Registered: 2010-10-27
Posts: 86
Website

Re: Libreoffice in KDE does not use KDE file dialogs

Same problem for me. Tried several "solutions"; none worked.


There is a difference between knowing the path and walking the path.

Offline

Board footer

Powered by FluxBB