You are not logged in.

#1 2014-05-13 09:05:15

G-kun
Member
Registered: 2014-05-13
Posts: 3

[SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

I make clear wine32 prefix and try to install vcrun2005 with winetricks

[g-kun@lambada ~]$ bash winetricks vcrun2005
Executing w_do_call vcrun2005
Executing load_vcrun2005
Using native,builtin override for following DLLs: atl80 msvcm80 msvcp80 msvcr80 vcomp
Executing winetricks_early_wine regedit C:\windows\Temp\_vcrun2005\override-dll.reg
Executing wine vcredist_x86.EXE
fixme:advapi:DecryptFileA ("C:\\users\\g-kun\\Temp\\IXP000.TMP\\", 00000000): stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
fixme:storage:create_storagefile Storage share mode not implemented.
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
------------------------------------------------------
vcrun2005 install completed, but installed file /home/g-kun/.wine/dosdevices/c:/windows/winsxs/x86_microsoft.vc80.mfc_1fc8b3b9a1e18e3b_8.0.50727.6195_none_deadbeef/mfc80.dll not found
------------------------------------------------------

Output from WINEARCH=win32 winecfg

[g-kun@lambada ~]$ WINEARCH=win32 winecfg
wine: created the configuration directory '/home/g-kun/.wine'
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
fixme:storage:create_storagefile Storage share mode not implemented.
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:appwizcpl:install_file MsiInstallProduct failed: 1615
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/home/g-kun/.wine' has been updated.

Last edited by G-kun (2014-05-14 06:14:00)

Offline

#2 2014-05-13 18:12:22

HiImTye
Member
From: Nanaimo, BC, Canada
Registered: 2012-05-09
Posts: 1,061

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

Offline

#3 2014-05-13 19:59:24

varsovie
Member
Registered: 2006-12-24
Posts: 14

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

I have exactly this same problem after upgrade.
Entire .wine folder removed to be sure there is pure wine profile.

G-Kun if the problem for you are lower/upercase filenames like mentioned by HilmTye the best way is to do loop device having fat fs linked to .wine and try then.

Offline

#4 2014-05-13 22:23:22

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

Probably a bug in wine.

wine-git-1.7.17.r92.ge2bf516-1-x86_64.pkg.tar.xz -- works as expected
wine-git-1.7.18.r136.g0fb88f8-1-x86_64.pkg.tar.xz -- throws mentioned errors

@moderator: you probably want to merge this thread with this one.

Offline

#5 2014-05-13 22:31:33

G-kun
Member
Registered: 2014-05-13
Posts: 3

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

emeres wrote:

Probably a bug in wine.

wine-git-1.7.17.r92.ge2bf516-1-x86_64.pkg.tar.xz -- works as expected
wine-git-1.7.18.r136.g0fb88f8-1-x86_64.pkg.tar.xz -- throws mentioned errors

@moderator: you probably want to merge this thread with this one.

I tryed to install wine 1.7.17 from sources (bin32-wine) (x86_x64 arch with gcc-mulltilib 4.9.0-02) but get same error

P.S sorry for bad english. Im from Russia smile

Offline

#6 2014-05-13 23:17:20

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

You could try ARM (if 1.7.17 does not work, try 1.7.16). The bug might have still been introduced in 1.7.17 version (at a later release than I stated).

Offline

#7 2014-05-14 00:37:37

SierraWhite
Member
Registered: 2014-05-14
Posts: 1

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

I filed a bug report a few days ago. See: https://bugs.archlinux.org/task/40310.
According to the wine devs this has to do with compiling the wine on gcc 4.9 Compiling with 4.8 resolves the issue.
The current solution is to install gcc 4.8 and build wine on that instead of the latest version.

EDIT:

Downloading 1.7.17 from the server emeres linked to and running pacman/yaourt -U pkgname solved the issue temporarily.
Don't forget to add an IgnorePkg=wine to /etc/pacman.conf until this gets fixed.

Last edited by SierraWhite (2014-05-14 00:46:20)

Offline

#8 2014-05-14 06:11:34

G-kun
Member
Registered: 2014-05-13
Posts: 3

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

I downgrade wine with this tool downgrader and it vcrun2005 worked !!!
Thanks for helping and fast reply :)

Offline

#9 2015-02-26 10:36:32

pdragon
Member
Registered: 2015-02-26
Posts: 1

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

G-kun wrote:

I downgrade wine with this tool downgrader and it vcrun2005 worked !!!
Thanks for helping and fast reply smile

Это плохо ибо у меня wine 1.6 и та же проблема, а на какую версию даунгрэйд сделал?

Offline

#10 2015-02-26 12:31:40

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,150
Website

Re: [SOLVED]can't install vcrun2005 on wine 1.7.18 (x64)

pdragon, please do not "necrobump" old threads, particularly solved ones.  Also please post in English on the main forums - there are language specific subforums/threads.  According to google-translate, your post suggests you are using an outdated version of wine.  The first thing to do is update your system.  Feel free to start a new thread and link to this one if you need help with an issue.

Closed.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB