You are not logged in.

#1 2014-02-20 03:24:05

henriqueleng
Member
Registered: 2014-02-18
Posts: 77

[SOLVED] Audio problems with alsa!

I have an Asus z87-k and i conected a soundbox on the audio card, in the green conector (that is the out) and i cant have any sound playing.

An screenshot from my alsamixer  https://imagizer.imageshack.us/v2/1358x … 6/7lsr.png

I checked everithing twice and anithing solved, i`ll be online to give any other information!

Last edited by henriqueleng (2014-02-22 04:31:18)


Emacs - tmux - Cmus - Mutt - Lynx/w3m - ....

Offline

#2 2014-02-20 09:56:37

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio problems with alsa!

Do you hear sound when something else is plugged in, say headphones? Show your ~/.asoundrc, /etc/asound.conf. Do you use jack, pulseaudio or any other soundserver? What does aplay -l show?

Offline

#3 2014-02-21 00:50:26

henriqueleng
Member
Registered: 2014-02-18
Posts: 77

Re: [SOLVED] Audio problems with alsa!

Lets continue the post!

I don't have any file in /etc/asound.conf., and i dont know where it can be!

I'm trying to configure alsa without any other server (pulseaudio, jack,...).

My lspci output have two audio devices, i think that is one of hdmi:

00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
---- 00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
----- 00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z87 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)
04:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 03)

I read in another forum that is because my hdmi as set as default. In Arch wiki, they say that i need to edit alsa-base.conf archive, but my pc dont have it too. I too read that how im using two devices that are using same module, edit alsa-base.conf dont will help.

Aplay -l Show me

**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Please help!


Emacs - tmux - Cmus - Mutt - Lynx/w3m - ....

Offline

#4 2014-02-21 01:00:36

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,025
Website

Re: [SOLVED] Audio problems with alsa!

Please don't keep using help in your thread titles: https://wiki.archlinux.org/index.php/Fo … ow_to_Post


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2014-02-21 01:25:07

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio problems with alsa!

Read alsa wiki. Set PCH card as your default.

Offline

#6 2014-02-21 01:41:12

henriqueleng
Member
Registered: 2014-02-18
Posts: 77

Re: [SOLVED] Audio problems with alsa!

Yeeah, it worked! Solved

i Just created the asound.conf file in /etc and added the lines

pcm.!default {
	type hw
	card 2
}

ctl.!default {
	type hw           
	card 2
}

Replacing the card number, with the number of my audio card that the command aplay -l showed me.

This is wath aplay -l give me

**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

So, in my asoun.conf file i put 1, to make the card 1, that is the PCH intel as default card!

Thank you!!


Emacs - tmux - Cmus - Mutt - Lynx/w3m - ....

Offline

#7 2014-02-21 10:16:39

brebs
Member
Registered: 2007-04-03
Posts: 3,742

Re: [SOLVED] Audio problems with alsa!

No, that's a terrible method. You've only redefined "default"- what about e.g. surround20? Plus, it looks like you've disabled dmix.

See ALSA wiki for better methods.

Offline

#8 2014-02-21 23:59:29

henriqueleng
Member
Registered: 2014-02-18
Posts: 77

Re: [SOLVED] Audio problems with alsa!

Now, im with no sound on firefox!


Emacs - tmux - Cmus - Mutt - Lynx/w3m - ....

Offline

#9 2014-02-22 00:17:47

henriqueleng
Member
Registered: 2014-02-18
Posts: 77

Re: [SOLVED] Audio problems with alsa!

brebs wrote:

No, that's a terrible method. You've only redefined "default"- what about e.g. surround20? Plus, it looks like you've disabled dmix.

See ALSA wiki for better methods.

Please, i'm new in Arch.

Waths the problem about it? And wath is dmix?


Emacs - tmux - Cmus - Mutt - Lynx/w3m - ....

Offline

#10 2014-02-22 00:22:19

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,363

Re: [SOLVED] Audio problems with alsa!

henriqueleng wrote:

And wath is dmix?

http://lmgtfy.com/?q=site%3Aarchlinux.org+dmix


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#11 2014-02-22 00:31:02

henriqueleng
Member
Registered: 2014-02-18
Posts: 77

Re: [SOLVED] Audio problems with alsa!

And the explanation about why my method is bad?


Emacs - tmux - Cmus - Mutt - Lynx/w3m - ....

Offline

#12 2014-02-22 02:21:17

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio problems with alsa!

It is not optimal for your case and I guess majority of desktop users. I actually meant to post this link, but was writing a bit for the other part, so it is my bad. Using modules configuration leaves, the enabled by default now, dmix plugin on top of corresponding card. Dmix is a software mixer (mixes different audio streams) for sound cards not supporting hardware mixing (meaning most on the market), so you can play multiple sounds at the same time (which is what you want right now). Having set hardware without any other configuration makes it unavailable to other applications as long as first one getting hold of it uses it.
If you use changing order by modules, delete that ~/.asoundrc. You can however edit it: add a dmix plugin and make it your default pcm device, tweak parameters further, etc. If you are not going to do any further configuration, then modules are the way to go.
And if you stay with that ~/.asoundrc use card names, not numbers.

Offline

#13 2014-02-22 03:52:17

henriqueleng
Member
Registered: 2014-02-18
Posts: 77

Re: [SOLVED] Audio problems with alsa!

Hi, i think that now its really solved.

Be realy confusing to me configure a module because all the two audio devices in my conputer are using the same module. I have two equal modules loaded, one for each audio card.

So when i created a alsa-base.conf file in /etc/modprobe.d like the wiki one
This is the file that i created.

options snd slots=snd_hda_intel,snd_hda_intel
options snd_hda_intel index=0
options snd_hda_intel index=1

It is really strange and confused. When i created it i dont expect that it stuff but now everithing is ok.

Now i wanna know if for a better organization have how i  differentiate the modules, in a way that the system understand. I think this because my system are showing my two modules with a number before the module name.
Have how i express it on the alsa-base.conf file like snd_hda_intel1 or something like this?

[henrique@henrique-pc ~]$ cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel

Emacs - tmux - Cmus - Mutt - Lynx/w3m - ....

Offline

#14 2014-04-19 13:58:14

brebs
Member
Registered: 2007-04-03
Posts: 3,742

Re: [SOLVED] Audio problems with alsa!

Here's my ~/.asoundrc, to fix the problem of the first card being "MID" rather than "PCH":

defaults.pcm.!card PCH
defaults.ctl.!card PCH

Offline

#15 2014-05-16 20:18:21

randomize46
Member
From: Moldova
Registered: 2011-11-16
Posts: 3

Re: [SOLVED] Audio problems with alsa!

Actually The Wiki here also describes the case when two cards use the same module (snd_hda_intel) but you want to specify some desired order of detection with index=x parameter in /etc/modprobe.d/alsa-base.conf file and need some way to distinguish them. You should use VID and PID. Using output of this command:

$ lspci -nn | grep -i audio

outputs this in my case

00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 04)

I set my Asus H87-PRO modo sound cards order like this in /etc/modprobe.d/alsa-base.conf :

options snd-hda-intel index=0 model=auto vid=8086 pid=8c20
options snd-hda-intel index=1 model=auto vid=8086 pid=0c0c

Seems working and no additional ~/.asoundrc used yet.

Offline

#16 2014-05-17 00:08:24

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio problems with alsa!

All comes down to the system. If alsa only is used, the defaults node brebs suggests should be preferred, since it does not mingle with the whole systems settings (and if that is needed, /etc/asound.conf can be used), can be [more] easily transferred/modified (no additional privileges needed) and keeps the default alsa configuration intact. If the user however runs or will be running a sound server (for example pulseaudio), the modprobe method should be preferred, since it gets it right for [probably] every sound architecture, which would cover the majority of users and therefore should be usually the preferred one (which is the reason it stays as the default configuration method on the wiki).
There is no reason for not using both methods in a more sophisticated configuration however.

Last edited by emeres (2014-05-17 00:13:22)

Offline

Board footer

Powered by FluxBB