You are not logged in.

#1 2006-02-13 03:48:16

viniosity
Member
From: New York, NY
Registered: 2005-01-22
Posts: 378
Website

Suspend inconsistent [solved.. I hope]

I am using the hibernate scripts and CK kernel to put my thinkpad to suspend (ram) mode.  If I put it to sleep and resume within a few minutes it generally works but I notice that if I leave it suspended for a while (haven't measured but say 30 minutes) that I have problems when I resume.

The most common is that it resumes and I can type as normal and execute commands in the console. (I always quit X before I type hibernate.)  But when I issue the startx command it will briefly start the X window manager (I see the 'X') and then the screen goes black. It doesn't go dark.. it goes black/blank. meaning there is still power to the screen but I can't see anything.  Switching VT does not get me back to a console at the point so I can only push the power button and start the shutdown process.

Has anyone else seen that?  Or, more importantly, know how to solve it?  Here is my hibernate.conf file:

[b]edit:[/b]
Snipped.. see below for new correct config

Offline

#2 2006-02-28 14:29:05

patroclo7
Member
From: Bassano del Grappa, ITALY
Registered: 2006-01-11
Posts: 913

Re: Suspend inconsistent [solved.. I hope]

Are you using a ck kernel or an archck one? I ask this, since I had  your problems when I tried to suspend to ram (not only to disk) without:
1) the suspend2 patch: this is surprising, since this patch should provide a new and proficient suspension to disk, and should not modify anything concerning suspension to ram (except for allowing suspension to ram after suspension to disk: an highly useful combination and what I do in most cases);
2) the radeonfb sleep fix which is around; this is relevant only if you have a radeon card; if you have one, than the best solution is just to used radeonfb (instead of any flavour of vesafb) and to apply that fix.

Both the patch and the fix are included in the archck patchset, but not in the mere ck one.
If you are running an archck kernel, then you can try to use radeonfb (provided you have a radeon card) and to activate the sleep fix with the specific kernel boot parameter:
video=radeonfb:force_sleep=1
With this solution, I am actually able to resume from suspending without that issue with startx and also to suspend to ram (and to disk, and to ram after suspension to disk) from inside X.


Mortuus in anima, curam gero cutis

Offline

#3 2006-02-28 15:13:18

viniosity
Member
From: New York, NY
Registered: 2005-01-22
Posts: 378
Website

Re: Suspend inconsistent [solved.. I hope]

I am using the CK Kernel but I do not have a Radeon card -- I've got an intel i915 chipset.

It's really frustrating me.. this is the one feature that kept me on Ubuntu for so long.  Arch is so much better in every other way. sad

Offline

#4 2006-02-28 21:08:52

patroclo7
Member
From: Bassano del Grappa, ITALY
Registered: 2006-01-11
Posts: 913

Re: Suspend inconsistent [solved.. I hope]

I would try with the suspend2 stuff anyway (if you are unable to suspend to ram, you will anyway be able to suspend to disk smile ). I suspect that it is not trivial to apply the suspend2 patch to a ck kernel, so I suggest to use the marvellous archck, which includes both.


Mortuus in anima, curam gero cutis

Offline

#5 2006-03-26 22:19:40

viniosity
Member
From: New York, NY
Registered: 2005-01-22
Posts: 378
Website

Re: Suspend inconsistent [solved.. I hope]

I accidentally screwed up my installation so I had to wipe everything out and reload Arch.  Instead of using the CK kernel I am using 2.6.16 from the testing repo. 

With the same hibernate scripts above, I can no longer get the display to come back after suspending.  Did I miss installing something the second time around or were there some changes that made the hibernate scripts not work?

I've got ibm_acpi and acpid loaded.  Did I forget an important module or daemon?

edit: looks like I forgot to pass the kernel params during boot.  Here is my  grub menu.lst line:

# (0) Arch Linux
title  Arch Linux
root   (hd0,2)
kernel /boot/vmlinuz26 root=/dev/sda3 ro console=tty1 resume2=swap:/dev/sda2 acpi_sleep=s3_bios,s3_mode
initrd /boot/initrd26.img

and the working hibernate.conf (make sure to disable vbe for the thinkpad x41.. but it may be needed for non-ibm's..

# Example hibernate.conf file. Adapt to your own tastes.
# Options are not case sensitive.
# 
# Run "hibernate -h" for help on the configuration items.

##############################################################################
### Choose your Suspend method. You currently have 3 choices:
###
###    suspend2            Software Suspend 2 (requires kernel patches from
###                        http://www.suspend2.net/)
###
###    sysfs_power_state   Uses /sys/power/state to suspend (activates pmdisk
###                        on kernels < 2.6.8, or vanilla swsusp otherwise).
###
###    acpi_sleep          Uses /proc/acpi/sleep to activate swsusp, or other
###                        ACPI sleep state supported by your machine.
###
##############################################################################

### suspend2 (for Software Suspend 2)
#UseSuspend2 yes
#Reboot no
#EnableEscape yes
#DefaultConsoleLevel 1
#Compressor lzf
#Encryptor none
# ImageSizeLimit 200
## useful for initrd usage:
# SuspendDevice swap:/dev/hda2
## Powerdown method - 3 for suspend-to-RAM, 4 for ACPI S4 sleep, 5 for poweroff
# PowerdownMethod 5
## Any other /proc/software_suspend setting can be set like so:
# ProcSetting expected_compression 50
## Or traditionally like this:
# Suspend2AllSettings 0 0 2056 65535 5
## Or even from the results of hibernate --save-settings with this:
# Suspend2AllSettingsFile /etc/hibernate/suspend-settings.conf
## For filewriter:
# FilewriterLocation /suspend_file 1000
# VerifyFilewriterResume2 yes
# ProcSetting userui_program /usr/local/sbin/suspend2ui_text

### sysfs_power_state
## To use /sys/power/state to suspend your machine (which may offer
## suspend-to-RAM, suspend-to-disk, standby, etc) comment out all the options
## above for Software Suspend 2, below for acpi_sleep, and uncomment this line.
## You may replace mem with any one of the states from "cat /sys/power/state"
UseSysfsPowerState mem
# PowerdownMethod shutdown

### acpi_sleep
## To use ACPI to suspend your machine (via /proc/acpi/sleep), comment out
## all the options above for Software Suspend 2 and sysfs, and uncomment this
## line. The number refers to the ACPI sleep state - 3 is suspend-to-RAM and
## 4 is suspend-to-disk.
# UseACPISleep 3

##############################################################################
### Some global settings
##############################################################################

Verbosity 0
LogFile /var/log/hibernate.log
LogVerbosity 1
# AlwaysForce yes
# AlwaysKill yes
# HibernateVT 15
# Distribution debian (or fedora/gentoo/mandrake/redhat/slackware/suse)
# XDisplay :0

##############################################################################
### Scriptlets
###   Scriptlets provide support for doing all sorts of things before and after
###   suspending. The defaults settings here should work for most people, but
###   you may wish to edit these to taste. Consult "hibernate -h" for help on
###   the configuration settings.
##############################################################################

### bootsplash
## If you use bootsplash, also enabling SwitchToTextMode is recommended if
## you use X, otherwise you may end up with a garbled X display.
# Bootsplash on
# BootsplashConfig /etc/bootsplash/default/config/bootsplash-1024x768.cfg

### clock
SaveClock restore-only

### devices
# IncompatibleDevices /dev/dsp /dev/video*

### diskcache
DisableWriteCacheOn /dev/sda2

### fbsplash (enable SwitchToTextMode if you use this)
#FBSplash on
#FBSplashTheme suspend2

### filesystems
# Unmount /nfsshare /windows /mnt/sambaserver
# UnmountFSTypes smbfs nfs
# UnmountGraceTime 1
# Mount /windows

### grub
# ChangeGrubMenu yes
# GrubMenuFile /boot/grub/menu.lst
# AlternateGrubMenuFile /boot/grub/menu-suspended.lst
# BackupGrubMenuFile /boot/grub/menu.lst.hibernate.bak

### hardware_tweaks
IbmAcpi yes
#RadeonTool yes

### lilo
# EnsureLILOResumes yes

### lock (generally you only want one of the following options)
# LockConsoleAs root
# LockXScreenSaver yes
# LockKDE yes
# LockXLock yes
# LockXAutoLock yes

### misclaunch
# OnSuspend 20 echo "Good night!"
# OnResume 20 echo "Good morning!"

### modules
# UnloadModules snd_via82cxxx usb-ohci
# UnloadAllModules yes
UnloadBlacklistedModules yes
LoadModules auto
# LoadModulesFromFile /etc/modules

### modules-gentoo
# GentooModulesAutoload yes

### network
# DownInterfaces eth0
# UpInterfaces auto

### pcmcia
# EjectCards yes

### programs
# IncompatiblePrograms xmms

### services
# RestartServices postfix
# StopServices alsasound
# StartServices aumix

### vbetool
#EnableVbetool yes
#RestoreVbeStateFrom /var/lib/vbetool/vbestate
#VbetoolPost yes
#RestoreVCSAData yes

### xhacks
SwitchToTextMode yes
#UseDummyXServer yes

### xstatus
## This can be set to gnome, kde or x:
XStatus gnome
# XSuspendText Preparing to suspend...
# XResumeText Resuming from suspend...
## When using XStatus x, and you have xosd installed:
#XosdSettings --font -misc-fixed-medium-r-semicondensed--*-120-*-*-c-*-*-* --colour=Green --shadow 1 --pos bottom --align center --offset 50

Offline

Board footer

Powered by FluxBB