You are not logged in.

#1 2014-06-01 20:26:20

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

[solved] No internet with systemd 213-3.

Probably because of https://bugs.archlinux.org/task/40629
I had to run

# systemctl enable systemd-resolved
# systemctl start systemd-resolved

to make my internet work again as it worked just fine in systemd 213-2.


Just a heads-up.

Last edited by karol (2014-07-21 17:33:47)

Offline

#2 2014-06-01 23:36:04

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: [solved] No internet with systemd 213-3.

Without explaining more about your setup, this seems really strange... systemd-resolved manages a file in /run which isn't used by default, and won't take precedence over a runtime resolv.conf generated by systemd-networkd.

What symptoms were you seeing? How do you otherwise manage your network config?

Offline

#3 2014-06-02 09:23:31

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [solved] No internet with systemd 213-3.

Symptoms? I got

$ ping -c 3 google.com
ping: unknown host www.google.com

I checked pacman log and noticed that one of the packages I've updated before the reboot was systemd. I downgraded to previous version and it worked.
I managed to figure it out when I run htop with both versions. I have a lean setup so it was easy to spot that systemd-resolved wasn't running.

What exactly do you need to know about my setup? I use an ethernet cable to connect my computer to the router/modem.
I've read the wiki to get an idea what systemd-networkd is about when I replaced dhcpcd with it, but I don't remember what configuration I've done, if any. What exactly should I post?

$ cat /etc/systemd/network/20-dhcp.network
[Match]
Name=*

[Network]
DHCP=yes
$ ip l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 00:09:6b:f3:a8:42 brd ff:ff:ff:ff:ff:ff

Offline

#4 2014-06-02 12:45:50

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: [solved] No internet with systemd 213-3.

The nature of /etc/resolv.conf is what's relevant here. I guess if this is a symlink on upgrade to 213, resolved should stay enabled.

Offline

#5 2014-06-02 21:56:19

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [solved] No internet with systemd 213-3.

Yes, it's a symlink:

$ ls -l /etc/resolv.conf 
lrwxrwxrwx 1 root root 32 Mar 14 08:37 /etc/resolv.conf -> /run/systemd/network/resolv.conf

Maybe I had something misconfigured. Should I downgrade systemd and check something? Should I disable systemd-resolved too?

Offline

#6 2014-06-02 22:32:58

Wibjarm
Member
Registered: 2012-05-04
Posts: 40

Re: [solved] No internet with systemd 213-3.

No, it isn't a misconfiguration, networkd just doesn't manage resolv.conf itself anymore.  It did previously, but that got removed when resolved was added, so  you need to have resolved enabled now if you were relying on networkd to generate the resolv.conf in /run.  It's an easy one to miss though, since the news file doesn't mention specifically that networkd doesn't do that anymore, and you have to poke through the commit log to find it.

Last edited by Wibjarm (2014-06-02 22:33:39)

Offline

Board footer

Powered by FluxBB