You are not logged in.

#1 2013-10-18 09:05:35

rggjan
Member
Registered: 2007-01-06
Posts: 69

Ctrl+shift+U -> Unicode input, how to disable?

Anyone knows how to disable ctrl+shift+u unicode input?

Whenever I press ctrl+shift+u, I get an underlined "u" and can enter some unicode number. However, I don't need it, and because of this, for example in qt creator the predefined "ctrl+shift+u" keyboard shortcut doesn't work.

I have no idea where this mapping comes from (obviously not qt, since ctrl+shift+u is mapped to an important shortcut), but maybe gnome or the xserver?

Thanks already

Offline

#2 2013-10-18 11:04:12

Jellicent
Member
From: Berlin
Registered: 2013-09-13
Posts: 187

Re: Ctrl+shift+U -> Unicode input, how to disable?

That depends on the terminal emulator you are using I think, you might wanna look there.

Offline

#3 2013-10-18 11:39:17

VCoolio
Member
From: Netherlands
Registered: 2010-01-05
Posts: 119

Re: Ctrl+shift+U -> Unicode input, how to disable?

It's a gtk+ / gnome thing that some terminal emulators support. But the op asked how to disable it. I'd look into either locale or input method settings. Try changing your locale to something ISO instead of something UTF, or mess around with the GTK_IM_MODULE variable like explained here

Offline

#4 2013-10-26 08:15:25

rggjan
Member
Registered: 2007-01-06
Posts: 69

Re: Ctrl+shift+U -> Unicode input, how to disable?

@Jellicent: No, it doesn't depend on the program. This happens in *every* application (firefox, qt programs, terminals, xterm, tk programs, gtk programs, ...).

@VCoolio: Changing the locale to ISO doesn't help. I'm going to check the GTK_IM_MODULE...

Offline

#5 2013-11-03 09:34:52

rggjan
Member
Registered: 2007-01-06
Posts: 69

Re: Ctrl+shift+U -> Unicode input, how to disable?

Didn't manage. I guess I'll have to live without the ctrl+shift+u shortcut sad

Offline

#6 2014-06-11 19:28:46

peniwize
Member
Registered: 2014-04-08
Posts: 3

Re: Ctrl+shift+U -> Unicode input, how to disable?

I just updated from Ubuntu 13.10 to Ubuntu 14.04 and I found that I have exactly this same problem, which is being caused by ibus (my up to date Arch system doesn't seem to have the problem).  You can see if ibus is running on your system via:

$ ps aux | grep -i ibus
peniwize  3108  0.0  0.2  47180  3620 ?        Ssl  Jun09   1:44 /usr/bin/ibus-daemon --daemonize --xim
peniwize  3127  0.0  0.0  37268   264 ?        Sl   Jun09   0:00 /usr/lib/ibus/ibus-dconf
peniwize  3129  0.0  0.7 181000 13040 ?        Sl   Jun09   0:34 /usr/lib/ibus/ibus-ui-gtk3
peniwize  3147  0.0  0.2  40224  3984 ?        Sl   Jun09   0:00 /usr/lib/ibus/ibus-x11 --kill-daemon
peniwize  3179  0.0  0.0  27956  1096 ?        Sl   Jun09   0:10 /usr/lib/ibus/ibus-engine-simple

I'm running XFCE and there is now a "Language Support" icon in the "Settings" panel (select "Settings Manager" on the main menu.)  The Language Support app contains a "Keyboard input method system" selection on Language tab.  I changed it from 'IBus' to 'None' and now Ctrl+Shift+u works again.  (This is a quick and dirty solution that works for me because I'm only using English and never have to type special characters.)

Offline

#7 2016-04-21 11:53:54

mandalic
Member
Registered: 2009-11-13
Posts: 43

Re: Ctrl+shift+U -> Unicode input, how to disable?

I figured out that killing ibus-daemon process removes the stubborn keybinding.

Offline

Board footer

Powered by FluxBB