You are not logged in.

#1 2014-06-24 20:00:08

hariskar
Member
From: Greece/Kavala
Registered: 2012-10-16
Posts: 181
Website

Soundcard not visible in Audacity playback devices

Although I have disabled the onboard sound card in bios it is listed here:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: D2X [Xonar D2X], device 0: Multichannel [Multichannel]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: D2X [Xonar D2X], device 1: Digital [Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: H4 [H4], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

In ~/.asoundrc I have set:

pcm.!default {
	type hw
	card 1
}

ctl.!default {
	type hw           
	card 1
}

BUT in audacity only the disabled NVidia cards are visible as playback devices. What can I do to be able to use Xonar D2X as playback device in audacity?
I have no other sound card relating problems.

Thank you

Offline

#2 2014-06-24 21:36:29

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: Soundcard not visible in Audacity playback devices

hariskar wrote:

Although I have disabled the onboard sound card in bios it is listed here

Which one is that supposed to be? Card 0 is from the GPU, card 1 is a PCI[E] device (certainly not integrated) and card 2 a USB one.

Are you aware of the limitation of this ~/.asoundrc setup? I recommend you first set up Xonar as your default device using defaults.pcm.card node or modprobe options. Or provide a more sophisticated setup in alsa configuration. Read the Alsa wiki.

Audacity lists in preferences every pcm and hw combination I have as playback and recording devices.

Last edited by emeres (2014-06-24 21:40:06)

Offline

Board footer

Powered by FluxBB