You are not logged in.

#1 2014-07-05 06:00:01

MoonSwan
Member
From: Great White North
Registered: 2008-01-23
Posts: 873

[solved] Taskcoach (AUR) Installs but does not work

Hello Fellow Forumers! 

I installed Taskcoach from the AUR and it compiled fine without errors.  However, when I try to run it from a terminal I get the following errors:

:~: taskcoach.py 

/bin/sh: xprop: command not found
Traceback (most recent call last):
  File "/usr/bin/taskcoach.py", line 72, in <module>
    start()
  File "/usr/bin/taskcoach.py", line 63, in start

/bin/sh: xprop: command not found
Traceback (most recent call last):
  File "/usr/bin/taskcoach.py", line 72, in <module>
    start()
  File "/usr/bin/taskcoach.py", line 63, in start
  app = application.Application(options, args)
  File "/usr/lib/python2.7 site-packages/taskcoachlib/patterns/singleton.py", line 29, in __call__
    class_.instance = super(Singleton, class_).__call__(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/taskcoachlib/application/application.py", line 117, in __init__
    self.init(**kwargs)
  File "/usr/lib/python2.7/site-packages/taskcoachlib/application/application.py", line 226, in init
    self.settings, splash=splash)
  File "/usr/lib/python2.7/site-packages/taskcoachlib/gui/mainwindow.py", line 92, in __init__
    self.taskFile.efforts())
  Filei"/usr/lib/python2.7/site-packages/taskcoachlib/gui/idlecontroller.py", line 84, in __init__
    super(IdleController, self).__init__()
  File "/usr/lib/python2.7/site-packages/taskcoachlib/patterns/observer.py", line 333, in __init__
    super(Observer, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/taskcoachlib/powermgt/idle.py", line 111, in __init__
    IdleQuery.__init__(self)
  File "/usr/lib/python2.7/site-packages/taskcoachlib/powermgt/idle.py", line 46, in __init__
    _xss = CDLL('libXss.so.1')
  File "/usr/lib/python2.7/ctypes/__init__.py", line 365, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: libXss.so.1: cannot open shared object file: No such file or directory

I have no idea where to even start sorting out these errors.  hmm  Help?

Last edited by MoonSwan (2014-07-05 06:47:55)


I'm torn apart between worlds. Basically, using vim in a highly visual environment with a lot of mouse features feels like soldering a lose wire to a motherboard with a Zippo and a needle, while working with ANY TEXT AT ALL with a "modern GUI" text editor feels like joining the London Philharmonic Orchestra with a Fisher-Price Laugh and Learn Magical Musical Mirror.  --Awebb

Offline

#2 2014-07-05 06:42:41

teacha
Member
From: Poland
Registered: 2008-04-22
Posts: 57

Re: [solved] Taskcoach (AUR) Installs but does not work

Have you got libxss and xorg-xprop installed? They seem to be missing.

Last edited by teacha (2014-07-05 06:42:59)

Offline

#3 2014-07-05 06:46:34

MoonSwan
Member
From: Great White North
Registered: 2008-01-23
Posts: 873

Re: [solved] Taskcoach (AUR) Installs but does not work

Yay it works!  Thank you very much it was a simple fix and I really need to pay more attention to errors I think.  Now to see if I can get SnapWM to play nicely with it.


I'm torn apart between worlds. Basically, using vim in a highly visual environment with a lot of mouse features feels like soldering a lose wire to a motherboard with a Zippo and a needle, while working with ANY TEXT AT ALL with a "modern GUI" text editor feels like joining the London Philharmonic Orchestra with a Fisher-Price Laugh and Learn Magical Musical Mirror.  --Awebb

Offline

#4 2014-07-05 06:48:23

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,304
Website

Re: [solved] Taskcoach (AUR) Installs but does not work

Please remember to mark your thread as [Solved] by editing your first post and prepending it to the title.


Moving to AUR issues...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB