You are not logged in.

#1 2014-05-28 20:16:45

mudri
Member
Registered: 2014-05-22
Posts: 29

Yet another wireless problem

These threads must get boring. Sorry about that.

I got a new router today, after having Arch installed and working (to an extent - it required running wpa_supplicant manually after each boot) on the old router for a few weeks. As is evidenced by this post, I have connected to it wirelessly from another computer, and also wired to the Arch. But I can't get the wifi to work on Arch.

My /etc/wpa_supplicant.conf was generated via wpa_passphrase, and contains (new) ssid, commented-out plain passkey and hexadecimal passkey.

ip link show wlp2s0:

3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 94:db:c9:4a:80:99 brd ff:ff:ff:ff:ff:ff

I try to run:

# wpa_supplicant -i wlp2s0 -c /etc/wpa_supplicant.conf -B
Successfully initialized wpa_supplicant

, which is not successful. Leaving off the “-B” gives a lot of “wlp2s0: CTRL-EVENT-SCAN-STARTED”, and occasionally a bit which includes “WPA: 4-Way Handshake failed - pre-shared key may be incorrect”. It gets the right ssid, and auth_failures is incremented with every 4-Way Handshake failure.

I'm not sure what else to add, but I'll add more on request.

Last edited by mudri (2014-07-08 13:29:25)

Offline

#2 2014-05-28 21:14:34

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,441

Re: Yet another wireless problem

Just checking here.  Is there a reason you are not using a higher level tool, such as netctl?
We can make this work if this is how you want to do it.  Just be aware there may be a better way.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#3 2014-05-28 21:17:50

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

I've tried wifi-config and netctl, and both failed. I'd prefer to use one of those if they worked.

BTW:

# netctl list
  wlp2s0_tp_link5
  wlp2s0_tp_link2.4
  wlp2s0-linksys2

The top two are from the new router (5 GHz with ssid=tp-link5, which doesn't seem to work anywhere, and 2.4 GHz with ssid=tp-link2.4) and the bottom is from the old router.

“netctl start wlp2s0_tp_link2.4” gives a failure, asking me to see the outputs of systemctl and journalctl -xn commands. I'll add them when I take the Arch down to the wired connection.

Last edited by mudri (2014-05-28 21:32:01)

Offline

#4 2014-05-28 21:38:40

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

As promised:

root@arch ~# systemctl status netctl@wlp2s0_tp_link2.4.service
netctl@wlp2s0_tp_link2.4.service - Networking for netctl profile wlp2s0_tp_link2.4
   Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static)
   Active: failed (Result: exit-code) since Wed 2014-05-28 22:27:11 BST; 5min ago
     Docs: man:netctl.profile(5)
  Process: 5414 ExecStart=/usr/lib/network/network start %I (code=exited, status=1/FAILURE)
 Main PID: 5414 (code=exited, status=1/FAILURE)

May 28 22:27:11 arch network[5414]: Starting network profile 'wlp2s0_tp_link2.4'...
May 28 22:27:11 arch network[5414]: The interface of network profile 'wlp2s0_tp_link2.4' is already up
May 28 22:27:11 arch systemd[1]: netctl@wlp2s0_tp_link2.4.service: main process exited, code=exited, status=1/FAILURE
May 28 22:27:11 arch systemd[1]: Failed to start Networking for netctl profile wlp2s0_tp_link2.4.
May 28 22:27:11 arch systemd[1]: Unit netctl@wlp2s0_tp_link2.4.service entered failed state.
root@arch ~# journalctl -xn
-- Logs begin at Mon 2014-05-19 17:57:05 BST, end at Wed 2014-05-28 22:37:54 BST. --
May 28 22:37:23 arch NetworkManager[3771]: <warn> Connection disconnected (reason -3)
May 28 22:37:23 arch kernel: cfg80211: Calling CRDA to update world regulatory domain
May 28 22:37:23 arch kernel: wlp2s0: deauthenticating from c0:4a:00:99:f3:c4 by local choice (reason=3)
May 28 22:37:23 arch NetworkManager[3771]: <info> (wlp2s0): supplicant interface state: disconnected -> inactive
May 28 22:37:24 arch dhcpcd[242]: enp4s0: fe80::cc3d:4ff:fee6:add5 is unreachable, expiring it
May 28 22:37:29 arch dhcpcd[242]: enp4s0: fe80::cc3d:4ff:fee6:add5 is unreachable, expiring it
May 28 22:37:40 arch dhcpcd[242]: enp4s0: fe80::cc3d:4ff:fee6:add5 is unreachable, expiring it
May 28 22:37:40 arch dhcpcd[242]: enp4s0: fe80::cc3d:4ff:fee6:add5 is reachable again
May 28 22:37:45 arch dhcpcd[242]: enp4s0: fe80::cc3d:4ff:fee6:add5 is unreachable, expiring it
May 28 22:37:54 arch dhcpcd[242]: enp4s0: fe80::cc3d:4ff:fee6:add5 is unreachable, expiring it

Offline

#5 2014-05-29 19:20:29

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

It's a win for Roy! I rebooted and now it seems to work without issue.

Offline

#6 2014-05-29 19:39:17

GloW_on_dub
Member
Registered: 2013-03-13
Posts: 328

Re: Yet another wireless problem

FYI, in that case :

The interface of network profile 'wlp2s0_tp_link2.4' is already up

You just need to set it down before starting it again:

set ip link wlp2s0 down

Offline

#7 2014-05-29 21:21:49

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

Thanks. I'll try to remember that in the future.

Offline

#8 2014-06-03 10:18:37

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

The same problems started again, and nothing I tried before or was going to try has worked. Is there any way that I could just remove everything about wifi and set it up in the most normal way?

Offline

#9 2014-06-03 10:58:41

aposteeltje
Member
From: Netherlands
Registered: 2013-01-29
Posts: 11

Re: Yet another wireless problem

ip link set wlp2s0 up
wpa_supplicant -B -i wlp2s0 -c <(wpa_passphrase SSID PASSWORD)
dhcpcd wlp2s0

Where instead of typing:SSID, you actual type the SSID-name .,
and PASSWORD your password

Or, when using / running NetworkManager:
nmcli d wifi connect SSID-name password

Offline

#10 2014-06-03 11:34:04

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

I tried the first bit, but it was no different to what I'd already done. On the second one (using “nmcli d wifi connect tp-link2.4 password passkey”), I get “Error: Connection activation failed: (7) Secrets were required, but not provided.”. Makes it sound as if the passkey is wrong, but I'm copying directly from a 192.168.1.1 page.

Offline

#11 2014-06-03 11:52:22

aposteeltje
Member
From: Netherlands
Registered: 2013-01-29
Posts: 11

Re: Yet another wireless problem

What sort of wireless device are you using?
Build-in, usb-stick.
Is the firmware installed?

Offline

#12 2014-06-03 11:57:13

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

Built-in, and I've got it to work before, so I assume that the firmware's there.

Offline

#13 2014-06-03 18:31:34

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

Did some more things, and it seems to be working again. I deleted all the config files I had made (or at least, the ones I could find), then went through the wpa_supplicant instructions. It seemed fairly painless, so I think I'll mark this as solved. I don't know whether it will hold up after reboot, though.

Offline

#14 2014-07-08 13:43:50

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

Okay, I'm going to reuse this thread for a bit of cleaning up. Everything works, except that I have to run

sudo wpa_supplicant -B -i wlp2s0 -c /etc/wpa_supplicant/example.conf

after each login. How can I automate this?

By the way, I boot straight to Gnome 3.12.

Offline

#15 2014-07-11 17:44:34

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

All of my issues may have something to do with this. I've never had the Wifi icon in Gnome. This, as far as I know, is controlled by nm-applet. However, running that gives this:

> nm-applet 

** (nm-applet:22011): WARNING **: fetch_connections_done: error fetching connections: (32) Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory..

It stays running after that message. I do have a file at /lib/systemd/system/NetworkManager.service, which looks like this:

[Unit]
Description=Network Manager
Wants=network.target
Before=network.target

[Service]
Type=dbus
BusName=org.freedesktop.NetworkManager
ExecStart=/usr/bin/NetworkManager --no-daemon
# Suppress stderr to eliminate duplicated messages in syslog. NM calls openlog()
# with LOG_PERROR when run in foreground. But systemd redirects stderr to
# syslog by default, which results in logging each message twice.
StandardError=null
# NM doesn't want systemd to kill its children for it
KillMode=process

[Install]
WantedBy=multi-user.target
Alias=dbus-org.freedesktop.NetworkManager.service
Also=NetworkManager-dispatcher.service

Also, htop shows an instance of nm-applet for the current user. I can't kill this, even if I use sudo htop (in which case I see 3 instances). What's going on here?

Offline

#16 2014-07-11 20:57:15

classic1977
Member
Registered: 2014-07-11
Posts: 6

Re: Yet another wireless problem

try:

$ ln -s /usr/lib/systemd/system/NetworManager.service /usr/lib/systemd/system/dbus-org.freedesktop.NetworkManager.service

then:

$ systemctl start NetworkManager

If you get the wifi menu in gnome (under the arrow to the right of the power button), then you're in business, just...

$ systemctl enable NetworkManager

and it should start automatically... well, with GNOME, at least.

Last edited by classic1977 (2014-07-11 21:01:45)

Offline

#17 2014-07-11 21:42:49

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

That indeed brings back the Wifi indicator (which survives restarts), but I don't seem to be able to connect that way. And worse, it blocks the wpa_supplicant method. It keeps reprompting for a password, but I'm sure that I've got the passkey right (it is asking for the passkey, right?). I'm copying it straight from the router's settings page loaded on another computer, which matches what I've been using for wpa_supplicant.

Offline

#18 2014-07-11 23:24:30

classic1977
Member
Registered: 2014-07-11
Posts: 6

Re: Yet another wireless problem

That indeed brings back the Wifi indicator (which survives restarts), but I don't seem to be able to connect that way. And worse, it blocks the wpa_supplicant method. It keeps reprompting for a password, but I'm sure that I've got the passkey right (it is asking for the passkey, right?). I'm copying it straight from the router's settings page loaded on another computer, which matches what I've been using for wpa_supplicant.

You've tried restarting the AP, I assume. If not, maybe it's just a lease issue?

Last edited by classic1977 (2014-07-11 23:25:30)

Offline

#19 2014-07-11 23:46:05

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

The router? Yes. No luck. I reëntered the security information, and now it just seems to be stuck in a “connecting” state.

I have an indicator showing download and upload rates. In this “connecting” state, downloads are at about 100 B/s and uploads are at 0.

Disabling security on the router and in Gnome didn't seem to work, so I don't think it's a passkey issue.

Offline

#20 2014-07-12 18:47:19

rgb-one
Member
Registered: 2013-09-15
Posts: 19

Re: Yet another wireless problem

You can use the examples in /etc/netctl/examples/ as a template. if it is the wireless you are trying to connect to, then copy the wireless_wpa file from the /etc/netctl/examples directory, to the /etc/netctl directory:

# cd /etc/netctl/examples/ && cp examples/wireless_wpa my-network

edit the file filling in the relevant information (this is assuming your wireless is using wpa). When that is complete:

# netctl enable my-network // enable the network connection

If it doesn't work the first time ensure you input the correct information. Make note of the Interface name with:

# ip link

Ensure it is included in the my-networks file.

Last edited by rgb-one (2014-07-12 18:56:42)

Offline

#21 2014-07-12 19:15:45

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

No:

# netctl enable wlp2s0_tp_link24
ln -s '/etc/systemd/system/netctl@wlp2s0_tp_link24.service' '/etc/systemd/system/multi-user.target.wants/netctl@wlp2s0_tp_link24.service'
# ip link
...
3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether 94:db:c9:4a:80:99 brd ff:ff:ff:ff:ff:ff
# netctl status wlp2s0_tp_link24
• netctl@wlp2s0_tp_link24.service - Networking for netctl profile wlp2s0_tp_link24
   Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static)
   Active: inactive (dead)
     Docs: man:netctl.profile(5)

It was causing a “fail” on boot, so I stopped and disabled it (I can't remember which is which). I tried similar above, and it never worked.

Last edited by mudri (2014-07-12 22:11:23)

Offline

#22 2014-07-13 18:07:29

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

Something I noticed after reading man NetworkManager: my /etc/NetworkManager/dispatcher.d/ is empty. dnsmasq.d/ is also empty, but system-connections/ does contain a correct-looking file. Is that how things should be?

Offline

#23 2014-07-14 09:41:47

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

More information: using NetworkManager and the GUI, I can't make a wired connection. Here's some abridged output (I really don't want to type it all out):

# systemctl status NetworkManager -l
...: <warn> Trying to remove a non-existant call id.
# systemctl stop NetworkManager
# ip link
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> ... state UP
# systemctl status NetworkManager -l
...: <warn> the dhcpcd backend does not support IPv6.

None of the messages from the first `systemctl status` command appeared in the second. But, more importantly, what do I do about IPv6? Surely something can support it if not dhcpcd.

Edit: I've now disabled NetworkManager via `systemctl mask NetworkManager && systemctl mask NetworkManager-dispatcher`, so I can make a wired connection again.

Edit2: That basically puts me in the same position as I was in before I started the NetworkManager stuff. The wireless connection works if I run that wpa_supplicant command.

Last edited by mudri (2014-07-15 09:56:46)

Offline

#24 2014-07-30 11:04:01

mudri
Member
Registered: 2014-05-22
Posts: 29

Re: Yet another wireless problem

I'm having another crack at this, with the recently-ugpraded NetworkManager. I ran a few things:

> cd /etc/NetworkManager/dispatcher.d/
> ls
> sudo systemctl unmask NetworkManager-dispatcher.service 
Removed symlink /etc/systemd/system/NetworkManager-dispatcher.service.
> sudo systemctl start NetworkManager-dispatcher.service
> ls
pre-down.d/  pre-up.d/
> ls pre-up.d/
> ls pre-down.d/
>

As far as I understand, there are supposed to be some scripts in here. But I'm not getting any. Also, I followed the links around and found that NetworkManager-dispatcher.service relies on /usr/lib/networkmanager/nm-dispatcher, which is a binary file.

Offline

Board footer

Powered by FluxBB