You are not logged in.

#1 2006-02-19 02:39:19

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

testing: ATI drivers for xorg7 - packages renamed.

I've just uploaded a new set of ati drivers *hopefully* compatible with xorg7, to testing. It's impossible for me to test, I havn't got an ATI card, so your feedback is vital.

What's also important about this is that they use a new naming setup.

The userspace tools and xorg stuff are in 'ati-drivers',
The kernel modules in ati-drivers-arch, and ati-drivers-archck.

So to install ati drivers, you are best to pacman -S ati-drivers-kernel, where kernel is your kernel. This will bring in ati-drivers too.

After installing, it is important that you make a symlink from /usr/X11R6/lib/modules to /usr/lib/xorg/modules, othweise direct rendering will not work.

Thankyou for your patience.

James

Offline

#2 2006-02-19 03:12:24

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

Good idea, splitting kernel module from userspace tools..  I'll have to remove my driver and test these out.  big_smile

-edit-
Allright, I've had a look at what's there, and I have a couple suggestions:
1) ati-drivers should both provide and conflict with libgl instead of just provide it
2) you seem to still be using the libGL.so 'workaround' where the package installs ati.libGL.so and renames it afterwards. With the xorg7 packaging system, this is no longer necessary - that's the point of the libgl pseudo-package dependancy.
3) You MUST use the ati-drivers graphical installer for the xorg module - there's a version check in the 6.8.0 .rpm that refuses to allow it to load with xorg 7.  Check out my PKGBUILD on the Wiki: ATI fglrx and Xorg 7 for a quick reference as to how to do that.
4) The fireglcontrol.desktop file still points to /usr/X11R6/bin/fireglcontrolpanel - this should be updated to /usr/bin/fireglcontrolpanel

By the way, if you ever want assistance maintaining/testing ATI's drivers, give me a shout and I'll be all too happy to lend a hand.  I've got an ATI 9600 and I'm using xorg 7, so I'm a ginuea-pig all set up and ready to go. wink  Plus I've got a ton of experience working with these things.

-=edit to add suggestion 4

Offline

#3 2006-02-19 04:11:16

linfocito
Member
From: Gurupi - TO, Brasil
Registered: 2003-05-18
Posts: 82

Re: testing: ATI drivers for xorg7 - packages renamed.

I installed your drivers and it's complaining about xorg version ("...is 7.0.0.0 and should be 6.8.0.0...").


"...archoholism is a hard disease to cure..."
Archlinux Brasil

Offline

#4 2006-02-19 05:03:37

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: testing: ATI drivers for xorg7 - packages renamed.

I've just uploaded -3 of ati-drivers. Thanks to Cerebral's PKGBUILD and his excellent work as a guinea pig, according to him -3 works awesomely.

James

Offline

#5 2006-02-19 05:10:38

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

I give my stamp of approval to these drivers.  *STAMP*

Offline

#6 2006-02-19 13:18:16

napoleon
Member
Registered: 2005-04-03
Posts: 176

Re: testing: ATI drivers for xorg7 - packages renamed.

Installed and working great!  big_smile  Good to see its now in testing. Kudos All involved.


A good friend will come and bail you out of jail...BUT a true friend will be sitting next to you saying, "Damn...that was fun!"

Offline

#7 2006-02-19 13:46:59

mmgm
Member
From: Israel
Registered: 2005-05-26
Posts: 52
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

Running fgl_glxgears as a regular user repeatedly spews out

FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
fglX11AllocateManagedSurface: __FGLTexMgrCreateObject failed!!

Everything is great as root. Any suggestions?

Edit: Mplayer now fails when using the xv driver, XImage/Shm works fine.

Offline

#8 2006-02-19 14:27:28

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

mmgm: Do you have the following line in /etc/fstab?

tmpfs     /dev/shm      tmpfs   defaults                 0      0

ATI's drivers require shared memory be mounted as tempfs to work.
Oh, wait, everything's great as root?  Check to see if

/dev/shm/ATISHM00

exists (or something with a very similar name) -- remove it if it's there.  It's likely owned by root.root and when you try to access shared memory as a user you get permission denied.  For some reason the drivers only give this file owner/group rw permissions, and don't even remove the file once the program's done. 

For your second issue, try adding this into your fglrx device section in xorg.conf:

    Option "VideoOverlay"               "on"
    Option "OpenGLOverlay"              "off"

Offline

#9 2006-02-19 14:54:51

mmgm
Member
From: Israel
Registered: 2005-05-26
Posts: 52
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

Both problems were solved. Thanks alot!

Offline

#10 2006-02-19 16:04:55

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: testing: ATI drivers for xorg7 - packages renamed.

I install my base system
Then pacman -S kernel26archck
I reboot then pacman -S ati-drivers xorg
modprobe fglrx works
i add in the rc.conf fglrx

Then i uncomment the testing
then pacman -Syu
modprobe fglrx doesn t work
so pacman -Rd ati-drivers
then pacman -S ati-drivers
modprobe fglrx doesn work

when i have a testing system i can t load fglrx...why ?


Noob

Offline

#11 2006-02-19 16:18:37

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

Vampyrx: when you say a "testing system", does that mean you went ahead with the xorg 7 upgrade too?  In that case, you don't need just the ati-drivers pacakge, you also need to install ati-drivers-archck from [testing]

Offline

#12 2006-02-19 16:36:18

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: testing: ATI drivers for xorg7 - packages renamed.

Try pacman Ss ati-drivers-archck and you will see there isn t this package but there is in community ati-drivers. This is a package create to the kernel26archck so ... i don t know


Noob

Offline

#13 2006-02-19 16:48:08

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

$ pacman -Ss ati-drivers
testing/ati-drivers 8.22.5-3
    ATI precompiled drivers for r350, r300, r250 and r200 chipsets. Userspace tools and libraries
testing/ati-drivers-arch 8.22.5-2
    ATI precompiled drivers for r350, r300, r250 and r200 chipsets. Drivers for the stock Arch Linux kernel.
testing/ati-drivers-archck 8.22.5-2
    ATI precompiled drivers for r350, r300, r250 and r200 chipsets. Drivers for the ArchCK Linux kernel.
community/ati-drivers 8.22.5-1
    ATI precompiled drivers for r350, r300, r250 and r200 chipsets. Built for the kernel26archck pkg in [community]
community/ati-drivers-arch 8.22.5-1
    ATI precompiled drivers for r350, r300, r250 and r200 chipsets. Built for the stock Arch Linux kernel.

You need testing/ati-drivers and testing/ati-drivers-archck -- are you sure your repos are synched? 

pacman -Sy

Offline

#14 2006-02-19 17:31:01

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: testing: ATI drivers for xorg7 - packages renamed.

Yeah but it seems no...so i will try another server


Noob

Offline

#15 2006-02-19 17:54:31

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: testing: ATI drivers for xorg7 - packages renamed.

Ok so this is the belnet.be server whom are not update...


Noob

Offline

#16 2006-02-19 18:49:54

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: testing: ATI drivers for xorg7 - packages renamed.

I have a last error with Xorg7 and ATI drivers : EE failed to load module GLcore loader failed, 7

Someone can help me ?


Noob

Offline

#17 2006-02-19 18:59:38

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

In your xorg.conf, remove the line in the Modules subsection that says "load GLCore"

Offline

#18 2006-02-19 23:19:09

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: testing: ATI drivers for xorg7 - packages renamed.

Vampyrx wrote:

I have a last error with Xorg7 and ATI drivers : EE failed to load module GLcore loader failed, 7

Someone can help me ?

I don't have Load GLcore in my xorg.conf and xorg.log has:

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
    compiled for 7.0.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
    compiled for 7.0.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.2
(II) Loading extension GLX

I have Radeon 9000, chip r250, agp, Xorg 7.0 whith today's update and works very good.

Offline

#19 2006-02-20 05:55:47

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: testing: ATI drivers for xorg7 - packages renamed.

I have a last problem i hope this is the last !
fgl_glxgears doesn't work
Using GLX_SGIX_pbuffer
X Error of failed request: BadMAtch (invalid parameter attributes)
Major opcode of failed request: 144 (GLX)
Minor opcode of failed request : 33
Serial number of failed request: 33
Current serial number un output stream: 33

fglrxinfo :
Display: : 0.0 screen: 0
OpengL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: MESA GLX indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.2)

No erro when i launch Xorg7 with Xfce4


Noob

Offline

#20 2006-02-20 06:18:27

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: testing: ATI drivers for xorg7 - packages renamed.

first post and post install message wrote:

After installing, it is important that you make a symlink from /usr/X11R6/lib/modules to /usr/lib/xorg/modules, othwise direct rendering will not work.

ensure you are also using the mentioned packages from testing, ati-drivers and ati-drivers-arch or ati-drivers-archck

iphitus

Offline

#21 2006-02-20 06:34:43

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: testing: ATI drivers for xorg7 - packages renamed.

Yeah this was the problem : the symlink !!!!
All WORKS NOW !!!!

THANKS A LOT


Noob

Offline

#22 2006-02-20 15:27:04

funkmuscle
Member
Registered: 2006-02-09
Posts: 504

Re: testing: ATI drivers for xorg7 - packages renamed.

Hey,

I've installed the ati drivers for both the arch and archck kernels as I use them for different reasons.
I get this error while booting:
FATAL: Error inserting fglrx (/lib/modules/2.6.15-archck/video/fglrx.ko): No such device

but when I check /lib/modules/2.6.15-archck/video, fglrx.ko is there.
I've added flgrx to rc.conf.

any help here??

Offline

#23 2006-02-20 17:04:06

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: testing: ATI drivers for xorg7 - packages renamed.

funkmuscle: What is your video card?

Offline

#24 2006-02-20 18:02:04

funkmuscle
Member
Registered: 2006-02-09
Posts: 504

Re: testing: ATI drivers for xorg7 - packages renamed.

ati 9600

Offline

#25 2006-02-20 23:54:03

gasparov
Member
Registered: 2006-02-10
Posts: 12

Re: testing: ATI drivers for xorg7 - packages renamed.

Hi
I have direct rendering as root but not as user,it complains about permissions denied

libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.2)
[root@arch gas]# ls -l /usr/lib|grep libGL
-rwxr-xr-x    1 root root  773442 Feb 20 14:30 ati.libGL.so.1.2
lrwxrwxrwx    1 root root      12 Feb 20 23:54 libGL.so -> libGL.so.1.2
lrwxrwxrwx    1 root root      12 Feb 20 23:54 libGL.so.1 -> libGL.so.1.2
-rwxr-xr-x    1 root root  770740 Feb 19 05:43 libGL.so.1.2
lrwxrwxrwx    1 root root      11 Feb 20 13:55 libGLU.so -> libGLU.so.1
lrwxrwxrwx    1 root root      20 Feb 20 13:55 libGLU.so.1 -> libGLU.so.1.3.060402
-rwxr-xr-x    1 root root  565518 Feb 12 20:47 libGLU.so.1.3.060402
lrwxrwxrwx    1 root root      11 Feb 20 13:55 libGLw.so -> libGLw.so.1
lrwxrwxrwx    1 root root      15 Feb 20 13:55 libGLw.so.1 -> libGLw.so.1.0.0
-rwxr-xr-x    1 root root   13823 Feb 12 20:47 libGLw.so.1.0.0
[root@arch gas]# ls -l /usr/X11R6/lib/
total 757
drwxr-xr-x  3 root root     72 Feb 20 13:54 X11
lrwxrwxrwx  1 root root     12 Feb 20 13:56 libGL.so.1 -> libGL.so.1.2
-rwxr-xr-x  1 root root 773442 Feb 20 13:56 libGL.so.1.2
lrwxrwxrwx  1 root root     21 Feb 21 00:26 modules -> /usr/lib/xorg/module

Am I going start games as root? 8)

Offline

Board footer

Powered by FluxBB