You are not logged in.

#1 2014-07-18 21:30:50

MikeDacre
Member
From: San Francisco Bay Area
Registered: 2013-01-18
Posts: 51
Website

[SOLVED] Annoying sudo message on every tty when using yaourt

Hi All,

This is probably very simple but I can't figure out how to solve it.

When I use yaourt to install software and it requests root using sudo I get the following message in every terminal window that is open:

sudo:    dacre : a password is required ; TTY=pts/0 ; PWD=/tmp/yaourt-tmp-dacre/aur-bedtools ; USER=root ; COMMAND=list /usr/bin/pacman --color auto -U /tmp/yaourt-tmp-dacre/PKGDEST.El8/bedtools-2.20.1-1-x86_64.pkg.tar.xz

This is very messy, particularly as it overwrites tmux windows as well. Does anyone know how I can disable this?

Thanks!

Last edited by MikeDacre (2014-09-25 21:44:54)

Offline

#2 2014-07-18 22:38:50

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,843
Website

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

Does this happen in a tty or just in emulators?  If just the latter, what is the output of `echo $TERM`?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2014-07-18 22:59:17

MikeDacre
Member
From: San Francisco Bay Area
Registered: 2013-01-18
Posts: 51
Website

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

It happens in both ttys and emulators.

In my tty $TERM is 'linux'

In my emulators it is either 'xterm-256color' or 'screen-256color', depending on if I am using tmux or not.

Offline

#4 2014-07-18 23:04:46

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,837
Website

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

What's in your yaourt config file (assuming there is one)?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2014-07-18 23:20:46

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,975

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

Moving to AUR Issues, Discussions, and PKGBUILD Requests.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#6 2014-07-21 15:26:32

MikeDacre
Member
From: San Francisco Bay Area
Registered: 2013-01-18
Posts: 51
Website

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

/etc/yaourrc:

#    yaourtrc  - Configuration for yaourt
# 
#   See yaourtrc(5) for more information
#   
#

# General
#AUTOSAVEBACKUPFILE=0
#DEVELSRCDIR=""
#DEVEL=0
#EDITOR="$EDITOR"
#FORCEENGLISH=0
#FORCE=0
#TMPDIR="/tmp"
#NO_TESTDB=0

# SUDO
#SUDONOVERIF=0      # Avoid multiple sudo checks when timestamp_timeout=0
#SUDOREDIRECT=1     # Define to 0 in case you use a fingerprint device

# ABS
#USE_GIT=0
# If the package "abs" is installed, those var are parsed from abs.conf
#REPOS=()           # REPOS available at $SYNCSERVER
#SYNCSERVER=""

# AUR
#AURURL="https://aur.archlinux.org"
#AURCOMMENT=5
#AURDEVELONLY=0
#AURSEARCH=1
#AURUPGRADE=0
#AURVOTE=1

# Build
#EXPORT=0           # Export to 1: EXPORTDIR or PKGDEST
                    # 2: pacman cache (as root)
#EXPORTSRC=0        # Need EXPORT>0 to be used
#EXPORTDIR=""       # If empty, use makepkg's connfiguration (see makepkg.conf)

# Prompt
#NOCONFIRM=0
UP_NOCONFIRM=1     # No prompt while build upgrades (including -Sbu)
BUILD_NOCONFIRM=1  # Only prompt for editing files
PU_NOCONFIRM=1     # Add --noconfirm to $PACMAN -U
#EDITFILES=1
#NOENTER=1

# Output
#USECOLOR=1
#USEPAGER=0
#DETAILUPGRADE=1
#SHOWORPHANS=1
#TERMINALTITLE=1

# Command
#PACMAN="pacman"
#DIFFEDITCMD="vimdiff"

# pacdiffviewer
#P_LOCATE=0         # Use locate instead of find
#P_SEARCHDIR=(/etc/ /boot/)
#P_SAVEDIR='/var/lib/yaourt/backupfiles'

Also, here is my /etc/sudoers file with a fake username:

## sudoers file.
##
## This file MUST be edited with the 'visudo' command as root.
## Failure to use 'visudo' may result in syntax or file permission errors
## that prevent sudo from running.
##
## See the sudoers man page for the details on how to write a sudoers file.
##

##
## Host alias specification
##
## Groups of machines. These may include host names (optionally with wildcards),
## IP addresses, network numbers or netgroups.
# Host_Alias	WEBSERVERS = www1, www2, www3

##
## User alias specification
##
## Groups of users.  These may consist of user names, uids, Unix groups,
## or netgroups.
# User_Alias	ADMINS = millert, dowdy, mikef

##
## Cmnd alias specification
##
## Groups of commands.  Often used to group related commands together.
# Cmnd_Alias	PROCESSES = /usr/bin/nice, /bin/kill, /usr/bin/renice, \
# 			    /usr/bin/pkill, /usr/bin/top

##
## Defaults specification
##
## You may wish to keep some of the following environment variables
## when running commands via sudo.
##
## Locale settings
# Defaults env_keep += "LANG LANGUAGE LINGUAS LC_* _XKB_CHARSET"
##
## Run X applications through sudo; HOME is used to find the
## .Xauthority file.  Note that other programs use HOME to find   
## configuration files and this may lead to privilege escalation!
# Defaults env_keep += "HOME"
##
## X11 resource path settings
# Defaults env_keep += "XAPPLRESDIR XFILESEARCHPATH XUSERFILESEARCHPATH"
##
## Desktop path settings
# Defaults env_keep += "QTDIR KDEDIR"
##
## Allow sudo-run commands to inherit the callers' ConsoleKit session
# Defaults env_keep += "XDG_SESSION_COOKIE"
##
## Uncomment to enable special input methods.  Care should be taken as
## this may allow users to subvert the command being run via sudo.
# Defaults env_keep += "XMODIFIERS GTK_IM_MODULE QT_IM_MODULE QT_IM_SWITCHER"
##
## Uncomment to enable logging of a command's output, except for
## sudoreplay and reboot.  Use sudoreplay to play back logged sessions.
# Defaults log_output
# Defaults!/usr/bin/sudoreplay !log_output
# Defaults!/usr/local/bin/sudoreplay !log_output
# Defaults!/sbin/reboot !log_output

##
## Runas alias specification
##

##
## User privilege specification
##
root ALL=(ALL) ALL
bobthebuilder ALL=(ALL) ALL

## Uncomment to allow members of group wheel to execute any command
# %wheel ALL=(ALL) ALL

## Same thing without a password
# %wheel ALL=(ALL) NOPASSWD: ALL

## Uncomment to allow members of group sudo to execute any command
# %sudo	ALL=(ALL) ALL

## Uncomment to allow any user to run sudo if they know the password
## of the user they are running the command as (root by default).
# Defaults targetpw  # Ask for the password of the target user
# ALL ALL=(ALL) ALL  # WARNING: only use this together with 'Defaults targetpw'

## Read drop-in files from /etc/sudoers.d
## (the '#' here does not indicate a comment)
#includedir /etc/sudoers.d

Offline

#7 2014-07-25 23:04:37

MikeDacre
Member
From: San Francisco Bay Area
Registered: 2013-01-18
Posts: 51
Website

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

I never figured this out, I just uninstalled sudo and am using su -c instead, much less useful, but that message was extremely annoying.

Offline

#8 2014-09-25 20:23:59

noahphense
Member
Registered: 2014-09-25
Posts: 2

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

Hey Mike!

Was in the process of watching an install of Arch when I came across this post.  I was doing a search on %wheel.

Anyhow, I see that your first wheel is still commented.

## Uncomment to allow members of group wheel to execute any command
# %wheel ALL=(ALL) ALL

* Reinstall SUDO
* Uncomment the "first wheel".  Leave the second one alone.
* add your user to the -G (group) wheel.

It should work then.

I've never used Arch, I will be hopefully in a couple hours.  wink   So don't take this next part the wrong way.
Why are adding yourself in the file this way?  Not sure what the up/downside is to hardcoding oneself into the sudoers file.

My understanding is that the user should just be added to the wheel group, then uncomment the "1st" %wheel.
SUDO should work fine after that.

This clip should start right at the sudo install.
Watch the video to where he edits sudoers file.

##
## User privilege specification
##
root ALL=(ALL) ALL
bobthebuilder ALL=(ALL) ALL

## Uncomment to allow members of group wheel to execute any command
# %wheel ALL=(ALL) ALL

## Same thing without a password
# %wheel ALL=(ALL) NOPASSWD: ALL

FIrst post, don't even have Arch installed yet.  Hope I do it the Arch Way.  wink

Cheers!

john

( I think I will remove this post later.  Doesn't feel right. )

Last edited by noahphense (2014-09-25 21:27:15)

Offline

#9 2014-09-25 21:44:14

MikeDacre
Member
From: San Francisco Bay Area
Registered: 2013-01-18
Posts: 51
Website

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

Hi John,

You are right, it does make more sense to just use the wheel group. I have my name hardcoded in just because that is the way I have done it for years.

I can confirm that that fixed the problem. I have no idea why it would make any difference, but that fixed it.

Thanks for your help and welcome to Arch :-)

-Mike

PS. I don't think there is any need to delete your post, I can't see anything wrong with it.

Offline

#10 2014-10-03 15:47:13

noahphense
Member
Registered: 2014-09-25
Posts: 2

Re: [SOLVED] Annoying sudo message on every tty when using yaourt

My pleasure Mike, glad it worked.

Currently back on Debian(#! to be specific).  I did a few installs of Arch sitting on an lvm (a beautiful combo).  By defalt nothing was managing the processor, or if it was, it was not doing a good job.  System would overheat in minutes.  Combo of cpu and gpu, mostly cpu.

I quickly got addicted to pacman. ha

So now, I think I'm going going to analyze what PM setup is sitting here in #!, then make another attempt with Arch, mirroring the PM.

Cheers!

john

Last edited by noahphense (2014-10-03 18:40:12)

Offline

Board footer

Powered by FluxBB