You are not logged in.

#1 2014-07-28 22:49:22

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

[solved] errors were encountered during the build. The image may not b

(the title is cut off, which is a nice pun on the warning message ;P)
Updated my system, got brand new linux 3.15.7-1 and also got

==> WARNING: errors were encountered during the build. The image may not be complete.

when creating the initcpio. I did reboot anyway, seems to work fine.
I'm using [testing] and the new mkinitcpio 18-1.

Is it a bug or a feature? Does anyone else has this issue?

$ sudo mkinitcpio -p linux
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 3.15.7-1-ARCH
  -> Running build hook: [systemd]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [consolefont]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 3.15.7-1-ARCH
  -> Running build hook: [systemd]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: smsmdtv
  -> Running build hook: [filesystems]
  -> Running build hook: [consolefont]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.

BTW, does every new release of the kernel have to go through [testing] repo?

Last edited by karol (2014-08-03 11:05:12)

Offline

#2 2014-07-28 22:57:13

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,012
Website

Re: [solved] errors were encountered during the build. The image may not b

Moving to [testing]...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2014-07-28 23:30:15

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [solved] errors were encountered during the build. The image may not b

I did downgrade linux to 3.15.6-1 and got the same warning. Downgraded mkinitcpio to 17-1 and got no warning on either kernel.

Offline

#4 2014-07-29 00:35:47

anatolik
Developer
Registered: 2012-09-27
Posts: 385

Re: [solved] errors were encountered during the build. The image may not b

I wonder if it is related to the lzo2->lzo rename that is baking in [testing] right now. Could you please run 'pacman -Sy lzo' and then rerun mkinitcpio again?

Offline

#5 2014-07-29 00:58:21

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [solved] errors were encountered during the build. The image may not b

I've already installed lzo 2.08-2 48 hours ago. 'pacman -Sy lzo' simply reinstalled it. I did remove it from cache, downloaded and installed again.
Using both the stock Arch kernel presets and the -ck one results in the warnings with mkinitcpio to 18-1.

Offline

#6 2014-07-29 01:17:56

anatolik
Developer
Registered: 2012-09-27
Posts: 385

Re: [solved] errors were encountered during the build. The image may not b

Ok, it is not lzo problem. Could you please run mkinitcpio with '-v' flag (verbose output) and share it with us?

Offline

#7 2014-07-29 01:33:25

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [solved] errors were encountered during the build. The image may not b

$ sudo mkinitcpio -v -p linux 2&> m.log

The log: http://sprunge.us/MXgd

Offline

#8 2014-07-29 07:13:18

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,838

Re: [solved] errors were encountered during the build. The image may not b

karol wrote:

does every new release of the kernel have to go through [testing] repo?

Yes - this applies to all packages in the core repo. For other repos, it is at the devs' discretion.

Offline

#9 2014-07-29 14:17:01

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [solved] errors were encountered during the build. The image may not b

I didn't see 3.15.7-1 in [testing], it must have been a very short stay.
Anyway, this issue seems to be with mkinitcpio, not with the kernel, although https://bbs.archlinux.org/viewtopic.php … 4#p1441064

Scimmia wrote:

Seems 3.15.7 is a binary module breaker and the modules haven't been rebuilt for it.

Last edited by karol (2014-07-29 14:18:46)

Offline

#10 2014-07-29 14:23:09

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,838

Re: [solved] errors were encountered during the build. The image may not b

Scimmia is referring to out-of-tree modules only e.g. nvidia, virtualbox, etc.

Offline

#11 2014-07-29 14:38:41

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [solved] errors were encountered during the build. The image may not b

They should have been updated too, IMHO.
I'm not using any, but stuff breaking or not shouldn't be based on luck.

Offline

#12 2014-08-03 11:02:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [solved] errors were encountered during the build. The image may not b

Now using lzo 2.08-3 and the warnings are gone.
Marking as solved.

Offline

Board footer

Powered by FluxBB