You are not logged in.

#1 2006-02-21 08:50:40

fdrebin
Member
Registered: 2005-04-25
Posts: 152

xorg 7.0 updated successfully but kde (kdm) won't start

i updated to xorg 7.0 following the wiki but, having kdm in my modules listed, kdm/kde won't start now...

Offline

#2 2006-02-21 09:49:46

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 797

Re: xorg 7.0 updated successfully but kde (kdm) won't start

Searching the forums for "kdm", there are around six threads since 20th February. Which solutions from these threads have you tried so far?

Online

#3 2006-02-21 17:22:22

fdrebin
Member
Registered: 2005-04-25
Posts: 152

Re: xorg 7.0 updated successfully but kde (kdm) won't start

i already updatet kde to .1 but still doesn't work.
i noticed that the command startx isn't there anymore but now there is startkde and this give me something like "cannot connect to x server"...

Offline

#4 2006-02-21 17:38:35

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 797

Re: xorg 7.0 updated successfully but kde (kdm) won't start

startx should be in /usr/bin, installed by the xorg-xinit package

Online

#5 2006-02-21 17:56:10

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: xorg 7.0 updated successfully but kde (kdm) won't start

fdrebin wrote:

i noticed that the command startx isn't there anymore

That means you need to logout and in again, the paths to startx changed. If you still have trouble running kdm, put exec startkde in ~.xinitrc and note the error messages. I had to do Xorg -configure and make some minor adjustments to the config file it spit back to get kde to work again.

Offline

#6 2006-02-21 18:51:59

fdrebin
Member
Registered: 2005-04-25
Posts: 152

Re: xorg 7.0 updated successfully but kde (kdm) won't start

- a locate startx couldn't find the command
- when running kdeinit i get "$DISLPAY is not set"
- entry in xinitrc doesn't change anything

Offline

#7 2006-02-21 18:55:45

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: xorg 7.0 updated successfully but kde (kdm) won't start

fdrebin wrote:

- a locate startx couldn't find the command

Did you ran updatedb before using locate? Is xorg-xinit installed? If not, install it.

fdrebin wrote:

- entry in xinitrc doesn't change anything

Did you ran startx after modifying ~/.xinitrc?

Offline

#8 2006-02-21 19:30:28

fdrebin
Member
Registered: 2005-04-25
Posts: 152

Re: xorg 7.0 updated successfully but kde (kdm) won't start

xorg-xinit was not installed ! WTF ?
when starting now startx i get something like
"failed to load module "nvidia" ...
no drivers available"
when i did "pacman -S nvidia" there were conflicts with some other package!

Offline

#9 2006-02-21 20:58:49

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: xorg 7.0 updated successfully but kde (kdm) won't start

If the conflict is with libgl-dri, you can remove libgl-dri. Both the nvidia binary drivers and the libgl-dri package provides libgl.

Offline

#10 2006-02-22 08:26:34

fdrebin
Member
Registered: 2005-04-25
Posts: 152

Re: xorg 7.0 updated successfully but kde (kdm) won't start

did this with "pacman -Sf nvidia".
it still didn't work so i installed xf86-input-keyboard/mouse ( is xf86 and xorg the same now? ) it still wouldn't work but after reboot it worked.
but for some reason i got no sound...

Offline

Board footer

Powered by FluxBB