You are not logged in.

#1 2014-08-05 20:28:11

Soukyuu
Member
Registered: 2014-04-08
Posts: 845

[tigervnc] clipboard operations turn unicode text into question marks

I'm using tigervnc as server on arch and ultravnc as client on windows. When copying a Japanese string between the server and a client, the clipboard contents are not copied as unicode but ansi with a wrong codepage.
For example, copying "テスト" results in "???". It doesn't matter which way the copy&past operation goes.

The server is configured to be able to display Japanese fonts, so it's not a font problem. I can also copy&paste between the applications running in the vnc session, it only breaks when I try to transfer text between the server and client...
UltraVNC apparently supports unicode (scroll down to the notes section), and I don't see why tigervnc should be unable to do it as well. Am I missing some configuration option? Not sure what info to provide.

Last edited by Soukyuu (2014-08-05 20:28:27)


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#2 2014-08-05 22:01:19

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: [tigervnc] clipboard operations turn unicode text into question marks

I just tried with both client and server on linux. Copying in one direction I too get "???", copying in the other direction I get "\u30c6\u30b9\u30c8".

I don't think this is Arch specific, so I'd say open a bug on the upstream issue tracker: https://github.com/TigerVNC/tigervnc/issues

Offline

#3 2014-08-05 23:06:03

Soukyuu
Member
Registered: 2014-04-08
Posts: 845

Re: [tigervnc] clipboard operations turn unicode text into question marks

Ok, I created a new issue here, let's wait and see...


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#4 2014-08-18 12:41:11

Soukyuu
Member
Registered: 2014-04-08
Posts: 845

Re: [tigervnc] clipboard operations turn unicode text into question marks

An update: I just got a reply that it's a limitation of the VNC clipboard protocol, and while ultraVNC has extended it, the extensions are not documented, so they couldn't be ported to tigerVNC yet.
I guess VNC is really ancient. Also kind of surprised, since I assumed everything on linux is inherently unicode-capable...


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

Board footer

Powered by FluxBB