You are not logged in.

#1 2004-02-13 11:41:47

dauphin
Member
From: Scotland
Registered: 2003-07-09
Posts: 188

Retaining Alsa settings (groan!)

I know it's a hoary old problem, but I cannot resolve it after trying the various suggestions in this forum.
I tried a script in /etc/rc.d, I tried doing it with /etc/devfsd.conf, I even tried configuring /etc/asound.state and then setting it read-only (my own not-so-bright idea), but so far nothing has worked.

Upon investigation, I find that even logging out of my user account in KDE and logging back in again as the same user is enough to zero my settings again.  So it is not surprising that any solution which operates at system startup/shutdown does not deal with the problem in my case.

Can anyone explain why logging out of my user account and back in again loses my alsa settings (happens whether KDE sound system is enabled or not)?

The other thing which may have a bearing on this is that although alsa is working, alsaconfig reports  "No supported PnP or PCI card found".  And kmix gives:

kmix: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.

I had snd-mixer-oss as a module in /etc/rc.conf, but it gave an error message that it was already loaded (and lsmod confirms) so I removed it from /etc/rc.conf.  Either way, it made no difference to the running of kmix, alsaconf or to saving my alsa settings.

I am using the 2.6.2 kernel and snd-mixer-oss is compiled as a module.  The sound card is an onboard CM8738.

Any ideas please?

Offline

#2 2004-02-13 11:52:46

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: Retaining Alsa settings (groan!)

Yes....

Emmmm.. first store alsa settings if using..by alsactl store then

in /etc/rc.local

stick a line

alsactl restore

As for KDE sounds I still have problems with systems notifications....As yet to hear start.wav :-)

Mr Green


Mr Green

Offline

#3 2004-02-13 12:06:07

dauphin
Member
From: Scotland
Registered: 2003-07-09
Posts: 188

Re: Retaining Alsa settings (groan!)

Thanks, but that's another one I've tried without success.  (That file is only going to be called at system startup, and my settings  - carefully saved with "alsactl store" - are cancelled the moment I log out of my KDE account.)

I have no problem with the KDE sounds themselves, in fact I'm sick of hearing them so they are all turned off except for email notification!

Offline

#4 2004-02-13 12:21:21

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: Retaining Alsa settings (groan!)

Take a look here ....

http://bbs.archlinux.org/viewtopic.php?t=2512

I have onboard sound too & it was & still is a pain  :cry:

I logged out & in again & settings were still there ....what have got in sound system ie ALSA autodetect OSS etc....

Mr Green


Mr Green

Offline

#5 2004-02-13 12:33:20

torindan
Member
From: Romania
Registered: 2004-01-13
Posts: 32

Re: Retaining Alsa settings (groan!)

I have same soundcard and kernel

$ uname -a
Linux torindan 2.6.2 #1 SMP Wed Feb 4 01:41:24 PST 2004 i686 unknown unknown GNU/Linux
$ grep audio /proc/pci
    Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 16).

Try following settings :

$ grep snd /etc/rc.conf
MODULES=(snd-cmipci snd-pcm-oss snd-seq-oss)
$ tail -2 /etc/devfsd.conf 
REGISTER        ^sound/.*       PERMISSIONS     root.sound 0660
REGISTER        ^snd/.*         PERMISSIONS     root.sound 0660

I think that first line is for 2.4.24 kernel...(old cmpci module)

with these settings ALSA loads a lot of modules :

$ lsmod | grep snd             
snd_seq_midi            6432  0 
snd_opl3_synth         14148  0 
snd_seq_instr           8384  1 snd_opl3_synth
snd_seq_midi_emul       6784  1 snd_opl3_synth
snd_ainstr_fm           2176  1 snd_opl3_synth
snd_seq_oss            33120  0 
snd_seq_midi_event      6176  2 snd_seq_midi,snd_seq_oss
snd_seq                54736  8 snd_seq_midi,snd_opl3_synth,snd_seq_instr,snd_seq_midi_emul,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            49348  1 
snd_mixer_oss          16768  1 snd_pcm_oss
snd_cmipci             32696  1 
snd_pcm                90784  2 snd_pcm_oss,snd_cmipci
snd_page_alloc          8996  1 snd_pcm
snd_opl3_lib            9056  2 snd_opl3_synth,snd_cmipci
snd_timer              22180  3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep               7168  1 snd_opl3_lib
snd_mpu401_uart         6272  1 snd_cmipci
snd_rawmidi            20512  2 snd_seq_midi,snd_mpu401_uart
snd_seq_device          6280  6 snd_seq_midi,snd_opl3_synth,snd_seq_oss,snd_seq,snd_opl3_lib,snd_rawmidi
snd                    45732  16 snd_seq_midi,snd_opl3_synth,snd_seq_instr,snd_seq_oss,snd_seq_midi_event,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_cmipci,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7584  2 snd

I have no idea if it should be so many stuff loaded, but at least it works smile

I use XFCE4 and I have no idea about sound in KDE, so probably my post will not help you, but who knows?

Offline

#6 2004-02-13 12:55:19

dauphin
Member
From: Scotland
Registered: 2003-07-09
Posts: 188

Re: Retaining Alsa settings (groan!)

Mr Green:  have checked through that other thread again but nothing there I haven't done!  Re. my KDE sound system, I usually have it disabled (the sounds still work though) but if I do enable it I set it to ALSA.

Torindan: Everything checks out as identical to yours, including all the modules.  As I say, ALSA works fine and I would ignore the kmix and alsaconf errors except I thought they might be a clue to why my settings don't get saved!
Another strange thing is that I have a test installation of SourceMage elsewhere on my box and after installing alsa there it detected and configured my CM8738 in a couple of seconds.  I never even had to tweak the settings, let alone worry about how to save them!

Offline

#7 2004-02-13 13:01:54

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: Retaining Alsa settings (groan!)

Well all I can say is that after loading 2.6.2 kernel I ran alsaconf...it detected my onboard sound set up modprobe.conf...used alsamixer to set volume levels away it went..

There are more ways to set up alsa than linux distros  lol

Which KDE are you using (version) ?

What you got in devfsd.conf (last lines)

Mr Green


Mr Green

Offline

#8 2004-02-13 13:10:46

dauphin
Member
From: Scotland
Registered: 2003-07-09
Posts: 188

Re: Retaining Alsa settings (groan!)

KDE 3.2

last part of devfsd.conf:

REGISTER sound/.* PERMISSIONS root.audio 660
REGISTER snd/.*  PERMISSIONS root.audio 660

 
# Load ALSA sound when needed
LOOKUP snd MODLOAD
LOOKUP dsp MODLOAD
LOOKUP mixer MODLOAD
LOOKUP sequencer MODLOAD

Offline

#9 2004-02-13 13:17:38

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: Retaining Alsa settings (groan!)

So you have audio group set up (I know it sounds silly but ....)

My devfsd.conf

REGISTER sound/.* PERMISSIONS root.users 660
REGISTER snd/.* PERMISSIONS root.users 660

Mr Green


Mr Green

Offline

#10 2004-02-13 13:27:02

dauphin
Member
From: Scotland
Registered: 2003-07-09
Posts: 188

Re: Retaining Alsa settings (groan!)

Yes I have audio group (and am a member of it!)
I used to have the same as you - there was little point in changing it really, but you know that clutching at straws feeling....!  Of course, it made no difference but there was even less point in changing back.

Offline

Board footer

Powered by FluxBB