You are not logged in.

#1 2014-08-23 23:39:07

Magbed
Member
Registered: 2013-06-02
Posts: 25

Primusrun crashes the system on exit

Hi there im using bumblebee on my laptop for the optimus support.

When i run any graphical application through bumblcee it crashes the whole system when i exit it.

for example:

$primusrun glxgears

It works and diplays it, but when i press ESC to exit, it freezes, crashes the system.

These are the logs from the crash.

Thnx for the help


ago 24 01:17:59 Archpire bumblebeed[228]: [  794.744022] [ERROR][XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: P
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.744013] [ERROR][XORG] (EE) Failed to load module "mouse" (module does not exist, 0)
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.744001] [WARN][XORG] (WW) Warning, couldn't open module mouse
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743990] [WARN][XORG] (WW) NVIDIA(0): Unable to get display device for DPI computation
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743978] [WARN][XORG] (WW) Unresolved symbol: fbGetGCPrivateKey
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743968] [ERROR][XORG] (EE) Failed to load module "mouse" (module does not exist, 0)
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743962] [WARN][XORG] (WW) Warning, couldn't open module mouse
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743954] [WARN][XORG] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or d
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743949] [ERROR][XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: P
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743943] [ERROR][XORG] (EE) systemd-logind: failed to get session: PID 4783 does not b
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743925] [WARN][XORG] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/7
ago 24 01:17:59 Archpire bumblebeed[228]: [  794.743897] [WARN][XORG] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/1
ago 24 01:17:58 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [P
ago 24 01:17:54 Archpire kernel: nvidia 0000:01:00.0: irq 50 for MSI/MSI-X
ago 24 01:17:54 Archpire kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  340.32  Tue Aug  5 20:58:26 PDT 2014
ago 24 01:17:54 Archpire kernel: [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
ago 24 01:17:54 Archpire slim[257]: xf86: found device 1
ago 24 01:17:54 Archpire slim[257]: removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1 /dev/dri/card1
ago 24 01:17:54 Archpire kernel: vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
ago 24 01:17:53 Archpire kernel: bbswitch: enabling discrete graphics

Offline

#2 2014-08-26 17:42:33

nach222hcan
Member
Registered: 2014-08-26
Posts: 1

Re: Primusrun crashes the system on exit

Hi!! take a look and see if you have this version of packets:

intel-dri-10.2.6-1-x86_64.pkg.tar.xz
lib32-intel-dri-10.2.6-1-x86_64.pkg.tar.xz
lib32-mesa-10.2.6-1-x86_64.pkg.tar.xz
lib32-mesa-libgl-10.2.6-1-x86_64.pkg.tar.xz
mesa-10.2.6-1-x86_64.pkg.tar.xz
mesa-libgl-10.2.6-1-x86_64.pkg.tar.xz

I had the same issue since they were updated.

Now I have downloaded to version 10.2.5-1 and solved the problem.

Let me know

Sorry about my english...

Offline

Board footer

Powered by FluxBB