You are not logged in.

#1 2005-12-21 11:05:09

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

hwd -x with modular xorg

wtf:

[root@myhost X11]# hwd -x
No Xserver installed!!

Not that I need this tool, but do more people experience this?

Offline

#2 2005-12-21 11:13:07

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: hwd -x with modular xorg

Given the directory change from 6.8 to 7, I think this is kind of a given... But yeah, I hope a new version hits Testing.

Offline

#3 2005-12-21 11:16:01

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: hwd -x with modular xorg

thought so already.
what about this, any idea?

[pressh@myhost ~]$ fvwm -r
Cannot parse color "black"
Cannot parse color "black"
Cannot parse color "gray"
Cannot parse color "black"
Cannot parse color "black"
Cannot parse color "black"
Cannot parse color "black"
Cannot parse color "grey"
Cannot parse color "gray"
Cannot parse color "black"
Cannot parse color "black"
Cannot parse color "grey"
Cannot parse color "slategrey"

but hey, this update is not all bad wink, my cups server just started to work again big_smile....somehow

Offline

#4 2005-12-21 12:29:12

basilburn
Member
Registered: 2005-12-09
Posts: 35

Re: hwd -x with modular xorg

Check the path to rgb.txt in xorg.conf. I had a similar problem with xterm.

Offline

#5 2005-12-21 12:55:24

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: hwd -x with modular xorg

thanks, that did the trick

Offline

#6 2005-12-21 20:05:53

mattux
Member
Registered: 2004-04-22
Posts: 81

Re: hwd -x with modular xorg

you can also edit the Fontpath line in Files section like this:
FontPath "/usr/share/fonts"


mattux

Offline

#7 2005-12-22 11:24:06

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: hwd -x with modular xorg

It's time to upgrade hwd. smile

Offline

#8 2005-12-26 03:30:59

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: hwd -x with modular xorg

For my information, what's name of the X config in modular xorg?

Currently hwd recognizes the following configs:
/etc/X11/xorg.conf
/etc/X11/ XF86Config-4

Offline

#9 2005-12-26 09:36:49

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: hwd -x with modular xorg

Still xorg.conf.

Offline

#10 2005-12-26 10:44:13

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: hwd -x with modular xorg

If still xorg.conf, then "hwd -x" will not say: "No Xserver installed!!"

pressh, do you have /etc/X11/xorg.conf

Offline

#11 2005-12-26 11:12:35

stavrosg
Member
From: Rhodes, Greece
Registered: 2005-05-01
Posts: 330
Website

Re: hwd -x with modular xorg

The file have now moved to /usr . e.g. the X server is now /usr/bin/X instead of the other. Maybe hwd looks in the wrong place?

Offline

#12 2005-12-26 11:12:41

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: hwd -x with modular xorg

Trust me, it's still xorg.conf. Use xorgconfig and see where the output goes.

Offline

#13 2005-12-26 11:33:53

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: hwd -x with modular xorg

Hwd is pointed to /etc/X11/

Offline

#14 2005-12-26 12:07:08

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: hwd -x with modular xorg

rasat:

Xsample() {
[ -f /usr/X11R6/bin/xorgcfg ] && X_SERVER="Xorg"
[ -f /usr/X11R6/bin/xorgcfg ] && X_CONFIG="xorg.conf"
[ -f /usr/X11R6/bin/xf86cfg ] && X_SERVER="XFree86"
[ -f /usr/X11R6/bin/xf86cfg ] && X_CONFIG="XF86Config-4"

its no longer /usr/X11R6/bin/whatver but /usr/bin/whatever. Try changing that.
It starts at line 48 in mkxcfg.

Offline

#15 2005-12-26 12:44:09

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Re: hwd -x with modular xorg

rasat wrote:

If still xorg.conf, then "hwd -x" will not say: "No Xserver installed!!"

pressh, do you have /etc/X11/xorg.conf

but it does.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#16 2005-12-26 14:20:59

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: hwd -x with modular xorg

I don't have the modular xorg installed, for testing purpose add the below lines in /usr/bin/mkxcfg after line 52 ([ -f /usr/X11R6/bin/xf86cfg ] && X_CONFIG="XF86Config-4"). Then run "hwd -x". Let me know if it works.

[ -f /usr/bin/xorgcfg ] && X_SERVER="Xorg"
[ -f /usr/bin/xorgcfg ] && X_CONFIG="xorg.conf"

Offline

#17 2006-02-21 08:08:26

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: hwd -x with modular xorg

Hwd-4.8 is now working with xorg 7.x. Detects the driver and does the X configure.

Example:
Video      : NVIDIA Corp.|NV18.6? GeForce4 MX 4000 server: Xorg (nv)
Driver     : xf86-video-nv

Offline

#18 2006-02-23 15:53:34

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: hwd -x with modular xorg

When will it hit the repos?

Offline

#19 2006-02-23 16:21:37

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: hwd -x with modular xorg

Already sent to the package maintainer. In repo at any time.

Offline

#20 2006-02-23 19:27:39

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,838

Re: hwd -x with modular xorg

I grabbed 4.8 off your site, rasat, after trashing xorg.conf on my second box here. It's great with xorg7. Just two small things I noticed - in the keyboard section, it still put in

Option      "XkbRules" "xfree86"

instead of

Option      "XkbRules" "xorg"

and it included GLcore in the Modules section, which is no longer necessary, and causes an error. Otherwise perfect, and of course, those are very quick to fix anyway.

Thanks. big_smile

Offline

#21 2006-02-23 20:08:00

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: hwd -x with modular xorg

tomk wrote:
Option      "XkbRules" "xfree86"

instead of

Option      "XkbRules" "xorg"

No... xorg rules are correct.


·¬»· i am shadowhand, powered by webfaction

Offline

#22 2006-02-23 20:19:45

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,838

Re: hwd -x with modular xorg

Umm..yeah - that's what I said. hwd -x generated "xfree86", instead of "xorg".

Offline

#23 2006-02-24 16:34:40

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Re: hwd -x with modular xorg

but that doesn't matter.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#24 2006-02-24 17:09:48

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,838

Re: hwd -x with modular xorg

Well, it mattered for me - I couldn't do Ctrl+Alt+Fn, or use my Windows keys, until I changed "xfree86" to "xorg". Plenty of others around here had the same problem, and the same fix. If it doesn't matter for you, that's great - one less thing for you to worry about.

Offline

Board footer

Powered by FluxBB