You are not logged in.

#1 2014-09-09 13:54:44

Ege
Member
Registered: 2014-07-24
Posts: 11

[SOLVED]Wrong Time

I am having issues about correcting time on my system. It always shows -3 hour lower than my time. (Europe/Istanbul)

timedatectl status                     
      Local time: Sal 2014-09-09 13:49:30 UTC
  Universal time: Sal 2014-09-09 13:49:30 UTC
        RTC time: Sal 2014-09-09 16:48:02
       Time zone: Europe/Istanbul (UTC, +0000)
     NTP enabled: no
NTP synchronized: no
 RTC in local TZ: no
      DST active: n/a

As you can see it shows Europe/Istanbul timezone as UTC +0 however it is UTC +3. That's why I can't fix my time using ntp nor changing time via settings. But my hardware clock seems to be true.

sudo LC_ALL=C hwclock --debug
hwclock from util-linux 2.25
Using the /dev interface to the clock.
Last drift adjustment done at 1410281024 seconds after 1969
Last calibration done at 1410281024 seconds after 1969
Hardware clock is on UTC time
Assuming hardware clock is kept in UTC time.
Waiting for clock tick...
...got clock tick
Time read from Hardware Clock: 2014/09/09 16:49:53
Hw clock time : 2014/09/09 16:49:53 = 1410281393 seconds since 1969
Tue Sep  9 16:49:53 2014  -0.734921 seconds

How can I fix that? Thanks.

Last edited by Ege (2014-09-09 18:13:47)

Offline

#2 2014-09-09 15:50:04

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 20,008

Re: [SOLVED]Wrong Time

Odd, it works on my system:

ewaller$@$odin ~ 1005 %timedatectl set-timezone Europe/Istanbul
==== AUTHENTICATING FOR org.freedesktop.timedate1.set-timezone ===
Authentication is required to set the system timezone.
Authenticating as:<Redacted>
Password:
==== AUTHENTICATION COMPLETE ===
ewaller$@$odin ~ 1006 %timedatectl
      Local time: Tue 2014-09-09 18:42:10 EEST
  Universal time: Tue 2014-09-09 15:42:10 UTC
        RTC time: Tue 2014-09-09 15:42:02
       Time zone: Europe/Istanbul (EEST, +0300)
     NTP enabled: no
NTP synchronized: no
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  Mon 2014-03-31 02:59:59 EET
                  Mon 2014-03-31 04:00:00 EEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  Sun 2014-10-26 03:59:59 EEST
                  Sun 2014-10-26 03:00:00 EET
ewaller$@$odin ~ 1007 %timedatectl set-timezone US/Pacific
==== AUTHENTICATING FOR org.freedesktop.timedate1.set-timezone ===
Authentication is required to set the system timezone.
Authenticating as: <Redacted>
Password:

==== AUTHENTICATION COMPLETE ===
ewaller$@$odin ~ 1008 %timedatectl
      Local time: Tue 2014-09-09 08:42:59 PDT
  Universal time: Tue 2014-09-09 15:42:59 UTC
        RTC time: Tue 2014-09-09 15:42:51
       Time zone: US/Pacific (PDT, -0700)
     NTP enabled: no
NTP synchronized: no
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  Sun 2014-03-09 01:59:59 PST
                  Sun 2014-03-09 03:00:00 PDT
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  Sun 2014-11-02 01:59:59 PDT
                  Sun 2014-11-02 01:00:00 PST
ewaller$@$odin ~ 1009 %md5sum /usr/share/zoneinfo/Europe/Istanbul
56c26bbc53d7d8dc661da4ccfc1d78bf  /usr/share/zoneinfo/Europe/Istanbul
ewaller$@$odin ~ [1]1011 %pacman -Qo /usr/share/zoneinfo/Europe/Istanbul
/usr/share/zoneinfo/Europe/Istanbul is owned by tzdata 2014f-1
ewaller$@$odin ~ 1012 %

Please verify your revision of the  tzdata package and the MD5 hash of  /usr/share/zoneinfo/Europe/Istanbul (should be  56c26bbc53d7d8dc661da4ccfc1d78bf )

Edit: Also, please post the output of uname -a

Last edited by ewaller (2014-09-09 16:26:30)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2014-09-09 17:09:10

Ege
Member
Registered: 2014-07-24
Posts: 11

Re: [SOLVED]Wrong Time

Thanks for your answer
md5sum check says mine is wrong.

$: sudo LC_ALL=C pacman -Qo /usr/share/zoneinfo/Europe/Istanbul
/usr/share/zoneinfo/Europe/Istanbul is owned by tzdata 2014f-1

$: md5sum /usr/share/zoneinfo/Europe/Istanbul
c79354b8dbee09e62bbc3fb544853283  /usr/share/zoneinfo/Europe/Istanbul

$: uname -a
Linux quaoar 3.16.1-1-ARCH #1 SMP PREEMPT Thu Aug 14 07:40:19 CEST 2014 x86_64 GNU/Linux

Offline

#4 2014-09-09 17:26:28

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 20,008

Re: [SOLVED]Wrong Time

Interesting, I see that tzdata was just updated today.  Try a pacman -Syu and let's see what happens.
https://www.archlinux.org/packages/core/any/tzdata/
I am updating my system and will get the new MD5 hash in a few moments

edit

ewaller$@$odin ~ 1018 %md5sum /usr/share/zoneinfo/Europe/Istanbul
56c26bbc53d7d8dc661da4ccfc1d78bf  /usr/share/zoneinfo/Europe/Istanbul
ewaller$@$odin ~ 1019 %

Looks like it did not change with this update.

Last edited by ewaller (2014-09-09 17:39:28)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#5 2014-09-09 18:13:31

Ege
Member
Registered: 2014-07-24
Posts: 11

Re: [SOLVED]Wrong Time

Everything works fine after the upgrade. Thank you.

Offline

Board footer

Powered by FluxBB