You are not logged in.

#1 2014-10-10 23:30:37

barefly
Member
Registered: 2014-08-16
Posts: 50

[SOLVED] Unable to mount USB, not showing up in lsblk

When I run lsblk -f to mount the device it is not showing up.

sda                                                      
├─sda1 ext4         61025ca3-7e81-4045-b4c5-1d021bfac5c8 /
├─sda2 ext4         c390cfbd-ba5b-4cb4-be6d-2338754ab465 /home
└─sda3 swap         54325b79-165e-4f7b-835e-f270b8de64e7 [SWAP]
sdb                                                      
├─sdb1 ext4         2c225928-f839-465d-a16e-ffd0eac68abb 
├─sdb2 ext4         71f1c3c1-8f59-463c-87b3-a97dc11eaf55 
├─sdb3 ntfs         1942538067BE10B7                     
└─sdb4 swap         c4ec35ac-dd65-470a-b9e0-d035ef8edd03 
sr0

Although when I check journalctl and dmesg I do find that it has been detected.

Oct 10 17:11:04 lordran kernel: usb 10-3: new high-speed USB device number 4 using ehci-pci
Oct 10 17:11:12 lordran kernel: usb 10-3: USB disconnect, device number 4
Oct 10 17:11:13 lordran kernel: usb 10-4: new high-speed USB device number 5 using ehci-pci
[ 5933.143128] usb 10-3: new high-speed USB device number 4 using ehci-pci
[ 5940.865773] usb 10-3: USB disconnect, device number 4
[ 5942.482695] usb 10-4: new high-speed USB device number 5 using ehci-pci

Im not sure what the issue is. I have tried the usb on several usb ports and it still continues to do the same. The usb also works on other computers, and I have tested a different usb as well to see if maybe there was a problem with the one I need to mount, but it is having the same issue as well. Any help would be appreciated.

Last edited by barefly (2014-10-11 00:31:22)

Offline

#2 2014-10-10 23:32:13

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,061

Re: [SOLVED] Unable to mount USB, not showing up in lsblk

It showed that a device was (dis)connected, but it doesn't acknowledge what class the device is.  What does lsusb show?


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#3 2014-10-10 23:36:13

barefly
Member
Registered: 2014-08-16
Posts: 50

Re: [SOLVED] Unable to mount USB, not showing up in lsblk

nomorewindows wrote:

It showed that a device was (dis)connected, but it doesn't acknowledge what class the device is.  What does lsusb show?

Bus 010 Device 006: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
Bus 010 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I went ahead and disconnected and reconnected the usb. The last line dmesg gives me is...

 7261.147678] usb 10-4: new high-speed USB device number 6 using ehci-pci

Last edited by barefly (2014-10-10 23:37:27)

Offline

#4 2014-10-10 23:46:45

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,061

Re: [SOLVED] Unable to mount USB, not showing up in lsblk

Didn't see the hub.  May try to skip the hub to see if does something different.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#5 2014-10-10 23:49:47

barefly
Member
Registered: 2014-08-16
Posts: 50

Re: [SOLVED] Unable to mount USB, not showing up in lsblk

nomorewindows wrote:

Didn't see the hub.  May try to skip the hub to see if does something different.

Thing is I don't have a usb hub. It's connecting directly the back of my pc. So im not sure why it thinks it's a hub as I dont have one connected.

Offline

#6 2014-10-10 23:52:13

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,061

Re: [SOLVED] Unable to mount USB, not showing up in lsblk

It is a root hub that any and all usb devices and other usb hubs connect into.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#7 2014-10-11 00:01:59

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,837

Re: [SOLVED] Unable to mount USB, not showing up in lsblk

Did you get a kernel update recently (during a "pacman -Syu")? Did you reboot after the kernel update?

Offline

#8 2014-10-11 00:08:53

barefly
Member
Registered: 2014-08-16
Posts: 50

Re: [SOLVED] Unable to mount USB, not showing up in lsblk

2ManyDogs wrote:

Did you get a kernel update recently (during a "pacman -Syu")? Did you reboot after the kernel update?

I did just do an upgrade less than an hour ago. I'll reboot and hopefully that'll fix everything.

EDIT: Yup that was it. Damn I feel dumb.

Last edited by barefly (2014-10-11 00:31:50)

Offline

Board footer

Powered by FluxBB