You are not logged in.

#1 2014-10-21 14:51:07

emacsomancer
Member
Registered: 2014-09-20
Posts: 198

[Solved] can't enter package management in latest version of Emacs

When I try to do something like 'package-install' or 'list-packages' in the latest version of Emacs, it refuses, complaining:

Lisp error: (void-function package-desc-vers)
  package-desc-vers([(0 0 1) nil "Matrix themed Zone mode" tar])
  ad-Advice-package--add-to-archive-contents(#[514 "@A\303H\304\305A\306HA\307H	A\310H	\311\fAG\312V\205*

Last edited by emacsomancer (2014-12-15 15:21:51)

Offline

#2 2014-10-23 22:47:47

archuser2
Member
Registered: 2014-01-16
Posts: 1

Re: [Solved] can't enter package management in latest version of Emacs

Do you have an older version of melpa in your load-path (e.g. .emacs.d/elpa/melpa-x.x) over-riding the built-in package management in later versions of emacs?

If so, delete the melpa-x.x directory and restart emacs.

Offline

Board footer

Powered by FluxBB