You are not logged in.

#1 2006-03-04 15:09:21

Arkamririon
Member
From: Germany
Registered: 2005-12-27
Posts: 34

Xorg7 Update: Permission denied to open VC?

I waited a long time, but today i tried updating to Xorg7, but it doesnt work.

When i start gdm i get this output in Xorg.0.log

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.15-ARCH i686
Current Operating System: Linux sorcbook 2.6.15-archck #1 SMP PREEMPT Tue Feb 14 19:49:58 EST 2006 i686
Build Date: 04 March 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar  4 15:55:57 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) FontPath set to "/usr/share/fonts/misc,/usr/share/fonts/75dpi,/usr/share/fonts/100dpi,/usr/share/fonts/TTF,/usr/share/fonts/Type1"
(**) RgbPath set to "/usr/share/X11/rgb"
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) xf86ReadBIOS: Failed to open /dev/mem (Permission denied)
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.2
        X.Org Video Driver: 0.8
        X.Org XInput driver : 0.5
        X.Org Server Extension : 0.2
        X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.8
(++) using VT number 7


Fatal server error:
xf86OpenConsole: Cannot open virtual console 7 (Permission denied)

(WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
(WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor

startx behaves in the same way

...
Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 (Permission denied)
...


Maybe this Warning has something to do with the problem :"(WW) xf86ReadBIOS: Failed to open /dev/mem (Permission denied)"?
But I have no idea how to solve this problem.

Offline

#2 2006-03-04 15:23:42

Xarturkhann
Member
From: Ankara
Registered: 2006-02-17
Posts: 55

Re: Xorg7 Update: Permission denied to open VC?

Same problem here!!!

Offline

#3 2006-03-04 15:25:22

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: Xorg7 Update: Permission denied to open VC?

Xarturkhann wrote:

Same problem here!!!

KDE (xserver) doesn't works anymore after update. There are no options for downgrade...

Offline

#4 2006-03-04 15:27:36

_Gandalf_
Member
Registered: 2006-01-12
Posts: 735

Re: Xorg7 Update: Permission denied to open VC?

First you haven't changed your RGB path, please follow http://wiki.archlinux.org/index.php/Xor … uration.29 carefully
and please include your xorg.conf

Offline

#5 2006-03-04 15:35:34

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Xorg7 Update: Permission denied to open VC?

Hmm, this is caused by forgetting fakeroot when packaging the latest Xorg package. The files are owned by uid 1000 and are setuid 1000 because of this. Xorg-server-1.0.1-6.pkg.tar.gz coming right up now.

Offline

#6 2006-03-04 15:35:57

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: Xorg7 Update: Permission denied to open VC?

_Gandalf_ wrote:

First you haven't changed your RGB path, please follow http://wiki.archlinux.org/index.php/Xor … uration.29 carefully
and please include your xorg.conf

My Xorg 7.0 did works good but after todays update stop working:

I get and error:

Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 Permission dennied
XIO: fatal IO error 104 (Connection reset by peer) on X server :0:0" after 0 request (0 known processed) with 0 events remaining.

Once again I used Xorg 7.0 about two weeks and I have all paths correct and before todays update works.

Offline

#7 2006-03-04 15:40:35

_Gandalf_
Member
Registered: 2006-01-12
Posts: 735

Re: Xorg7 Update: Permission denied to open VC?

look at JGC comment above... it will be fixed soon...

Offline

#8 2006-03-04 16:51:43

Bralkein
Member
Registered: 2004-10-26
Posts: 354

Re: Xorg7 Update: Permission denied to open VC?

Yeah, the new package is out and the problem is fixed. Man, it was a pain finding this thread with links...

Offline

#9 2006-03-04 17:49:42

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: Xorg7 Update: Permission denied to open VC?

_Gandalf_ wrote:

look at JGC comment above... it will be fixed soon...

Yes, packega is out, update but I am not lucky one. I use ati drivers and now I have a problem:

failed to load "glx" (module does not exist,0)
dlopen: /usr/lib/xorg/modules/drivers/fglrx_drv.so undefied symbol in __glXActiveScreen
Failed load /usr/libxorg/modules/drivers/fglrx_drv.so

I did try to reinstall ATI drivers but I cannot start KDE.

Offline

#10 2006-03-04 18:10:18

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

Re: Xorg7 Update: Permission denied to open VC?

JGC wrote:

Hmm, this is caused by forgetting fakeroot when packaging the latest Xorg package. The files are owned by uid 1000 and are setuid 1000 because of this. Xorg-server-1.0.1-6.pkg.tar.gz coming right up now.

Your new package fixes the problem noted in this thread earlier, but seems to get rid of the ability to use glx extensions.

Offline

#11 2006-03-04 18:16:01

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: Xorg7 Update: Permission denied to open VC?

ralvy wrote:
JGC wrote:

Hmm, this is caused by forgetting fakeroot when packaging the latest Xorg package. The files are owned by uid 1000 and are setuid 1000 because of this. Xorg-server-1.0.1-6.pkg.tar.gz coming right up now.

Your new package fixes the problem noted in this thread earlier, but seems to get rid of the ability to use glx extensions.

...and I don't have an old package and I cannot run xserver and I cannot do my work which it need to be done and what can I do? Start a car and go to work...I am really not a lucky...  :mrgreen:

Offline

#12 2006-03-04 18:50:16

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

Re: Xorg7 Update: Permission denied to open VC?

lumiwa wrote:

...and I don't have an old package and I cannot run xserver and I cannot do my work which it need to be done and what can I do? Start a car and go to work...I am really not a lucky...  :mrgreen:

Find a mirror that has the older versions of xorg-server and libgl-dri and install them?

Offline

#13 2006-03-04 19:28:48

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Xorg7 Update: Permission denied to open VC?

Make sure you upgrade to the latest ati-drivers package also.

Another option, if you don't want to use the ati-drivers package:

cd /usr/lib/xorg/modules/extensions
ln -s libGLcore.xorg libGLcore.so
ln -s libglx.xorg libglx.so

This is what the latest libgl-dri and ati-drivers packages do in the PKGBUILD already.

Offline

#14 2006-03-04 20:26:08

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: Xorg7 Update: Permission denied to open VC?

JGC wrote:

Make sure you upgrade to the latest ati-drivers package also.

I think people who update both xorg-server and libgl-dri or ati-drivers simultaneously are experiencing the 'file moved from one package to another' problem again -- libgl-dri installs libglx.so, then xorg-server is removed (removing libglx.so) and updated (adding libglx.xorg) - end result is user has no libglx.so

Fix for anyone experiencing lack of GLX after updating both the libgl package and xorg-server: reinstall libgl-dri or ati-drivers (whichever you use)

Offline

#15 2006-03-04 20:42:29

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: Xorg7 Update: Permission denied to open VC?

Cerebral wrote:
JGC wrote:

Make sure you upgrade to the latest ati-drivers package also.

I think people who update both xorg-server and libgl-dri or ati-drivers simultaneously are experiencing the 'file moved from one package to another' problem again -- libgl-dri installs libglx.so, then xorg-server is removed (removing libglx.so) and updated (adding libglx.xorg) - end result is user has no libglx.so

Fix for anyone experiencing lack of GLX after updating both the libgl package and xorg-server: reinstall libgl-dri or ati-drivers (whichever you use)

I got an ''old" xorg-server -4 and now works as before.
What I did before? I installed xorg-server 6 and reinstalled ati drivers. It didn't works. Then I pacman -Rd ati-drivers and installed ati-drivers again and it didn't works. Than I got the "old" server and now works again with "old" ati drivers.

BTW:  I have installed ati drivers version 8.22.5-1. If I installed ATI drivers from pacman server for arch than pacman -S ati-drivers-arc than pacman installed version ati-drivers-arch 8.22.5-2 and ati-drivers 8.22.5-3 and /opt/ati is no more there (removed). Where are  now file 'fglrx_module_setup.sh? Do we don't need it anymore?

Thanks.

Offline

#16 2006-03-04 22:31:23

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: Xorg7 Update: Permission denied to open VC?

lumiwa - fglrx_module_setup.sh was something I provided with my 'kernel independent' PKGBUILDS, which were never 'official' ati-drivers pacakges.  With the official packages in [extra], this script isn't necessary.

The drivers in [extra] have seperate kernel module and xorg-module packages: ati-drivers-arch(ck) and ati-drivers respectively.  If you're using stock kernel, install ati-drivers-arch.  If you're using archck, install ati-drivers-archck. 

Make sure you get the newest versions from the extra repo, these should be ati-drivers-arch 8.22.5-2 and ati-drivers 8.22.5-4.

Offline

#17 2006-03-04 23:02:13

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

Re: Xorg7 Update: Permission denied to open VC?

Cerebral wrote:

Fix for anyone experiencing lack of GLX after updating both the libgl package and xorg-server: reinstall libgl-dri or ati-drivers (whichever you use)

This worked for me. I reinstalled libgl-dri on my i810 video system, and now I can use glx extensions.

Offline

#18 2006-03-04 23:27:17

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: Xorg7 Update: Permission denied to open VC?

Cerebral wrote:

lumiwa - fglrx_module_setup.sh was something I provided with my 'kernel independent' PKGBUILDS, which were never 'official' ati-drivers pacakges.  With the official packages in [extra], this script isn't necessary.

The drivers in [extra] have seperate kernel module and xorg-module packages: ati-drivers-arch(ck) and ati-drivers respectively.  If you're using stock kernel, install ati-drivers-arch.  If you're using archck, install ati-drivers-archck. 

Make sure you get the newest versions from the extra repo, these should be ati-drivers-arch 8.22.5-2 and ati-drivers 8.22.5-4.

Thanks. I installed pacman -S ati-drivers-arch and pacman installed ati-drivers-arch 8.22.5-2 and ati-drivers 8.22.5-3, than ln -s...and it works. With 8.22.5.-4 I got few errors and doesn;t works.

Offline

#19 2006-03-05 00:15:19

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 627
Website

Re: Xorg7 Update: Permission denied to open VC?

Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 (Permission denied)

Also had this weird answer when i wanted to startx today after a system update + shift from nv to nvidia driver.
Lost an hour & a half trying to figure out  what caused it :?
Then coming back home tonight i did another pacman -Syu that got xorg-server 1.0.1-6 installed, and everything went back to normal without touching a single conf file roll [/code]


PGP Key: 1C2A554EFF0157D9
Core i3 @3.30GHz | 4GB RAM | Arch linux-ck
Atom N450 2 gig RAM, Arch linux 4.6.0rc3 i686 (5+H battery smile) | ARM Tegra K1 4 gig RAM, Chrome OS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16.0-0.bpo.4-586 on SDHC

Offline

Board footer

Powered by FluxBB