You are not logged in.

#1 2014-11-22 21:55:20

Frabato
Member
Registered: 2007-10-24
Posts: 267

[SOLVED] can't play .dsf audio files in linux

Hi All,

A friend (who uses a mac) sent me what are supposed to be high quality audio files. The extension is .dsf. Surfing the net I found that they may be "Delusion Digital Sound Files" playable in windows with DeliPlayer, StormSky RainbowPlayer, OpenMPT and MODPlug Player but I can't anything to play them in linux. I've tried vlc and mplayer. Any clues for me?

Thanks.

Last edited by Frabato (2014-11-23 04:16:28)

Offline

#2 2014-11-22 22:02:27

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,920
Website

Re: [SOLVED] can't play .dsf audio files in linux

I'm not sure about playing - but you can convert them to something playable:
https://aur.archlinux.org/packages/dsf2flac-svn/


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2014-11-23 01:27:34

Frabato
Member
Registered: 2007-10-24
Posts: 267

Re: [SOLVED] can't play .dsf audio files in linux

Thanks, this program seems like it should do the trick but:

==> dsf2flac-svn dependencies:
 - boost-libs (already installed)
 - flac (already installed)
 - subversion (already installed)

and

CMake Error at /usr/share/cmake-3.0/Modules/FindBoost.cmake:1179 (message):
  Unable to find the requested Boost libraries.

  Unable to find the Boost header files.  Please set BOOST_ROOT to the root
  directory containing Boost or BOOST_INCLUDEDIR to the directory containing
  Boost's headers.
Call Stack (most recent call first):
  CMakeLists.txt:30 (find_package)


-- Found Ogg: /usr/lib64/libogg.so
-- Found Flac: /usr/lib64/libFLAC.so
-- Found Flac++: /usr/lib64/libFLAC++.so
-- Found Id3: /usr/lib64/libid3.so
-- Found Zlib: /usr/lib64/libz.so
-- Found Rtlib: /usr/lib64/librt.so
CMake Error: The following variables are used in this project, but they are set  
to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake file 
s:
Boost_INCLUDE_DIR (ADVANCED)
   used as include directory in directory /tmp/yaourt-tmp-a/aur-dsf2flac-svn/src 
/dsf2flac-read-only-build

-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-a/aur-dsf2flac-svn/src/dsf2flac-read-only-build/CMakeF 
iles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build dsf2flac-svn.
==> Restart building dsf2flac-svn ? [y/N]

I'm not very knowledgeable about this kind of thing, does anyone know how to fix this?

Thanks

Offline

#4 2014-11-23 01:37:50

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,920
Website

Re: [SOLVED] can't play .dsf audio files in linux

I just tried it out and got the same error - it seems two build deps were missing from the PKGBUILD: cmake + boost.  Once installed it built fine.

The PKGBUILD also uses the old svn syntax - this should be flagged out of date* and replaced.  I'll see if I can get a proper one together, but for now installing the missing dependencies should have it up and running.

EDIT: *I just flagged it directing the maintainer to this thread.  Here's a fully updated PKGBUILD:

_svnname="dsf2flac"
_svnlocal="${_svnname}-read-only"
pkgname="${_svnname}-svn"
pkgver=r53
pkgrel=1
pkgdesc="A file conversion tool for translating dsf and dff dsd audio files into flac pcm audio files."
arch=('i686' 'x86_64')
url="https://code.google.com/p/dsf2flac"
license=('GPL3')
depends=('boost-libs' 'flac' 'id3lib')
makedepends=('boost' 'cmake' 'subversion')
source=("${_svnlocal}::svn+http://dsf2flac.googlecode.com/svn/trunk/")
sha256sums=('SKIP')

prepare() {
  cd "${srcdir}/${_svnlocal}"
  sed -i 's/static 1/static 0/' CMakeLists.txt
}

pkgver() {
  cd "${srcdir}/${_svnlocal}"
  local ver="$(svnversion)"
  printf "r%s" "${ver//[[:alpha:]]}"
}

build() {
  cd "${srcdir}/${_svnlocal}"
  cmake .
  make
}

package() {
  cd "${srcdir}/${_svnlocal}"
  install -Dm755 dsf2flac "${pkgdir}/usr/bin/dsf2flac"
}

Last edited by Trilby (2014-11-23 02:03:21)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2014-11-23 02:36:31

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,912
Website

Re: [SOLVED] can't play .dsf audio files in linux

mpd plays dsf files...


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#6 2014-11-23 04:15:26

Frabato
Member
Registered: 2007-10-24
Posts: 267

Re: [SOLVED] can't play .dsf audio files in linux

Thanks Trilby, the pkgbuild worked perfectly and thanks Rasi, I'll check out mpd. I was always hesitant because it seems like a pain to set up but I see that the archwiki has all the info I need.

Cheers!

Offline

#7 2014-11-23 12:21:51

laloch
Member
Registered: 2010-02-04
Posts: 185

Re: [SOLVED] can't play .dsf audio files in linux

Hi Trilby,

Trilby wrote:

I just tried it out and got the same error - it seems two build deps were missing from the PKGBUILD: cmake + boost.  Once installed it built fine.

I've updated the PKGBUILD. Thanks.

Trilby wrote:

The PKGBUILD also uses the old svn syntax - this should be flagged out of date* and replaced.  I'll see if I can get a proper one together, but for now installing the missing dependencies should have it up and running.

The structure of the PKGBUILD conforms to the SVN PKGBUILD prototype in the abs package. I'm not going to change it now.

Last edited by laloch (2014-11-23 12:24:25)

Offline

#8 2014-11-23 12:29:26

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,920
Website

Re: [SOLVED] can't play .dsf audio files in linux

Thanks for the quick response.  Just adding the dependencies will have it fully functional again.  But the SVN PKGBUILD prototype in the ABS is known to be out of date.  You may want to check out the next section of that wiki page that covers the new source syntax.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#9 2014-11-25 22:44:06

hifi25nl
Member
Registered: 2011-05-07
Posts: 238
Website

Re: [SOLVED] can't play .dsf audio files in linux

For playing dsf files you have these options (without converting to another format one by one)

1) mpd or better mpd-dsd  (free, can play DSD files but cannot convert on the fly)
2) hqplayer (trial, it can play and eventually convert to PCM in real time)
4) jriver-media-center (trial, it can play and eventually convert to PCM in real time)
5) hqplayer-embedded (you can control and play dsf files from your smartphone with BubbleUPNP. Rygel and Minimserver must be installed on archlinux PC)

All these packages are in AUR
https://aur.archlinux.org/packages/?SeB=m&K=blackhole

Last edited by hifi25nl (2014-11-25 22:45:51)

Offline

#10 2015-04-18 23:09:34

gps1539
Member
From: Los Gatos, CA
Registered: 2013-11-06
Posts: 114

Re: [SOLVED] can't play .dsf audio files in linux

mpv can also play dsf and dff files

Offline

Board footer

Powered by FluxBB